[jira] [Commented] (GEODE-2892) Add sizeOnServer and isEmptyOnServer to Region

2017-06-01 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/GEODE-2892?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033388#comment-16033388
 ] 

ASF subversion and git services commented on GEODE-2892:


Commit badd7ae51b5a381effe09f9ea9ed828494200762 in geode's branch 
refs/heads/release/1.2.0 from [~eshu]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=badd7ae ]

GEODE-2892: Add sizeOnServer and isEmptyOnServer to Region

Implement sizeOnServer and isEmptyOnServer so that ClientRegion could get size 
on the server.

cherry-pick fbb74d8ef30269a1e40e21af0708404ad7309551 from develop


> Add sizeOnServer and isEmptyOnServer to Region
> --
>
> Key: GEODE-2892
> URL: https://issues.apache.org/jira/browse/GEODE-2892
> Project: Geode
>  Issue Type: Sub-task
>  Components: regions
>Reporter: Fred Krone
>Assignee: Eric Shu
>  Labels: storage_2
> Fix For: 1.2.0
>
>
> To lower confusion while also not breaking backwards compatibility Region 
> needs explicit "onServer" methods.
> sizeOnServer 
> isEmptyOnServer 
> These could also be named something like size(boolean localSize) to keep the 
> API a less wordy.
> ACCEPTANCE:
> When a developer uses these methods then the result should be from the 
> server-side.   This includes accessor Regions.
> JavaDocs should be updated accordingly.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (GEODE-2892) Add sizeOnServer and isEmptyOnServer to Region

2017-06-01 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/GEODE-2892?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033294#comment-16033294
 ] 

ASF subversion and git services commented on GEODE-2892:


Commit fbb74d8ef30269a1e40e21af0708404ad7309551 in geode's branch 
refs/heads/develop from [~eshu]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=fbb74d8 ]

GEODE-2892: Add sizeOnServer and isEmptyOnServer to Region

Implement sizeOnServer and isEmptyOnServer so that ClientRegion could get size 
on the server.


> Add sizeOnServer and isEmptyOnServer to Region
> --
>
> Key: GEODE-2892
> URL: https://issues.apache.org/jira/browse/GEODE-2892
> Project: Geode
>  Issue Type: Sub-task
>  Components: regions
>Reporter: Fred Krone
>Assignee: Eric Shu
>  Labels: storage_2
> Fix For: 1.2.0
>
>
> To lower confusion while also not breaking backwards compatibility Region 
> needs explicit "onServer" methods.
> sizeOnServer 
> isEmptyOnServer 
> These could also be named something like size(boolean localSize) to keep the 
> API a less wordy.
> ACCEPTANCE:
> When a developer uses these methods then the result should be from the 
> server-side.   This includes accessor Regions.
> JavaDocs should be updated accordingly.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)