Vladimir Ozerov created IGNITE-3527:
---------------------------------------

             Summary: IGFS: Review "rename", "delete" and "mkdirs" return types 
in IgniteFileSystem and IgfsSecondaryFileSystem:
                 Key: IGNITE-3527
                 URL: https://issues.apache.org/jira/browse/IGNITE-3527
             Project: Ignite
          Issue Type: Task
          Components: IGFS
    Affects Versions: 1.6
            Reporter: Vladimir Ozerov
             Fix For: 2.0


Currently their semantics are not clear:
- boolean delete()
- void mkdirs()
- void rename();

They all must have the same return type and semantics. The question is which 
semantics to choose:
1) Return boolean and (almost) never throw exceptions. This is "JDK way". I 
personally do not like it because user will have to both check for true/false 
and use try/catch.
2) Return void and throw exception if something went wrong. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to