[jira] [Updated] (LUCENE-3464) Rename IndexReader.reopen to make it clear that reopen may not happen

2011-11-21 Thread Robert Muir (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/LUCENE-3464?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Robert Muir updated LUCENE-3464:


Attachment: LUCENE-3464_see_its_just_fine.patch

Thats no problem, it just calls super.doOpenIfChanged, see my proof of concept.

 Rename IndexReader.reopen to make it clear that reopen may not happen
 -

 Key: LUCENE-3464
 URL: https://issues.apache.org/jira/browse/LUCENE-3464
 Project: Lucene - Java
  Issue Type: Bug
Reporter: Michael McCandless
Assignee: Michael McCandless
 Fix For: 3.5, 4.0

 Attachments: LUCENE-3464.3x.patch, LUCENE-3464.patch, 
 LUCENE-3464.patch, LUCENE-3464_see_its_just_fine.patch


 Spinoff from LUCENE-3454 where Shai noted this inconsistency.
 IR.reopen sounds like an unconditional operation, which has trapped users in 
 the past into always closing the old reader instead of only closing it if the 
 returned reader is new.
 I think this hidden maybe-ness is trappy and we should rename it 
 (maybeReopen?  reopenIfNeeded?).
 In addition, instead of returning this when the reopen didn't happen, I 
 think we should return null to enforce proper usage of the maybe-ness of this 
 API.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Updated] (LUCENE-3464) Rename IndexReader.reopen to make it clear that reopen may not happen

2011-10-03 Thread Michael McCandless (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/LUCENE-3464?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Michael McCandless updated LUCENE-3464:
---

Attachment: LUCENE-3464.3x.patch

Tentative 3.x patch.

I had to whip out VirtualMethod for back compat would appreciate a review 
that I did this correctly!  Heavy guns.

 Rename IndexReader.reopen to make it clear that reopen may not happen
 -

 Key: LUCENE-3464
 URL: https://issues.apache.org/jira/browse/LUCENE-3464
 Project: Lucene - Java
  Issue Type: Bug
Reporter: Michael McCandless
Assignee: Michael McCandless
 Fix For: 3.5, 4.0

 Attachments: LUCENE-3464.3x.patch, LUCENE-3464.patch, 
 LUCENE-3464.patch


 Spinoff from LUCENE-3454 where Shai noted this inconsistency.
 IR.reopen sounds like an unconditional operation, which has trapped users in 
 the past into always closing the old reader instead of only closing it if the 
 returned reader is new.
 I think this hidden maybe-ness is trappy and we should rename it 
 (maybeReopen?  reopenIfNeeded?).
 In addition, instead of returning this when the reopen didn't happen, I 
 think we should return null to enforce proper usage of the maybe-ness of this 
 API.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Updated] (LUCENE-3464) Rename IndexReader.reopen to make it clear that reopen may not happen

2011-09-30 Thread Michael McCandless (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/LUCENE-3464?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Michael McCandless updated LUCENE-3464:
---

Attachment: LUCENE-3464.patch

New patch, cutting over to IndexReader.openIfChanged(oldReader) static
methods... I like this much better since it in no way implies the old
reader is reopened / altered in place.  It returns null if there is no
change to the index.  I think it's ready!


 Rename IndexReader.reopen to make it clear that reopen may not happen
 -

 Key: LUCENE-3464
 URL: https://issues.apache.org/jira/browse/LUCENE-3464
 Project: Lucene - Java
  Issue Type: Bug
Reporter: Michael McCandless
Assignee: Michael McCandless
 Fix For: 3.5, 4.0

 Attachments: LUCENE-3464.patch, LUCENE-3464.patch


 Spinoff from LUCENE-3454 where Shai noted this inconsistency.
 IR.reopen sounds like an unconditional operation, which has trapped users in 
 the past into always closing the old reader instead of only closing it if the 
 returned reader is new.
 I think this hidden maybe-ness is trappy and we should rename it 
 (maybeReopen?  reopenIfNeeded?).
 In addition, instead of returning this when the reopen didn't happen, I 
 think we should return null to enforce proper usage of the maybe-ness of this 
 API.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Updated] (LUCENE-3464) Rename IndexReader.reopen to make it clear that reopen may not happen

2011-09-26 Thread Michael McCandless (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/LUCENE-3464?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Michael McCandless updated LUCENE-3464:
---

Attachment: LUCENE-3464.patch

Patch, changing to .reopenIfChanged.

Still wondering about IR.openIfChanged though

 Rename IndexReader.reopen to make it clear that reopen may not happen
 -

 Key: LUCENE-3464
 URL: https://issues.apache.org/jira/browse/LUCENE-3464
 Project: Lucene - Java
  Issue Type: Bug
Reporter: Michael McCandless
Assignee: Michael McCandless
 Fix For: 3.5, 4.0

 Attachments: LUCENE-3464.patch


 Spinoff from LUCENE-3454 where Shai noted this inconsistency.
 IR.reopen sounds like an unconditional operation, which has trapped users in 
 the past into always closing the old reader instead of only closing it if the 
 returned reader is new.
 I think this hidden maybe-ness is trappy and we should rename it 
 (maybeReopen?  reopenIfNeeded?).
 In addition, instead of returning this when the reopen didn't happen, I 
 think we should return null to enforce proper usage of the maybe-ness of this 
 API.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org