Re: Review Request 64365: RANGER-1916:Remove duplicate code and optimize code in AtlasClient.class

2017-12-06 Thread Ramesh Mani

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/64365/#review193086
---


Ship it!




Ship It!

- Ramesh Mani


On Dec. 6, 2017, 7:53 a.m., pengjianhua wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/64365/
> ---
> 
> (Updated Dec. 6, 2017, 7:53 a.m.)
> 
> 
> Review request for ranger, Alok Lal, Ankita Sinha, Don Bosco Durai, Colm O 
> hEigeartaigh, Gautam Borad, Madhan Neethiraj, Ramesh Mani, Selvamohan 
> Neethiraj, Velmurugan Periasamy, and Qiang Zhang.
> 
> 
> Bugs: RANGER-1916
> https://issues.apache.org/jira/browse/RANGER-1916
> 
> 
> Repository: ranger
> 
> 
> Description
> ---
> 
> Remove duplicate code and optimize code in AtlasClient.class
> The follow code
> “if (client != null)
> { client.destroy(); }
> ” 
> in connectionTestResource and connectionTestResource method has been declared 
> and execute in the getResourceList method that called them ,so remove 
> duplicate code,And change the code "AtlasClient AtlasClient = null;" to 
> "AtlasClient atlasClient = null;"
> 
> 
> Diffs
> -
> 
>   
> plugin-atlas/src/main/java/org/apache/ranger/services/atlas/client/AtlasClient.java
>  857df87 
> 
> 
> Diff: https://reviews.apache.org/r/64365/diff/1/
> 
> 
> Testing
> ---
> 
> Tested it.
> 
> 
> Thanks,
> 
> pengjianhua
> 
>



Re: Review Request 64365: RANGER-1916:Remove duplicate code and optimize code in AtlasClient.class

2017-12-06 Thread Qiang Zhang

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/64365/#review193030
---


Ship it!




Ship It!

- Qiang Zhang


On 十二月 6, 2017, 7:53 a.m., pengjianhua wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/64365/
> ---
> 
> (Updated 十二月 6, 2017, 7:53 a.m.)
> 
> 
> Review request for ranger, Alok Lal, Ankita Sinha, Don Bosco Durai, Colm O 
> hEigeartaigh, Gautam Borad, Madhan Neethiraj, Ramesh Mani, Selvamohan 
> Neethiraj, Velmurugan Periasamy, and Qiang Zhang.
> 
> 
> Bugs: RANGER-1916
> https://issues.apache.org/jira/browse/RANGER-1916
> 
> 
> Repository: ranger
> 
> 
> Description
> ---
> 
> Remove duplicate code and optimize code in AtlasClient.class
> The follow code
> “if (client != null)
> { client.destroy(); }
> ” 
> in connectionTestResource and connectionTestResource method has been declared 
> and execute in the getResourceList method that called them ,so remove 
> duplicate code,And change the code "AtlasClient AtlasClient = null;" to 
> "AtlasClient atlasClient = null;"
> 
> 
> Diffs
> -
> 
>   
> plugin-atlas/src/main/java/org/apache/ranger/services/atlas/client/AtlasClient.java
>  857df87 
> 
> 
> Diff: https://reviews.apache.org/r/64365/diff/1/
> 
> 
> Testing
> ---
> 
> Tested it.
> 
> 
> Thanks,
> 
> pengjianhua
> 
>



Re: Review Request 64365: RANGER-1916:Remove duplicate code and optimize code in AtlasClient.class

2017-12-06 Thread Colm O hEigeartaigh

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/64365/#review192982
---


Ship it!




Ship It!

- Colm O hEigeartaigh


On Dec. 6, 2017, 7:53 a.m., pengjianhua wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/64365/
> ---
> 
> (Updated Dec. 6, 2017, 7:53 a.m.)
> 
> 
> Review request for ranger, Alok Lal, Ankita Sinha, Don Bosco Durai, Colm O 
> hEigeartaigh, Gautam Borad, Madhan Neethiraj, Ramesh Mani, Selvamohan 
> Neethiraj, Velmurugan Periasamy, and Qiang Zhang.
> 
> 
> Bugs: RANGER-1916
> https://issues.apache.org/jira/browse/RANGER-1916
> 
> 
> Repository: ranger
> 
> 
> Description
> ---
> 
> Remove duplicate code and optimize code in AtlasClient.class
> The follow code
> “if (client != null)
> { client.destroy(); }
> ” 
> in connectionTestResource and connectionTestResource method has been declared 
> and execute in the getResourceList method that called them ,so remove 
> duplicate code,And change the code "AtlasClient AtlasClient = null;" to 
> "AtlasClient atlasClient = null;"
> 
> 
> Diffs
> -
> 
>   
> plugin-atlas/src/main/java/org/apache/ranger/services/atlas/client/AtlasClient.java
>  857df87 
> 
> 
> Diff: https://reviews.apache.org/r/64365/diff/1/
> 
> 
> Testing
> ---
> 
> Tested it.
> 
> 
> Thanks,
> 
> pengjianhua
> 
>



Review Request 64365: RANGER-1916:Remove duplicate code and optimize code in AtlasClient.class

2017-12-05 Thread pengjianhua

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/64365/
---

Review request for ranger, Alok Lal, Ankita Sinha, Don Bosco Durai, Colm O 
hEigeartaigh, Gautam Borad, Madhan Neethiraj, Ramesh Mani, Selvamohan 
Neethiraj, Velmurugan Periasamy, and Qiang Zhang.


Bugs: RANGER-1916
https://issues.apache.org/jira/browse/RANGER-1916


Repository: ranger


Description
---

Remove duplicate code and optimize code in AtlasClient.class
The follow code
“if (client != null)
{ client.destroy(); }
” 
in connectionTestResource and connectionTestResource method has been declared 
and execute in the getResourceList method that called them ,so remove duplicate 
code,And change the code "AtlasClient AtlasClient = null;" to "AtlasClient 
atlasClient = null;"


Diffs
-

  
plugin-atlas/src/main/java/org/apache/ranger/services/atlas/client/AtlasClient.java
 857df87 


Diff: https://reviews.apache.org/r/64365/diff/1/


Testing
---

Tested it.


Thanks,

pengjianhua