Re: [dev-context] 2 patches for grph-inc

2012-10-21 Thread Peter Münster
Hello Hans,

What do you think about these patches?

-- 
   Peter
___
dev-context mailing list
dev-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/dev-context


Re: [dev-context] 2 patches for grph-inc

2012-09-24 Thread Peter Münster
On Fri, Sep 14 2012, Aditya Mahajan wrote:

 Hans already added a generic function \setemeasure to syst-aux, that can be
 used here.

I've tried, but without success... :(

TIA for any further help,
-- 
   Peter
___
dev-context mailing list
dev-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/dev-context


Re: [dev-context] 2 patches for grph-inc

2012-09-13 Thread Peter Münster
On Fri, Sep 07 2012, Aditya Mahajan wrote:

 +   \edef\current_width{\externalfigureparameter\c!width}%
 +   \edef\current_height{\externalfigureparameter\c!height}%
 +   \def\nocrap##1{\doifnotemptyvalue{##1}{%
 +   \the\dimexpr\csname##1\endcsname\relax}}%

 It is better to use a more meaningful name. This can be a general macro that
 will be useful outside of the figure inclusion code as well.

Ok. What about \scratch_current_width, \scratch_current_height,
\scratch_nocrap ?  Or something similar...

-- 
   Peter
___
dev-context mailing list
dev-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/dev-context


Re: [dev-context] 2 patches for grph-inc

2012-09-13 Thread Aditya Mahajan

On Thu, 13 Sep 2012, Peter Münster wrote:


On Fri, Sep 07 2012, Aditya Mahajan wrote:


+   \edef\current_width{\externalfigureparameter\c!width}%
+   \edef\current_height{\externalfigureparameter\c!height}%
+   \def\nocrap##1{\doifnotemptyvalue{##1}{%
+   \the\dimexpr\csname##1\endcsname\relax}}%


It is better to use a more meaningful name. This can be a general macro that
will be useful outside of the figure inclusion code as well.


Ok. What about \scratch_current_width, \scratch_current_height,
\scratch_nocrap ?  Or something similar...


Hans already added a generic function \setemeasure to syst-aux, that can 
be used here.


Note that a simple \doifnotemptyvalue is not enough. I can pass values
like 'fit', 'max', etc to height and width keys, so you must check if what 
is being passed is a dimension before calling \dimexpr.


Aditya___
dev-context mailing list
dev-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/dev-context


Re: [dev-context] 2 patches for grph-inc

2012-09-06 Thread Aditya Mahajan

On Fri, 7 Sep 2012, Peter Münster wrote:


2.) To avoid crap in the width and height options:

--8---cut here---start-8---
--- grph-inc.mkiv~  2012-07-20 23:26:52.0 +0200
+++ grph-inc.mkiv   2012-08-01 00:02:23.851094854 +0200
@@ -293,6 +293,10 @@
   %
   \the\t_grph_include_local_settings
   \dostarttagged\t!image\empty
+   \edef\current_width{\externalfigureparameter\c!width}%
+   \edef\current_height{\externalfigureparameter\c!height}%
+   \def\nocrap##1{\doifnotemptyvalue{##1}{%
+   \the\dimexpr\csname##1\endcsname\relax}}%


It is better to use a more meaningful name. This can be a general macro 
that will be useful outside of the figure inclusion code as well.



   \ctxlua{figures.push {
name   = \p_grph_include_name,
label  = \p_grph_include_label,
@@ -312,8 +316,8 @@
resolution = \externalfigureparameter\c!resolution,
color  = 
\internalspotcolorparent{\externalfigureparameter\c!color}, % hack is needed
[repeat] = \externalfigureparameter\c!repeat,
-width  = \externalfigureparameter\c!width,  % can be crap
-height = \externalfigureparameter\c!height, % can be crap
+width  = \nocrap{current_width},  % no more crap
+height = \nocrap{current_height}, % no more crap
} }%


Aditya___
dev-context mailing list
dev-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/dev-context