Re: [xwiki-devs] Onboarding feedback

2018-04-20 Thread Sergiu Dumitriu
On 04/19/2018 06:50 AM, Vincent Massol wrote:
> Thanks for the feedback Adel
> 
>> On 19 Apr 2018, at 11:05, Adel Atallah  wrote:
>>
>> Hello everyone,
>>
>> I've been following the onboarding tracks 1 and 2 on the past days, here is
>> what I can say:
>> The first track really helped me to get started in XWiki contributions as I
>> could easily pick a jira issue to work on. The issue description was clear
>> even though we had to discuss it on the chat. Speaking of the chat, it has
>> been a very valuable tool, people have been very responsive and I was
>> rarely stuck. I found the development practice a bit inconvenient at first,
>> having to make changes in the vm files of my XWiki instance and then report
>> the changes to the sources. I would have love to see a way to link my
>> source files (especially for vm/js/css files) with the one of my XWiki
>> instance to avoid errors when I copy past my changes (and get benefit of my
>> git ecosystem).
> 
> 
> For XAR dev I’d really like to have a “mvn xar:push” and “mvn xar:pull” mojos 
> to sync your XML with an XWiki instance.

Sounds like you want this:

https://github.com/xwiki/xwiki-commons/compare/master...sebialex:GetMojo

> We could imagine something similar for template files.
> 
> Thanks
> -Vincent
> 
> 
>> The second track is a good introduction to some XWiki concepts, I don't
>> have much to say for this one. A link to a real application could maybe
>> give a better understanding.
>>
>> Thanks again for the help I had!
>>
>>  *Adel Atallah*
>> *Product developer intern*
>> adel.atal...@xwiki.com 
>> tel: +33 (0)6 12 96 35 06
> 


-- 
Sergiu Dumitriu
http://purl.org/net/sergiu


Re: [xwiki-devs] [Discussion] Coding practice for location of internal package name

2018-04-20 Thread Sergiu Dumitriu
+1 to what Eduard said.

On 04/20/2018 05:34 AM, Eduard Moraru wrote:
> +1 for the definition of "module" (in "module name") as general maven
> module and not only top level modules.
> 
> i.e. a package name
> "org.xwiki.module.submodule1.submodule2.submoduleN.*internal*.package1.package2.packageN"
> corresponding to a maven artifact with ID
> "org.xwiki.module.submodule1.submodule2.submoduleN".
> 
> Thanks,
> Eduard
> 
> On Wed, Apr 18, 2018 at 7:59 PM, Thomas Mortagne 
> wrote:
> 
>> On Wed, Apr 18, 2018 at 6:43 PM, Clément Aubin 
>> wrote:
>>> Hi devs,
>>>
>>> On 04/18/2018 10:45 AM, Marius Dumitru Florea wrote:
 I think I prefer having the internal package closer to the root (so that
 it's easier to spot it) but I may have made the same "error" like
>> Guillaume
 and Thomas in the past.
>>>
>>> IMO, the current rule is incomplete as we do not take into account
>>> submodules (which are the root cause of this conversation).
>>>
>>> In the example given by Vincent, the package
>>> org.xwiki.notifications.preferences.internal is part of the module
>>> xwiki-platform-notifications-preferences : if we consider that the name
>>> of the module is notification-preferences, then it's logical to put the
>>> internal subpackage here.
>>>
>>> Note that this is the same idea for org.xwiki.job.handler.internal,
>>> which is in the submodule xwiki-platform-job-handler.
>>
>> Yep that's the idea.
>>
>> The rule I usually apply IS "org.xwiki.(module name).internal." from
>> my point of view or to me more accurate the rule way I see it would be
>> better described as "everything in the module have the same package
>> prefix" so "org.xwiki.job.handler" in that example. The thing is you
>> interpret "module name" as "top level module name" which I don't
>> really agree with.
>> http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/
>> JavaCodeStyle/#HPackagenames
>> is not really explicit about submodules in practice.
>>
>>>
>>> We then have to choose either to accept this format or totally discard
>>> submodules.
>>>
 On Mon, Apr 16, 2018 at 7:28 PM, Vincent Massol 
>> wrote:

> Hi devs,
>
> On Matrix/IRC, I’ve posted the following:
>
> "
> * Guillaume Delhumeau: BTW your naming is strange for the internal
>> package
> * for ex: package org.xwiki.notifications.preferences.internal.email;
> * normally we put internal just after the main package part
> * ie.
> * org.xwiki.notifications.internal.*
> * and org.xwiki.notifications.* for public classes
> * see http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/
> JavaCodeStyle/#HPackagenames
> * General rule is org.xwiki.(module name).internal.
> * I see thomas has done the same “error" for
> org.xwiki.job.handler.internal and org.xwiki.job.handler.
>> internal.question
> . So maybe there's something to discuss/change
> * I guess we have a mix of both now so we should discuss it and adjust
>> our
> rules if need be
> “
>
> So I think we don’t have all the same rules/understanding of the
> definition at http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/
> JavaCodeStyle/#HPackagenames
>
> I’d like to discuss with you to see what you prefer and adjust our
>> rules
> so that it matches what we do in practice.
>
> Any take in this?
>
> Thanks
> -Vincent
>>
>>
>>
>> --
>> Thomas Mortagne
>>


-- 
Sergiu Dumitriu
http://purl.org/net/sergiu


Re: [xwiki-devs] [Discussion] Coding practice for location of internal package name

2018-04-20 Thread Eduard Moraru
+1 for the definition of "module" (in "module name") as general maven
module and not only top level modules.

i.e. a package name
"org.xwiki.module.submodule1.submodule2.submoduleN.*internal*.package1.package2.packageN"
corresponding to a maven artifact with ID
"org.xwiki.module.submodule1.submodule2.submoduleN".

Thanks,
Eduard

On Wed, Apr 18, 2018 at 7:59 PM, Thomas Mortagne 
wrote:

> On Wed, Apr 18, 2018 at 6:43 PM, Clément Aubin 
> wrote:
> > Hi devs,
> >
> > On 04/18/2018 10:45 AM, Marius Dumitru Florea wrote:
> >> I think I prefer having the internal package closer to the root (so that
> >> it's easier to spot it) but I may have made the same "error" like
> Guillaume
> >> and Thomas in the past.
> >
> > IMO, the current rule is incomplete as we do not take into account
> > submodules (which are the root cause of this conversation).
> >
> > In the example given by Vincent, the package
> > org.xwiki.notifications.preferences.internal is part of the module
> > xwiki-platform-notifications-preferences : if we consider that the name
> > of the module is notification-preferences, then it's logical to put the
> > internal subpackage here.
> >
> > Note that this is the same idea for org.xwiki.job.handler.internal,
> > which is in the submodule xwiki-platform-job-handler.
>
> Yep that's the idea.
>
> The rule I usually apply IS "org.xwiki.(module name).internal." from
> my point of view or to me more accurate the rule way I see it would be
> better described as "everything in the module have the same package
> prefix" so "org.xwiki.job.handler" in that example. The thing is you
> interpret "module name" as "top level module name" which I don't
> really agree with.
> http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/
> JavaCodeStyle/#HPackagenames
> is not really explicit about submodules in practice.
>
> >
> > We then have to choose either to accept this format or totally discard
> > submodules.
> >
> >> On Mon, Apr 16, 2018 at 7:28 PM, Vincent Massol 
> wrote:
> >>
> >>> Hi devs,
> >>>
> >>> On Matrix/IRC, I’ve posted the following:
> >>>
> >>> "
> >>> * Guillaume Delhumeau: BTW your naming is strange for the internal
> package
> >>> * for ex: package org.xwiki.notifications.preferences.internal.email;
> >>> * normally we put internal just after the main package part
> >>> * ie.
> >>> * org.xwiki.notifications.internal.*
> >>> * and org.xwiki.notifications.* for public classes
> >>> * see http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/
> >>> JavaCodeStyle/#HPackagenames
> >>> * General rule is org.xwiki.(module name).internal.
> >>> * I see thomas has done the same “error" for
> >>> org.xwiki.job.handler.internal and org.xwiki.job.handler.
> internal.question
> >>> . So maybe there's something to discuss/change
> >>> * I guess we have a mix of both now so we should discuss it and adjust
> our
> >>> rules if need be
> >>> “
> >>>
> >>> So I think we don’t have all the same rules/understanding of the
> >>> definition at http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/
> >>> JavaCodeStyle/#HPackagenames
> >>>
> >>> I’d like to discuss with you to see what you prefer and adjust our
> rules
> >>> so that it matches what we do in practice.
> >>>
> >>> Any take in this?
> >>>
> >>> Thanks
> >>> -Vincent
>
>
>
> --
> Thomas Mortagne
>