[PATCH 0210/1285] Replace numeric parameter like 0444 with macro

2016-08-03 Thread Krzysztof Kozlowski
On Tue, Aug 02, 2016 at 06:50:01PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the 
> corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
> 
> Signed-off-by: Chuansheng Liu 
> Signed-off-by: Baole Ni 
> ---
>  drivers/gpu/drm/qxl/qxl_drv.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

I got almost 1000 patches out of your mail bomb. For all of them: NACK.
Other people pointed actual reasons (title, readability, cc-list). The
commit msg should be also written in a more readable way.

Anyway, in Intel there are a lot of people having kernel contributions
so it is a shame that you didn't ask them for advice how to do it...

BR,
Krzysztof


[PATCH 0210/1285] Replace numeric parameter like 0444 with macro

2016-08-02 Thread Baole Ni
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the 
corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu 
Signed-off-by: Baole Ni 
---
 drivers/gpu/drm/qxl/qxl_drv.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/qxl/qxl_drv.c b/drivers/gpu/drm/qxl/qxl_drv.c
index dc9df5f..f62a099 100644
--- a/drivers/gpu/drm/qxl/qxl_drv.c
+++ b/drivers/gpu/drm/qxl/qxl_drv.c
@@ -51,10 +51,10 @@ static int qxl_modeset = -1;
 int qxl_num_crtc = 4;

 MODULE_PARM_DESC(modeset, "Disable/Enable modesetting");
-module_param_named(modeset, qxl_modeset, int, 0400);
+module_param_named(modeset, qxl_modeset, int, S_IRUSR);

 MODULE_PARM_DESC(num_heads, "Number of virtual crtcs to expose (default 4)");
-module_param_named(num_heads, qxl_num_crtc, int, 0400);
+module_param_named(num_heads, qxl_num_crtc, int, S_IRUSR);

 static struct drm_driver qxl_driver;
 static struct pci_driver qxl_pci_driver;
-- 
2.9.2