Re: [PATCH 10/14] dt-bindings: power: supply: Add Mediatek MT6370 Charger binding documentation

2022-06-02 Thread ChiaEn Wu
Hi Krzysztof,

Thank you for the valuable suggestion.
Sorry for sending the same email again. I forgot to reply to everyone
in my last email..

Krzysztof Kozlowski  於 2022年6月1日 週三 上午4:15寫道:
>
> On 31/05/2022 12:42, ChiaEn Wu wrote:
> > From: ChiaEn Wu 
> >
>
> Subject - remove "binding documentation". It's already implied by prefix.
>
> > Add Mediatek MT6370 Charger binding documentation.
> >
> > Signed-off-by: ChiaEn Wu 
> > ---
> >  .../power/supply/mediatek,mt6370-charger.yaml | 60 +++
> >  1 file changed, 60 insertions(+)
> >  create mode 100644 
> > Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> >
> > diff --git 
> > a/Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> >  
> > b/Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> > new file mode 100644
> > index ..9d5c4487ca9c
> > --- /dev/null
> > +++ 
> > b/Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> > @@ -0,0 +1,60 @@
> > +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> > +%YAML 1.2
> > +---
> > +$id: 
> > http://devicetree.org/schemas/power/supply/mediatek,mt6370-charger.yaml#
> > +$schema: http://devicetree.org/meta-schemas/core.yaml#
> > +
> > +title: Mediatek MT6370 Battery Charger
> > +
> > +maintainers:
> > +  - ChiaEn Wu 
> > +
> > +description: |
> > +  This module is part of the MT6370 MFD device.
> > +  Provides Battery Charger, Boost for OTG devices and BC1.2 detection.
> > +
> > +properties:
> > +  compatible:
> > +const: mediatek,mt6370-charger
> > +
> > +  interrupts:
> > +description: |
> > +  Specify what irqs are needed to be handled by MT6370 Charger driver. 
> > IRQ
> > +  "MT6370_IRQ_CHG_MIVR", "MT6370_IRQ_ATTACH" and 
> > "MT6370_IRQ_OVPCTRL_UVP_D"
> > +  are required.
> > +items:
> > +  - description: BC1.2 done irq for mt6370 charger
> > +  - description: usb plug in irq for mt6370 charger
> > +  - description: mivr irq for mt6370 charger
>
> s/for mt6370 charger//
> in each item

I got it, this will be refined in the next version. Thanks!

>
> > +
> > +  interrupt-names:
> > +items:
> > +  - const: attach_i
> > +  - const: uvp_d_evt
> > +  - const: mivr
> > +
> > +  io-channels:
> > +description: |
> > +  Use ADC channel to read vbus, ibus, ibat, etc., info. Ibus ADC 
> > channel
> > +  is required.
>
> Constraints (e.g. maxItems) are needed.

OK, I will add them in the new version!

>
> > +
> > +  usb-otg-vbus:
>
> Let's keep the same name as in MT6360:
>
> usb-otg-vbus-regulator

I'll change the name to correspond with MT6360 in the next patch, thanks!

> > +type: object
> > +description: OTG boost regulator.
> > +$ref: /schemas/regulator/regulator.yaml#
> > +
> > +properties:
> > +  enable-gpio:
> > +maxItems: 1
> > +description: |
> > +  Specify a valid 'enable' gpio for the regulator and it's optional
>
> This description is pointless - does not bring any more information. You
> repeat the schema. Please, avoid such descriptions.

I got it, I will remove them in the next patch.

>
> > +
> > +required:
> > +  - compatible
> > +  - interrupts
> > +  - interrupt-names
> > +  - io-channels
> > +
> > +additionalProperties: false
>
>
> How about example? Or is it going to be in MFD schema?

All of MT6370 binding documentation examples are in the MFD schema! Thanks.

>
>
> Best regards,
> Krzysztof

Best regards,
ChiaEn Wu


Re: [PATCH 10/14] dt-bindings: power: supply: Add Mediatek MT6370 Charger binding documentation

2022-05-31 Thread Krzysztof Kozlowski
On 31/05/2022 12:42, ChiaEn Wu wrote:
> From: ChiaEn Wu 
> 

Subject - remove "binding documentation". It's already implied by prefix.

> Add Mediatek MT6370 Charger binding documentation.
> 
> Signed-off-by: ChiaEn Wu 
> ---
>  .../power/supply/mediatek,mt6370-charger.yaml | 60 +++
>  1 file changed, 60 insertions(+)
>  create mode 100644 
> Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> 
> diff --git 
> a/Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml 
> b/Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> new file mode 100644
> index ..9d5c4487ca9c
> --- /dev/null
> +++ 
> b/Documentation/devicetree/bindings/power/supply/mediatek,mt6370-charger.yaml
> @@ -0,0 +1,60 @@
> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/power/supply/mediatek,mt6370-charger.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Mediatek MT6370 Battery Charger
> +
> +maintainers:
> +  - ChiaEn Wu 
> +
> +description: |
> +  This module is part of the MT6370 MFD device.
> +  Provides Battery Charger, Boost for OTG devices and BC1.2 detection.
> +
> +properties:
> +  compatible:
> +const: mediatek,mt6370-charger
> +
> +  interrupts:
> +description: |
> +  Specify what irqs are needed to be handled by MT6370 Charger driver. 
> IRQ
> +  "MT6370_IRQ_CHG_MIVR", "MT6370_IRQ_ATTACH" and 
> "MT6370_IRQ_OVPCTRL_UVP_D"
> +  are required.
> +items:
> +  - description: BC1.2 done irq for mt6370 charger
> +  - description: usb plug in irq for mt6370 charger
> +  - description: mivr irq for mt6370 charger

s/for mt6370 charger//
in each item

> +
> +  interrupt-names:
> +items:
> +  - const: attach_i
> +  - const: uvp_d_evt
> +  - const: mivr
> +
> +  io-channels:
> +description: |
> +  Use ADC channel to read vbus, ibus, ibat, etc., info. Ibus ADC channel
> +  is required.

Constraints (e.g. maxItems) are needed.

> +
> +  usb-otg-vbus:

Let's keep the same name as in MT6360:

usb-otg-vbus-regulator
> +type: object
> +description: OTG boost regulator.
> +$ref: /schemas/regulator/regulator.yaml#
> +
> +properties:
> +  enable-gpio:
> +maxItems: 1
> +description: |
> +  Specify a valid 'enable' gpio for the regulator and it's optional

This description is pointless - does not bring any more information. You
repeat the schema. Please, avoid such descriptions.

> +
> +required:
> +  - compatible
> +  - interrupts
> +  - interrupt-names
> +  - io-channels
> +
> +additionalProperties: false


How about example? Or is it going to be in MFD schema?


Best regards,
Krzysztof