Re: [PATCH v1 30/35] drm/sun4i: tv: Rename error label

2022-07-30 Thread Jernej Škrabec
Dne petek, 29. julij 2022 ob 18:35:13 CEST je Maxime Ripard napisal(a):
> The other error labels in sun4i_tv_bind() are named after the task they
> perform (err_disable_clk to call clk_disable_unprepare for example).
> 
> However, the err_cleanup_connector is named after the calling site
> (drm_connector_init failing) and will actually cleanup the encoder. Let's
> rename it to err_cleanup_encoder to be consistent.
> 
> Signed-off-by: Maxime Ripard 

Reviewed-by: Jernej Skrabec 

Best regards,
Jernej

> 
> diff --git a/drivers/gpu/drm/sun4i/sun4i_tv.c
> b/drivers/gpu/drm/sun4i/sun4i_tv.c index 6d7e1d51569a..ad6a3739bfa9 100644
> --- a/drivers/gpu/drm/sun4i/sun4i_tv.c
> +++ b/drivers/gpu/drm/sun4i/sun4i_tv.c
> @@ -580,7 +580,7 @@ static int sun4i_tv_bind(struct device *dev, struct
> device *master, if (ret) {
>   dev_err(dev,
>   "Couldn't initialise the Composite 
connector\n");
> - goto err_cleanup_connector;
> + goto err_cleanup_encoder;
>   }
>   tv->connector.interlace_allowed = true;
> 
> @@ -588,7 +588,7 @@ static int sun4i_tv_bind(struct device *dev, struct
> device *master,
> 
>   return 0;
> 
> -err_cleanup_connector:
> +err_cleanup_encoder:
>   drm_encoder_cleanup(>encoder);
>  err_disable_clk:
>   clk_disable_unprepare(tv->clk);






[PATCH v1 30/35] drm/sun4i: tv: Rename error label

2022-07-29 Thread Maxime Ripard
The other error labels in sun4i_tv_bind() are named after the task they
perform (err_disable_clk to call clk_disable_unprepare for example).

However, the err_cleanup_connector is named after the calling site
(drm_connector_init failing) and will actually cleanup the encoder. Let's
rename it to err_cleanup_encoder to be consistent.

Signed-off-by: Maxime Ripard 

diff --git a/drivers/gpu/drm/sun4i/sun4i_tv.c b/drivers/gpu/drm/sun4i/sun4i_tv.c
index 6d7e1d51569a..ad6a3739bfa9 100644
--- a/drivers/gpu/drm/sun4i/sun4i_tv.c
+++ b/drivers/gpu/drm/sun4i/sun4i_tv.c
@@ -580,7 +580,7 @@ static int sun4i_tv_bind(struct device *dev, struct device 
*master,
if (ret) {
dev_err(dev,
"Couldn't initialise the Composite connector\n");
-   goto err_cleanup_connector;
+   goto err_cleanup_encoder;
}
tv->connector.interlace_allowed = true;
 
@@ -588,7 +588,7 @@ static int sun4i_tv_bind(struct device *dev, struct device 
*master,
 
return 0;
 
-err_cleanup_connector:
+err_cleanup_encoder:
drm_encoder_cleanup(>encoder);
 err_disable_clk:
clk_disable_unprepare(tv->clk);

-- 
b4 0.10.0-dev-49460