Re: [PATCH v3 0/3] drm/bridge: display-connector: add external supply support

2023-05-31 Thread Neil Armstrong
Hi,

On Wed, 31 May 2023 03:02:56 +0300, Dmitry Baryshkov wrote:
> On some devices the 5V pin of the HDMI connector and/or the ESD
> protection logic is powered on by a separate regulator. The dp-connector
> for such usecases provides dp-pwr supply support. Follow this example
> and make hdmi-connector support the hdmi-pwr supply.
> 
> Changes since v2:
> - Changed to use proper supply name instead of hardcoded "dp-pwr" (Neil)
> 
> [...]

Thanks, Applied to https://anongit.freedesktop.org/git/drm/drm-misc.git 
(drm-misc-next)

[1/3] dt-bindings: display: hdmi-connector: add hdmi-pwr supply
  
https://cgit.freedesktop.org/drm/drm-misc/commit/?id=41b74821751466457dc8b87606ac4d71ec568d4e
[2/3] drm/bridge: display-connector: rename dp_pwr to connector_pwr
  
https://cgit.freedesktop.org/drm/drm-misc/commit/?id=99304fd0050314a0c998c28300393ec574998db9
[3/3] drm/bridge: display-connector: handle hdmi-pwr supply
  
https://cgit.freedesktop.org/drm/drm-misc/commit/?id=6eb6b6f0a012993070b26dacb5ea1ff5fc233c18

-- 
Neil



[PATCH v3 0/3] drm/bridge: display-connector: add external supply support

2023-05-30 Thread Dmitry Baryshkov
On some devices the 5V pin of the HDMI connector and/or the ESD
protection logic is powered on by a separate regulator. The dp-connector
for such usecases provides dp-pwr supply support. Follow this example
and make hdmi-connector support the hdmi-pwr supply.

Changes since v2:
- Changed to use proper supply name instead of hardcoded "dp-pwr" (Neil)

Changes since v1:
- Changed the pin description to HDMI +5V Power
- Renamed 'connector_pwr' to simpler 'supply'
- Extracted the common supply-handling code for DP and HDMI

Dmitry Baryshkov (3):
  dt-bindings: display: hdmi-connector: add hdmi-pwr supply
  drm/bridge: display-connector: rename dp_pwr to connector_pwr
  drm/bridge: display-connector: handle hdmi-pwr supply

 .../display/connector/hdmi-connector.yaml |  3 +
 drivers/gpu/drm/bridge/display-connector.c| 61 ++-
 2 files changed, 35 insertions(+), 29 deletions(-)

-- 
2.39.2