Re: [PATCH v5 0/19] backlight: backlight updates

2020-07-20 Thread Sam Ravnborg
Hi Lee.

On Mon, Jul 20, 2020 at 10:36:01AM +0100, Lee Jones wrote:
> On Sun, 19 Jul 2020, Sam Ravnborg wrote:
> 
> > Hi all.
> > 
> > Follow-up on v4 - with only a few changes listed below and
> > in the individual patches.
> > Thanks for all the reviews and the feedback on the patches!
> > 
> > I am planning a follow-up on this patchset to update the
> > backlight drivers all over to use backlight_get_brightness()
> > and backlight_is_blank() as appropriate.
> 
> [...]
> 
> > Sam Ravnborg (19):
> >   backlight: refactor fb_notifier_callback()
> >   backlight: add backlight_is_blank()
> >   backlight: improve backlight_ops documentation
> >   backlight: improve backlight_properties documentation
> >   backlight: improve backlight_device documentation
> >   backlight: document inline functions in backlight.h
> >   backlight: document enums in backlight.h
> >   backlight: remove the unused backlight_bl driver
> >   backlight: drop extern from prototypes
> >   backlight: add overview and update existing doc
> >   backlight: wire up kernel-doc documentation
> >   backlight: introduce backlight_get_brightness()
> >   backlight: as3711_bl: simplify update_status
> >   backlight: cr_bllcd: introduce gpio-backlight semantics
> >   backlight: gpio_backlight: simplify update_status()
> >   backlight: jornada720_bl: introduce backlight_is_blank()
> >   backlight: use backlight_get_brightness()
> >   backlight: drop backlight_put()
> >   backlight: make of_find_backlight static
> 
> All applied, but to be honest, that was quite painful.
That was not the intention :-(

> 
> A few notes for subsequent patches.
> 
>  - Enable spell-checkers in your editors
>- I fixed the issues up for you here - there were quite a few!
>  - Run ./checkpatch.pl before submitting - here's what I find useful
>* .git/hooks/post-commit: https://pastebin.ubuntu.com/p/WpPFd6M2rB/
>  - Please keep the in-patch changelog below the '---' line, so that it
>does not end up in the final commit log
>  - Cc: lines *above* the *-bys please
>  - Cc: lines dropped for any *-bys provided
>  - Lines wrapped ~72 chars (not 50)
>  - One whole empty line spacing between paragraphs
>  - Ensure you use the formatting expected of the subsystem - in the
>case of Backlight it's:
> 
>  : : Subject beginning with an upper-case char
> 
>A `git log --oneline -- subsystem` would give you a good idea of
>what's expected.

Thanks for the input - I will use these points as guideline for the next
batch of backlight patches.

Sam
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [PATCH v5 0/19] backlight: backlight updates

2020-07-20 Thread Lee Jones
On Sun, 19 Jul 2020, Sam Ravnborg wrote:

> Hi all.
> 
> Follow-up on v4 - with only a few changes listed below and
> in the individual patches.
> Thanks for all the reviews and the feedback on the patches!
> 
> I am planning a follow-up on this patchset to update the
> backlight drivers all over to use backlight_get_brightness()
> and backlight_is_blank() as appropriate.

[...]

> Sam Ravnborg (19):
>   backlight: refactor fb_notifier_callback()
>   backlight: add backlight_is_blank()
>   backlight: improve backlight_ops documentation
>   backlight: improve backlight_properties documentation
>   backlight: improve backlight_device documentation
>   backlight: document inline functions in backlight.h
>   backlight: document enums in backlight.h
>   backlight: remove the unused backlight_bl driver
>   backlight: drop extern from prototypes
>   backlight: add overview and update existing doc
>   backlight: wire up kernel-doc documentation
>   backlight: introduce backlight_get_brightness()
>   backlight: as3711_bl: simplify update_status
>   backlight: cr_bllcd: introduce gpio-backlight semantics
>   backlight: gpio_backlight: simplify update_status()
>   backlight: jornada720_bl: introduce backlight_is_blank()
>   backlight: use backlight_get_brightness()
>   backlight: drop backlight_put()
>   backlight: make of_find_backlight static

All applied, but to be honest, that was quite painful.

A few notes for subsequent patches.

 - Enable spell-checkers in your editors
   - I fixed the issues up for you here - there were quite a few!
 - Run ./checkpatch.pl before submitting - here's what I find useful
   * .git/hooks/post-commit: https://pastebin.ubuntu.com/p/WpPFd6M2rB/
 - Please keep the in-patch changelog below the '---' line, so that it
   does not end up in the final commit log
 - Cc: lines *above* the *-bys please
 - Cc: lines dropped for any *-bys provided
 - Lines wrapped ~72 chars (not 50)
 - One whole empty line spacing between paragraphs
 - Ensure you use the formatting expected of the subsystem - in the
   case of Backlight it's:

 : : Subject beginning with an upper-case char

   A `git log --oneline -- subsystem` would give you a good idea of
   what's expected.

-- 
lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel


[PATCH v5 0/19] backlight: backlight updates

2020-07-19 Thread Sam Ravnborg
Hi all.

Follow-up on v4 - with only a few changes listed below and
in the individual patches.
Thanks for all the reviews and the feedback on the patches!

I am planning a follow-up on this patchset to update the
backlight drivers all over to use backlight_get_brightness()
and backlight_is_blank() as appropriate.

v5:
  - Added r-b's
  - Updated cr_bllcd to use gpio-backlight semantics
  - Various editorial updates to changelogs
  - Rebased on top of Lee's backlight tree
  - Dropped "make of_find_backlight_by_node() static"
The change depends on drm-misc-next.
Will be re-send when the changes hits the backlight tree
(We could have done this in other ways, but it is easier to just wait)

v4:
  - Introduced backlight_get_brightness based on feedback from Emil.
  - Properly described the rationale behind more restrictive locking use
I checked that locking was not used outside backlight core
by renaming the lock fields.
As it is not used seems OK to restrict use to the core.
  - Introducing backlight_get_brightness invalidated
some patches and I did a bit finer split to ease review.
  - Added acks
  - A few small adjustments documented in the individual patches

v3:
  - Dropped video patch that was reviewd and thus applied
  - Updated kernel-doc so all fields now have a short intro
  - Improved readability in a lot of places, thanks to review
feedback from Daniel - thanks!
  - Added better intro to backlight
  - Added acks

Several other smaller changes documented in the
patches.
I left out patches to make functions static as
there are dependencies to drm-misc-next for these.

v2:
  - Dropped drm patches that was reviewed and thus applied (Thanks Tomi)
  - Updated backligth_is_blank() based on Daniel's feedback
  - Dropped EXPORT_SYMBOL that was no longer relevant
  - Reordered patches, so patches with no external
dependencies comes first
  - Updated the description that follows.

The following series touches a lot of backlight things.

Starts with a small refactoring in backligth.c to remove some indents.
This increases the readability and no functional changes.

Then two new helpers backlight_is_blank(), backlight_get_brightness()
are added. These helpers simplifies the implementation of update_status()
in the backlight drivers where they are used.

Then while surfing the code I missed some documentation.
So I got a bit carried away and updated the documentation
for the backlight core and added it to kernel-doc.
The documentation express my current understanding.
Everything from spelling errors to outright wrong content
shall be anticipated - so please review!
We are all best helped if the documentation is correct
and up-to-date and it is readable.

In this process I identified that the backlight_bl driver
was no longer in use - so drop it.

Everything builds, but so far no run-time testing.

Sam

Sam Ravnborg (19):
  backlight: refactor fb_notifier_callback()
  backlight: add backlight_is_blank()
  backlight: improve backlight_ops documentation
  backlight: improve backlight_properties documentation
  backlight: improve backlight_device documentation
  backlight: document inline functions in backlight.h
  backlight: document enums in backlight.h
  backlight: remove the unused backlight_bl driver
  backlight: drop extern from prototypes
  backlight: add overview and update existing doc
  backlight: wire up kernel-doc documentation
  backlight: introduce backlight_get_brightness()
  backlight: as3711_bl: simplify update_status
  backlight: cr_bllcd: introduce gpio-backlight semantics
  backlight: gpio_backlight: simplify update_status()
  backlight: jornada720_bl: introduce backlight_is_blank()
  backlight: use backlight_get_brightness()
  backlight: drop backlight_put()
  backlight: make of_find_backlight static

 Documentation/gpu/backlight.rst  |  12 +
 Documentation/gpu/index.rst  |   1 +
 drivers/video/backlight/88pm860x_bl.c|  13 +-
 drivers/video/backlight/Kconfig  |   8 -
 drivers/video/backlight/Makefile |   1 -
 drivers/video/backlight/adp5520_bl.c |  10 +-
 drivers/video/backlight/adp8860_bl.c |  10 +-
 drivers/video/backlight/adp8870_bl.c |  10 +-
 drivers/video/backlight/as3711_bl.c  |  11 +-
 drivers/video/backlight/backlight.c  | 208 +---
 drivers/video/backlight/bd6107.c |   7 +-
 drivers/video/backlight/corgi_lcd.c  |   8 +-
 drivers/video/backlight/cr_bllcd.c   |  25 +-
 drivers/video/backlight/da903x_bl.c  |  13 +-
 drivers/video/backlight/ep93xx_bl.c  |   8 +-
 drivers/video/backlight/generic_bl.c | 110 -
 drivers/video/backlight/gpio_backlight.c |  17 +-
 drivers/video/backlight/hp680_bl.c   |   6 +-
 drivers/video/backlight/jornada720_bl.c  |   2 +-
 drivers/video/backlight/kb3886_bl.c  |   6 +-
 drivers/video/backlight/led_bl.c |