[elinks-dev] Re: Feature Requests

2006-06-24 Thread Ligesh
On Fri, Jun 23, 2006 at 05:06:09AM +, Miciah Dashiel Butler Masters wrote:
 On Tue, Jun 20, 2006 at 11:52:35AM +0530, Ligesh wrote:
  On Tue, Jun 20, 2006 at 06:03:21AM +, Miciah Dashiel Butler Masters 
  wrote:
So I am talking about simple editing, for instance, in the input URL 
box. The general editing for simple data everywhere; filling in forms 
etc.
   I'll see about adding a few actions tomorrow.
  
   I am sure you know it, but the code is in the inpfield.c file. There is a 
  switch case, and you need to add one a case ACT_EDIT_KILL_WORD above the 
  ACT_EDIT_KILL_TO_BOL.
 
 There is a lot of code duplication between the general UI widgets and
 document form controls, which I would like to clean up, but I eventually
 just wrote a patch for the functionality presently under discussion:
 
 http://pasky.or.cz/gitweb.cgi?p=elinks.git;a=commit;h=29ffe71bc1b0ed6322105c1ebcb565f6793ea81e
 

 Thanks a lot. I will get the latest code. Btw, is there any chance for the 
movement system as I had explained. :-) 

 Thanks a lot.


___
elinks-dev mailing list
elinks-dev@linuxfromscratch.org
http://linuxfromscratch.org/mailman/listinfo/elinks-dev


[elinks-dev] Re: Feature Requests

2006-06-24 Thread Miciah Dashiel Butler Masters
On Fri, Jun 23, 2006 at 03:41:13PM +0530, Ligesh wrote:
 On Fri, Jun 23, 2006 at 05:06:09AM +, Miciah Dashiel Butler Masters wrote:
  On Tue, Jun 20, 2006 at 11:52:35AM +0530, Ligesh wrote:
   On Tue, Jun 20, 2006 at 06:03:21AM +, Miciah Dashiel Butler Masters 
   wrote:
 So I am talking about simple editing, for instance, in the input URL 
 box. The general editing for simple data everywhere; filling in forms 
 etc.
I'll see about adding a few actions tomorrow.
   
I am sure you know it, but the code is in the inpfield.c file. There is 
   a switch case, and you need to add one a case ACT_EDIT_KILL_WORD above 
   the ACT_EDIT_KILL_TO_BOL.
  
  There is a lot of code duplication between the general UI widgets and
  document form controls, which I would like to clean up, but I eventually
  just wrote a patch for the functionality presently under discussion:
  
  http://pasky.or.cz/gitweb.cgi?p=elinks.git;a=commit;h=29ffe71bc1b0ed6322105c1ebcb565f6793ea81e
  
 
  Yeah, I saw that. It is present in two places. The remove word works 
 beautifully. There is a very minute issue though, in the emacs remove word, 
 the delimiter is not 'space', but rather ANY meta character. So that, if we 
 have
  [...]

This should be easy enough. Should I just use isalnum instead of
isspace? Next question: Should this be configurable? We already have too
many options.

-- 
Miciah Masters [EMAIL PROTECTED] / [EMAIL PROTECTED]
___
elinks-dev mailing list
elinks-dev@linuxfromscratch.org
http://linuxfromscratch.org/mailman/listinfo/elinks-dev


[elinks-dev] Re: Feature Requests

2006-06-24 Thread Ligesh
On Sat, Jun 24, 2006 at 06:31:47AM +, Miciah Dashiel Butler Masters wrote:
 On Sat, Jun 24, 2006 at 10:48:59AM +0530, Ligesh wrote:
  On Fri, Jun 23, 2006 at 08:47:59PM +, Miciah Dashiel Butler Masters 
  wrote:
   
   This should be easy enough. Should I just use isalnum instead of
   isspace? Next question: Should this be configurable? We already have too
   many options.
  
   Yeah true. No. It is not configurable. They are separate motions 
  altogether. And the kill-word-back actually means that it will do till a 
  metachar.
 
 What do you mean? Are you asserting that because it has 'word' in the
 name, it should stop at non-alphanumeric characters?
 

 I can tell you  how it is in bash. Bash has two actions.

 backward-kill-word: This does what I had proposed. Kill a previous word till 
it reaches a metachar (non-alphanumeric).

 unix-word-rubout: This deletes the previous characters till it encounters a 
space.

 So I think in kill-word-back, it should be alnum. *If YOU want* you can 
implement a 'unix-word-rubout' too, but that's not really needed. I personally 
dislike the concept of 'unix-word-rubout'. Especially when you type in a url, 
you would want to remove the last directory, and not the entire string.

 So I presonally would prefer kill-word-back to use '!isalnum' rather than 
'isspace'. So yes, just replacing isspace, with !isalnum should fix it.

 Thanks a lot.

 

 

___
elinks-dev mailing list
elinks-dev@linuxfromscratch.org
http://linuxfromscratch.org/mailman/listinfo/elinks-dev