Re: [FFmpeg-devel] [PATCH] ffmpeg_opt: rename loop option to loop2

2015-10-14 Thread Ganesh Ajjanagadde
On Wed, Oct 14, 2015 at 2:23 PM, Michael Niedermayer  wrote:
> From: Michael Niedermayer 
>
> The "loop" option is used in several demuxers (like img2dec) and muxers, 
> using the same name in ffmpeg_opt
> breaks them. Feel free to revert this and replace by any other solution or 
> rename both as preferred
> This is just as a quick fix to avoid the regression with existing command 
> lines and to have both named
> the same (which does not work)

quick alternative (based on help text) - stream_loop in ffmpeg_opt?

>
> Example:
> ./ffmpeg -loop 1 -i fate-suite/png1/lena-rgb24.png -t 1 test.avi
> will produce 25 frames with the img2dec loop but only 1 frame at 25fps with 
> the ffmpeg loop option
>
> Signed-off-by: Michael Niedermayer 
> ---
>  ffmpeg_opt.c |2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/ffmpeg_opt.c b/ffmpeg_opt.c
> index 573da72..b99a75a 100644
> --- a/ffmpeg_opt.c
> +++ b/ffmpeg_opt.c
> @@ -3158,7 +3158,7 @@ const OptionDef options[] = {
>  { "dump_attachment", HAS_ARG | OPT_STRING | OPT_SPEC |
>   OPT_EXPERT | OPT_INPUT, { .off 
> = OFFSET(dump_attachment) },
>  "extract an attachment into a file", "filename" },
> -{ "loop", OPT_INT | HAS_ARG | OPT_EXPERT | OPT_INPUT |
> +{ "loop2", OPT_INT | HAS_ARG | OPT_EXPERT | OPT_INPUT |
>  OPT_OFFSET,  { .off 
> = OFFSET(loop) }, "set number of times input stream shall be looped", "loop 
> count" },
>  { "debug_ts",   OPT_BOOL | OPT_EXPERT,   { 
> _ts },
>  "print timestamp debugging info" },
> --
> 1.7.9.5
>
> ___
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


[FFmpeg-devel] [PATCH] ffmpeg_opt: rename loop option to loop2

2015-10-14 Thread Michael Niedermayer
From: Michael Niedermayer 

The "loop" option is used in several demuxers (like img2dec) and muxers, using 
the same name in ffmpeg_opt
breaks them. Feel free to revert this and replace by any other solution or 
rename both as preferred
This is just as a quick fix to avoid the regression with existing command lines 
and to have both named
the same (which does not work)

Example:
./ffmpeg -loop 1 -i fate-suite/png1/lena-rgb24.png -t 1 test.avi
will produce 25 frames with the img2dec loop but only 1 frame at 25fps with the 
ffmpeg loop option

Signed-off-by: Michael Niedermayer 
---
 ffmpeg_opt.c |2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/ffmpeg_opt.c b/ffmpeg_opt.c
index 573da72..b99a75a 100644
--- a/ffmpeg_opt.c
+++ b/ffmpeg_opt.c
@@ -3158,7 +3158,7 @@ const OptionDef options[] = {
 { "dump_attachment", HAS_ARG | OPT_STRING | OPT_SPEC |
  OPT_EXPERT | OPT_INPUT, { .off = 
OFFSET(dump_attachment) },
 "extract an attachment into a file", "filename" },
-{ "loop", OPT_INT | HAS_ARG | OPT_EXPERT | OPT_INPUT |
+{ "loop2", OPT_INT | HAS_ARG | OPT_EXPERT | OPT_INPUT |
 OPT_OFFSET,  { .off = 
OFFSET(loop) }, "set number of times input stream shall be looped", "loop 
count" },
 { "debug_ts",   OPT_BOOL | OPT_EXPERT,   { 
_ts },
 "print timestamp debugging info" },
-- 
1.7.9.5

___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] ffmpeg_opt: rename loop option to loop2

2015-10-14 Thread Ganesh Ajjanagadde
On Wed, Oct 14, 2015 at 3:08 PM, Michael Niedermayer
 wrote:
> On Wed, Oct 14, 2015 at 02:33:30PM -0400, Ganesh Ajjanagadde wrote:
>> On Wed, Oct 14, 2015 at 2:23 PM, Michael Niedermayer  
>> wrote:
>> > From: Michael Niedermayer 
>> >
>> > The "loop" option is used in several demuxers (like img2dec) and muxers, 
>> > using the same name in ffmpeg_opt
>> > breaks them. Feel free to revert this and replace by any other solution or 
>> > rename both as preferred
>> > This is just as a quick fix to avoid the regression with existing command 
>> > lines and to have both named
>> > the same (which does not work)
>>
>> quick alternative (based on help text) - stream_loop in ffmpeg_opt?
>
> ok, renamed and applied

docs may need updating as well. Will check and send patch tonight.

>
> [...]
> --
> Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
>
> The educated differ from the uneducated as much as the living from the
> dead. -- Aristotle
>
> ___
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] ffmpeg_opt: rename loop option to loop2

2015-10-14 Thread Michael Niedermayer
On Wed, Oct 14, 2015 at 02:33:30PM -0400, Ganesh Ajjanagadde wrote:
> On Wed, Oct 14, 2015 at 2:23 PM, Michael Niedermayer  wrote:
> > From: Michael Niedermayer 
> >
> > The "loop" option is used in several demuxers (like img2dec) and muxers, 
> > using the same name in ffmpeg_opt
> > breaks them. Feel free to revert this and replace by any other solution or 
> > rename both as preferred
> > This is just as a quick fix to avoid the regression with existing command 
> > lines and to have both named
> > the same (which does not work)
> 
> quick alternative (based on help text) - stream_loop in ffmpeg_opt?

ok, renamed and applied

[...]
-- 
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

The educated differ from the uneducated as much as the living from the
dead. -- Aristotle 


signature.asc
Description: Digital signature
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] ffmpeg_opt: rename loop option to loop2

2015-10-14 Thread Carl Eugen Hoyos
Michael Niedermayer  niedermayer.cc> writes:

> > quick alternative (based on help text) - stream_loop in ffmpeg_opt?
> 
> ok, renamed and applied

Thank you both!

Carl Eugen

___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel