Re: [FFmpeg-devel] [PATCH 4/5] Introduce ff_rtsp_averror()

2014-10-20 Thread Michael Niedermayer
On Sat, Oct 18, 2014 at 12:24:02AM +0400, Andrey Utkin wrote:
 Currently this is another name for ff_http_averror()
 ---
  libavformat/rtspcodes.h | 7 +++
  1 file changed, 7 insertions(+)

applied

thanks

[...]
-- 
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Rewriting code that is poorly written but fully understood is good.
Rewriting code that one doesnt understand is a sign that one is less smart
then the original author, trying to rewrite it will not make it better.


signature.asc
Description: Digital signature
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


[FFmpeg-devel] [PATCH 4/5] Introduce ff_rtsp_averror()

2014-10-17 Thread Andrey Utkin
Currently this is another name for ff_http_averror()
---
 libavformat/rtspcodes.h | 7 +++
 1 file changed, 7 insertions(+)

diff --git a/libavformat/rtspcodes.h b/libavformat/rtspcodes.h
index d4ae0a8..0ae490a 100644
--- a/libavformat/rtspcodes.h
+++ b/libavformat/rtspcodes.h
@@ -25,6 +25,7 @@
 #define AVFORMAT_RTSPCODES_H
 
 #include libavutil/common.h
+#include libavformat/http.h
 
 /** RTSP handling */
 enum RTSPStatusCode {
@@ -139,4 +140,10 @@ enum RTSPMethod {
 RECORD,
 UNKNOWN = -1,
 };
+
+static inline int ff_rtsp_averror(enum RTSPStatusCode status_code, int 
default_averror)
+{
+return ff_http_averror(status_code, default_averror);
+}
+
 #endif /* AVFORMAT_RTSPCODES_H */
-- 
1.8.5.5

___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel