Re: [Flightgear-devel] Good company on the list;

2008-09-26 Thread gerard robin
On jeudi 25 septembre 2008, Alex Perry wrote:
 On Thu, Sep 25, 2008 at 3:52 AM, Martin Spott [EMAIL PROTECTED] 
wrote:
  FGFS stopped building on my develop machine and I've not resolved the
  issue yet.
 
  May I expect you to increase your participation here if we're going to
  solve your trouble ?  ;-)

 Heh.  Yeah, that's why I poke at it occasionally.  Currently, the
 build finishes and an attempt to run segfaults immediately.  I haven't
 investigated further yet.  Using fgfs, simgear, osg, plib from cvs/svn
 and the rest from debian lenny on amd64.

I have had such problem with a 64 bits systems.
I noticed that .fgfsrc  which pointed to a ./fgfs/preferences.xml file was the 
cause of the segfault with a out of memory  (probably when reading that  
preferences.xml file)

The operating system was Fedora.

Since, i have installed  on that computer (which is not mine) OpenSUSE 11 
(with KDE3)  everything is right now.

Cheers

-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] key-handler system allowing many actions with only few keyboard shortcuts

2008-09-26 Thread Sébastien MARQUE
hi,

nice to read that you find the system useful, and thanks a lot to 
contribute and improve it. For now I'm very (it's a weak word) busy, so 
even if I red what you have written I've got not a minute to write a 
single code line until some weeks, but I really appreciate your opinion.

best regards,

seb

Melchior FRANZ a écrit :
 * Melchior FRANZ -- Tuesday 23 September 2008:
 The implementation is new, the idea isn't: John D. has suggested
 such a feature. (I had started implementing it, but never finished.)
 
 FWIW: I'm about to finish that, so no need to adapt your version. :-)
 
 BTW: there's now a props.runBinding() function that allows to execute
 regular bindings from Nasal. That way you can use all of the
 fgcommands in your XML config and don't need to implement all the
 actions.
 
 m.
 
 -
 This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
 Build the coolest Linux based applications with Moblin SDK  win great prizes
 Grand prize is a trip for two to an Open Source event anywhere in the world
 http://moblin-contest.org/redirect.php?banner_id=100url=/
 ___
 Flightgear-devel mailing list
 Flightgear-devel@lists.sourceforge.net
 https://lists.sourceforge.net/lists/listinfo/flightgear-devel
 
 

-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] [Flightgear-cvslogs] CVS: data/Nasal glide_slope_tunnel.nas, 1.4, 1.5

2008-09-26 Thread James Turner

On 25 Sep 2008, at 15:32, Melchior FRANZ wrote:

 I see you don't like my long_underscored_function_names [...]

 That's because we don't have a single function name with underscores.
 It's setprop, not set_prop. It's settimer, not set_timer, etc. It's
 about consistency.

Okay - is there a Nasal style guide anywhere? In the wiki perhaps? I  
find alllowercasenames rather hard to read, but obviously I'll stick  
to whatever the current convention is.

 I'm also a bit unhappy with the active in the
 name. You can't search for an active runway based on runway data. What
 is active is decided by the ATC. You can at best search for the best
 suited runway.  :-}

Well, my justification here is twofold: firstly, each of the copies of  
the code I combined to create the current implementation had a comment  
saying something like 'get the active runway' or similar. That's the  
terminology that was being used (however inaccurate) so I kept it. But  
the second point is that once Durk's code is hooked up, this really  
*will* be the ATC decided runway - since ATC will be using the same  
backend logic.

 but I'm not a fan of script functions that take (potentially) hard- 
 to-
 remember arguments:

 Nasal TNG solves that problem:

  foo = airportinfo(id:EHAM, radial:40);

Okay, excellent, named arguments are great - but perhaps airport info  
should be using them? Or is it already?

 That's assuming that the function is a wrapper for the built-in
 command.

Can you explain this part in detail? Some limitation of built-in  
commands only taking enumerated arguments?

 That's understandable. You haven't contributed a single line of Nasal
 so far, have you?  :-P

Well, there's lots of C++ to work on before I get into Nasal :)

James


-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] New nasal drop, new syntax

2008-09-26 Thread Andy Ross
Note that a reasonably big Nasal change just went into SimGear.
Melchior had a chance to test it out first, so hopefully not too much
will have broken.  The documentation for the new syntax is below.
There's also been some work done to reduce the memory footprint for
strings (store short strings inside the structure), hashes (about a
60% overhead reduction) and function closure objects (about 100 bytes
each).

As always, let me know what broke.

New syntax:

1. Call-by-name function arguments.  You can specify a hash literal in
place of ordered function arguments, and it will become the local
variable namespace for the called function, making functions with many
arguments more readable.  Ex:

   view_manager.lookat(heading:180, pitch:20, roll:0, x:X0, y:Y0, z:Z0,
   time:now, fov:55);

Declared arguments are checked and defaulted as would be expected:
it's an error if you fail to pass a value for an undefaulted argument,
missing default arguments get assigned, and any rest parameter
(e.g. func(a,b=2,rest...){}) will be assigned with an empty vector.

2. Vector slicing.  Vectors (lists) can now be created from others
using an ordered list of indexes and ranges.  For example:

   var v1 = [a,b,c,d,e]

   var v2 = v1[3,2];   # == [d,c];
   var v3 = v1[1:3];   # i.e. range from 1 to 3: [b,c,d];
   var v4 = v1[1:];# no value means to the end: [b,c,d,e]
   var i = 2;
   var v5 = v1[i]; # runtime expressions are fine: [c]
   var v6 = v1[-2,-1]; # negative indexes are relative to end: [d,e]

The range values can be computed at runtime (e.g. i=1; v5=v1[i:]).
Negative indices work the same way the do with the vector functions
(-1 is the last element, -2 is 2nd to last, etc...).

3. Multi-assignment expressions.  You can assign more than one
variable (or lvalue) at a time by putting them in a parenthesized
list:

   (var a, var b) = (1, 2);
   var (a, b) = (1, 2);   # Shorthand for (var a, var b)
   (var a, v[0], obj.field) = (1,2,3) # Any assignable lvalue works

   var color = [1, 1, 0.5];
   var (r, g, b) = color;  # works with runtime vectors too

-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] Screenshots of the coming helicopter Eurocopter EC 145

2008-09-26 Thread Matthias Boerner
Hello,

I would like to announce some screenshots of the coming helicopter
Eurocopter EC 145. The model is still not finished but I thought it
would be nice to show some pictures/screenshots made in osgviewer.

Here is the link:

http://fgfs.i-net.hu/modules/xcgal/thumbnails.php?album=44

I have to say thank you to Gabor for using his webspace on his
FlightGear tracker server.

Regards

Matthias


-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] New nasal drop, new syntax

2008-09-26 Thread Alex Perry
On Fri, Sep 26, 2008 at 11:25 AM, Andy Ross [EMAIL PROTECTED] wrote:
 Note that a reasonably big Nasal change just went into SimGear.
 As always, let me know what broke.

Negative 8-).
When I recompiled SG and FG after pulling the update in, FGFS started working.
Either there was something else that got fixed by this extra recompile
iteration,
or there is some architecture specific bug you happened to provide a fix for.

-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel