[jira] [Updated] (FOP-2788) Inconsistent method name "writeToStream"

2018-04-17 Thread KuiLIU (JIRA)

 [ 
https://issues.apache.org/jira/browse/FOP-2788?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

KuiLIU updated FOP-2788:

Attachment: rename-method-writeToStream.patch

> Inconsistent method name "writeToStream"
> 
>
> Key: FOP-2788
> URL: https://issues.apache.org/jira/browse/FOP-2788
> Project: FOP
>  Issue Type: Improvement
>Affects Versions: trunk
>Reporter: KuiLIU
>Priority: Major
> Attachments: rename-method-writeToStream.patch
>
>
> The method closes a stream, but its name is "writetoStream". The method name 
> "closeStream" should be better.
> {code:java}
>/**
>   * Tells the streamer to write
>   *
>   * @throws IOException thrown if an I/O exception of some sort has 
> occurred.
>   */
>  public void writeToStream() throws IOException {
>  streamer.close();
>  }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Updated] (FOP-2788) Inconsistent method name "writeToStream"

2018-04-17 Thread KuiLIU (JIRA)

 [ 
https://issues.apache.org/jira/browse/FOP-2788?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

KuiLIU updated FOP-2788:

Affects Version/s: trunk
  Description: 
The method closes a stream, but its name is "writetoStream". The method name 
"closeStream" should be better.


{code:java}
   /**
  * Tells the streamer to write
  *
  * @throws IOException thrown if an I/O exception of some sort has 
occurred.
  */
 public void writeToStream() throws IOException {
 streamer.close();
 }
{code}


> Inconsistent method name "writeToStream"
> 
>
> Key: FOP-2788
> URL: https://issues.apache.org/jira/browse/FOP-2788
> Project: FOP
>  Issue Type: Improvement
>Affects Versions: trunk
>Reporter: KuiLIU
>Priority: Major
>
> The method closes a stream, but its name is "writetoStream". The method name 
> "closeStream" should be better.
> {code:java}
>/**
>   * Tells the streamer to write
>   *
>   * @throws IOException thrown if an I/O exception of some sort has 
> occurred.
>   */
>  public void writeToStream() throws IOException {
>  streamer.close();
>  }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)