Re: [PATCH, rs6000] Rename variable for clarity

2021-02-23 Thread Segher Boessenkool
Hi!

On Tue, Feb 23, 2021 at 04:12:42PM -0600, Pat Haugen wrote:
> gcc/
>   * config/rs6000/rs6000.c (next_insn_prefixed_p): Rename.
>   (rs6000_final_prescan_insn): Adjust.
>   (rs6000_asm_output_opcode): Likewise.

Excellent.  Okay for trunk and 10.  Thank you!


Segher


[PATCH, rs6000] Rename variable for clarity

2021-02-23 Thread Pat Haugen via Gcc-patches
Rename next_insn_prefixed_p for improved clarity.

Bootstrap/regtest on powerpc64le with no new regressions. Ok for trunk?

-Pat


2021-02-22  Pat Haugen  

gcc/
* config/rs6000/rs6000.c (next_insn_prefixed_p): Rename.
(rs6000_final_prescan_insn): Adjust.
(rs6000_asm_output_opcode): Likewise.


diff --git a/gcc/config/rs6000/rs6000.c b/gcc/config/rs6000/rs6000.c
index ec068c58aa5..4e608073358 100644
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
@@ -26191,7 +26191,7 @@ prefixed_paddi_p (rtx_insn *insn)
 
 /* Whether the next instruction needs a 'p' prefix issued before the
instruction is printed out.  */
-static bool next_insn_prefixed_p;
+static bool prepend_p_to_next_insn;
 
 /* Define FINAL_PRESCAN_INSN if some processing needs to be done before
outputting the assembler code.  On the PowerPC, we remember if the current
@@ -26202,7 +26202,7 @@ static bool next_insn_prefixed_p;
 void
 rs6000_final_prescan_insn (rtx_insn *insn, rtx [], int)
 {
-  next_insn_prefixed_p = (get_attr_prefixed (insn) != PREFIXED_NO);
+  prepend_p_to_next_insn = (get_attr_prefixed (insn) != PREFIXED_NO);
   return;
 }
 
@@ -26212,7 +26212,7 @@ rs6000_final_prescan_insn (rtx_insn *insn, rtx [], int)
 void
 rs6000_asm_output_opcode (FILE *stream)
 {
-  if (next_insn_prefixed_p)
+  if (prepend_p_to_next_insn)
 fprintf (stream, "p");
 
   return;