zx2c4       15/01/28 13:15:08

  Modified:             ChangeLog
  Added:                pass-1.6.4.ebuild
  Removed:              pass-1.6.3.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
A5DE03AE)

Revision  Changes    Path
1.30                 app-admin/pass/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/ChangeLog?rev=1.30&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/ChangeLog?rev=1.30&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/ChangeLog?r1=1.29&r2=1.30

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/pass/ChangeLog,v
retrieving revision 1.29
retrieving revision 1.30
diff -u -r1.29 -r1.30
--- ChangeLog   21 Nov 2014 09:54:15 -0000      1.29
+++ ChangeLog   28 Jan 2015 13:15:08 -0000      1.30
@@ -1,6 +1,12 @@
 # ChangeLog for app-admin/pass
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/ChangeLog,v 1.29 2014/11/21 
09:54:15 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/ChangeLog,v 1.30 2015/01/28 
13:15:08 zx2c4 Exp $
+
+*pass-1.6.4 (28 Jan 2015)
+
+  28 Jan 2015; Jason A. Donenfeld <zx...@gentoo.org> +pass-1.6.4.ebuild,
+  -pass-1.6.3.ebuild:
+  Version bump
 
   21 Nov 2014; Tim Harder <radher...@gentoo.org> pass-1.6.3.ebuild,
   pass-9999.ebuild:



1.1                  app-admin/pass/pass-1.6.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/pass-1.6.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/pass-1.6.4.ebuild?rev=1.1&content-type=text/plain

Index: pass-1.6.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/pass-1.6.4.ebuild,v 1.1 
2015/01/28 13:15:08 zx2c4 Exp $

EAPI=4

inherit bash-completion-r1 elisp-common

DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely 
using gpg, pwgen, and git"
HOMEPAGE="http://zx2c4.com/projects/password-store/";
SRC_URI="http://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz";

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~x86-macos"
IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"

RDEPEND="
        app-crypt/gnupg
        app-admin/pwgen
        >=app-text/tree-1.7.0
        git? ( dev-vcs/git )
        X? ( x11-misc/xclip )
        elibc_Darwin? ( app-misc/getopt )
        zsh-completion? ( app-shells/gentoo-zsh-completions )
        fish-completion? ( app-shells/fish )
        dmenu? ( x11-misc/dmenu x11-misc/xdotool )
        emacs? ( virtual/emacs )
"

S="${WORKDIR}/password-store-${PV}"

src_prepare() {
        use elibc_Darwin || return
        # use coreutils'
        sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
        # host getopt isn't cool, and we aren't brew (rip out brew reference)
        sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
        # make sure we can find "mount"
        sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
}

src_compile() {
        :;
}

src_install() {
        use zsh-completion && export FORCE_ZSHCOMP=1
        use fish-completion && export FORCE_FISHCOMP=1
        emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
        use dmenu && dobin contrib/dmenu/passmenu
        newbashcomp src/completion/pass.bash-completion pass
        if use emacs; then
                elisp-install ${PN} contrib/emacs/*.el
                elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
        fi
        if use importers; then
                exeinto /usr/share/${PN}/importers
                doexe contrib/importers/*
        fi
}

pkg_postinst() {
        use emacs && elisp-site-regen
        if use importers; then
                einfo "To import passwords from other password managers, you 
may use the"
                einfo "various importer scripts found in:"
                einfo "    ${ROOT}usr/share/${PN}/importers/"
        fi
}

pkg_postrm() {
        use emacs && elisp-site-regen
}




Reply via email to