rich0       14/04/26 00:35:51

  Modified:             ChangeLog
  Added:                dar-2.4.13.ebuild
  Log:
  bump - 508688
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x08C170DE55EC123A)

Revision  Changes    Path
1.57                 app-backup/dar/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-backup/dar/ChangeLog?rev=1.57&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-backup/dar/ChangeLog?rev=1.57&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-backup/dar/ChangeLog?r1=1.56&r2=1.57

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v
retrieving revision 1.56
retrieving revision 1.57
diff -u -r1.56 -r1.57
--- ChangeLog   1 Mar 2014 22:16:10 -0000       1.56
+++ ChangeLog   26 Apr 2014 00:35:51 -0000      1.57
@@ -1,6 +1,11 @@
 # ChangeLog for app-backup/dar
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.56 2014/03/01 
22:16:10 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.57 2014/04/26 
00:35:51 rich0 Exp $
+
+*dar-2.4.13 (26 Apr 2014)
+
+  26 Apr 2014; Richard Freeman <ri...@gentoo.org> +dar-2.4.13.ebuild:
+  bump - 508688
 
   01 Mar 2014; Michał Górny <mgo...@gentoo.org> dar-2.4.10.ebuild,
   dar-2.4.11.ebuild, dar-2.4.12.ebuild, dar-2.4.2.ebuild, dar-2.4.9.ebuild:



1.1                  app-backup/dar/dar-2.4.13.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-backup/dar/dar-2.4.13.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-backup/dar/dar-2.4.13.ebuild?rev=1.1&content-type=text/plain

Index: dar-2.4.13.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.4.13.ebuild,v 1.1 
2014/04/26 00:35:51 rich0 Exp $

EAPI="5"
inherit confutils eutils flag-o-matic

DESCRIPTION="A full featured backup tool, aimed for disks 
(floppy,CDR(W),DVDR(W),zip,jazz etc.)"
HOMEPAGE="http://dar.linux.free.fr/";
SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
IUSE="acl dar32 dar64 doc gcrypt lzo nls static static-libs"

RESTRICT="test" # need to be run as root

RDEPEND=">=sys-libs/zlib-1.2.3:=
        !static? ( app-arch/bzip2:= )
        acl? ( !static? ( sys-apps/attr:= ) )
        gcrypt? ( dev-libs/libgcrypt:0= )
        lzo? ( !static? ( dev-libs/lzo:= ) )
        nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
        static? ( app-arch/bzip2[static-libs] )
        static? ( sys-libs/zlib[static-libs] )
        acl? ( static? ( sys-apps/attr[static-libs] ) )
        lzo? ( static? ( dev-libs/lzo[static-libs] ) )
        nls? ( sys-devel/gettext )
        doc? ( app-doc/doxygen )"

pkg_setup() {
        confutils_use_conflict dar32 dar64
}

src_configure() {
        local myconf="--disable-upx"

        # Bug 103741
        filter-flags -fomit-frame-pointer

        use acl || myconf="${myconf} --disable-ea-support"
        use dar32 && myconf="${myconf} --enable-mode=32"
        use dar64 && myconf="${myconf} --enable-mode=64"
        use doc || myconf="${myconf} --disable-build-html"
        # use examples && myconf="${myconf} --enable-examples"
        use gcrypt || myconf="${myconf} --disable-libgcrypt-linking"
        use lzo || myconf="${myconf} --disable-liblzo2-linking"
        use nls || myconf="${myconf} --disable-nls"
        if ! use static ; then
                myconf="${myconf} --disable-dar-static"
                if ! use static-libs ; then
                        myconf="${myconf} --disable-static"
                fi
        fi

        econf ${myconf} || die
}

src_install() {
        emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html 
install || die

        if ! use static-libs ; then
                find "${ED}" "(" -name '*.la' -o -name '*.a' ")" -delete || die
        fi

        dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
}




Reply via email to