robbat2     14/06/23 14:30:35

  Added:                xe-guest-utilities-6.2.0_p1120.ebuild
                        xe-guest-utilities-5.6.0_p595.ebuild metadata.xml
                        xe-guest-utilities-6.1.0_p1033.ebuild ChangeLog
  Log:
  Initial commit, based off Chris Camisa's work in his OpenStack overlay: 
https://github.com/Camisa/OpenStack-Overlay/tree/master/sys-cluster/xe-guest-utilities;
 I intend to proxy further commits from him.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.1                  
app-emulation/xe-guest-utilities/xe-guest-utilities-6.2.0_p1120.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-6.2.0_p1120.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-6.2.0_p1120.ebuild?rev=1.1&content-type=text/plain

Index: xe-guest-utilities-6.2.0_p1120.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-6.2.0_p1120.ebuild,v
 1.1 2014/06/23 14:30:35 robbat2 Exp $

EAPI=5
inherit eutils rpm linux-info
DESCRIPTION="XenServer Virtual Machine Tools"
HOMEPAGE="http://www.citrix.com/";
PV_BASE=${PV/_*}
PV_FULL=${PV/_p/-}
SRC_URI="http://updates.vmd.citrix.com/XenServer/${PV_BASE}/rhel4x/SRPMS/xe-guest-utilities-${PV_FULL}.src.rpm";
LICENSE="LGPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE="xenstore"
DEPEND="app-arch/rpm2targz"
RDEPEND="
        !xenstore? ( app-emulation/xen-tools )
        xenstore? ( !app-emulation/xen-tools )"
S=${WORKDIR}
CONFIG_CHECK="~XEN_COMPAT_XENFS ~XENFS"
QA_PREBUILT="usr/bin/xenstore* usr/bin/xeninfo"

src_unpack() {
        rpm_src_unpack ${A}
        # Upstream includes xenstore-sources.tar.bz2
        # but it is NOT the complete source :-(
}

src_prepare() {
        epatch "${FILESDIR}"/${PN}-6.2.0_p1120-Guest-Attributes.patch
        epatch "${FILESDIR}"/${PN}-6.2.0_p1120-Linux-Distribution.patch
}

src_install() {
        newinitd "${FILESDIR}/xe-daemon.initd" xe-daemon
        dosbin xe-daemon
        dosbin xe-linux-distribution
        dosbin xe-update-guest-attrs
        insinto /lib/udev/rules.d
        newins xen-vcpu-hotplug.rules 10-xen-vcpu-hotplug.rules

        if use xenstore; then
                dobin usr/bin/xeninfo
                dobin usr/bin/xenstore
                dobin usr/bin/xenstore-*
        fi
}

pkg_postinst() {
        if [ ! -e /etc/runlevels/boot/xe-daemon ]; then
                elog "To start the xe-daemon automatically by default"
                elog "you should add it to the boot runlevel :"
                elog "'rc-update add xe-daemon boot'"
                elog
        fi
}



1.1                  
app-emulation/xe-guest-utilities/xe-guest-utilities-5.6.0_p595.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-5.6.0_p595.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-5.6.0_p595.ebuild?rev=1.1&content-type=text/plain

Index: xe-guest-utilities-5.6.0_p595.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-5.6.0_p595.ebuild,v
 1.1 2014/06/23 14:30:35 robbat2 Exp $

EAPI=5
inherit eutils rpm linux-info
DESCRIPTION="XenServer Virtual Machine Tools"
HOMEPAGE="http://www.citrix.com/";
PV_BASE=${PV/_*}
PV_FULL=${PV/_p/-}
SRC_URI="http://updates.vmd.citrix.com/XenServer/${PV_BASE}/rhel4x/SRPMS/xe-guest-utilities-${PV_FULL}.src.rpm";
LICENSE="LGPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE="xenstore"
DEPEND="app-arch/rpm2targz"
RDEPEND="
        !xenstore? ( app-emulation/xen-tools )
        xenstore? ( !app-emulation/xen-tools )"
S=${WORKDIR}
CONFIG_CHECK="~XEN_COMPAT_XENFS ~XENFS"
QA_PREBUILT="usr/bin/xenstore* usr/bin/xeninfo"

src_unpack() {
        rpm_src_unpack ${A}
        # Upstream includes xenstore-sources.tar.bz2
        # but it is NOT the complete source :-(
}

src_prepare() {
        epatch "${FILESDIR}"/${PN}-5.6.100_p651-gentoo.patch
        epatch "${FILESDIR}"/${PN}-5.6.100_p651-update-guest-attrs.patch
}

src_install() {
        newinitd "${FILESDIR}/xe-daemon.initd" xe-daemon
        dosbin xe-daemon
        dosbin xe-linux-distribution
        dosbin xe-update-guest-attrs
        insinto /lib/udev/rules.d
        newins xen-vcpu-hotplug.rules 10-xen-vcpu-hotplug.rules

        if use xenstore; then
                dobin usr/bin/xeninfo
                dobin usr/bin/xenstore
                dobin usr/bin/xenstore-*
        fi
}

pkg_postinst() {
        if [ ! -e /etc/runlevels/boot/xe-daemon ]; then
                elog "To start the xe-daemon automatically by default"
                elog "you should add it to the boot runlevel :"
                elog "'rc-update add xe-daemon boot'"
                elog
        fi
}



1.1                  app-emulation/xe-guest-utilities/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
<herd>openstack</herd>
<herd>virtualization</herd>
<herd>xen</herd>
<maintainer>
        <email>ch...@camisa.org</email>
        <name>Christopher J. Camisa</name>
        <description>proxy maintainer</description>
</maintainer>
<maintainer>
        <email>robb...@gentoo.org</email>
</maintainer>
<longdescription>XenServer Virtual Machine Tools</longdescription>
<use>
        <flag name="xenstore">Use xenstore binaries bundled by Citrix instead 
of building app-emulation/xen-tools</flag>
</use>
</pkgmetadata>



1.1                  
app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild?rev=1.1&content-type=text/plain

Index: xe-guest-utilities-6.1.0_p1033.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild,v
 1.1 2014/06/23 14:30:35 robbat2 Exp $

EAPI=5
inherit eutils rpm linux-info
DESCRIPTION="XenServer Virtual Machine Tools"
HOMEPAGE="http://www.citrix.com/";
PV_BASE=${PV/_*}
PV_FULL=${PV/_p/-}
SRC_URI="http://updates.vmd.citrix.com/XenServer/${PV_BASE}/rhel4x/SRPMS/xe-guest-utilities-${PV_FULL}.src.rpm";
LICENSE="LGPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE="xenstore"
DEPEND="app-arch/rpm2targz"
RDEPEND="
        !xenstore? ( app-emulation/xen-tools )
        xenstore? ( !app-emulation/xen-tools )"
S=${WORKDIR}
CONFIG_CHECK="~XEN_COMPAT_XENFS ~XENFS"
QA_PREBUILT="usr/bin/xenstore* usr/bin/xeninfo"

src_unpack() {
        rpm_src_unpack ${A}
        # Upstream includes xenstore-sources.tar.bz2
        # but it is NOT the complete source :-(
}

src_prepare() {
        epatch "${FILESDIR}"/${PN}-6.2.0_p1120-Guest-Attributes.patch
        epatch "${FILESDIR}"/${PN}-6.2.0_p1120-Linux-Distribution.patch
}

src_install() {
        newinitd "${FILESDIR}/xe-daemon.initd" xe-daemon
        dosbin xe-daemon
        dosbin xe-linux-distribution
        dosbin xe-update-guest-attrs
        insinto /lib/udev/rules.d
        newins xen-vcpu-hotplug.rules 10-xen-vcpu-hotplug.rules

        if use xenstore; then
                dobin usr/bin/xeninfo
                dobin usr/bin/xenstore
                dobin usr/bin/xenstore-*
        fi
}

pkg_postinst() {
        if [ ! -e /etc/runlevels/boot/xe-daemon ]; then
                elog "To start the xe-daemon automatically by default"
                elog "you should add it to the boot runlevel :"
                elog "'rc-update add xe-daemon boot'"
                elog
        fi
}



1.1                  app-emulation/xe-guest-utilities/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xe-guest-utilities/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for app-emulation/xe-guest-utilities
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/app-emulation/xe-guest-utilities/ChangeLog,v 
1.1 2014/06/23 14:30:35 robbat2 Exp $

*xe-guest-utilities-5.6.0_p595 (23 Jun 2014)
*xe-guest-utilities-6.1.0_p1033 (23 Jun 2014)
*xe-guest-utilities-6.2.0_p1120 (23 Jun 2014)

  23 Jun 2014; Robin H. Johnson <robb...@gentoo.org> +files/xe-daemon.initd,
  +files/xe-guest-utilities-5.6.100_p651-gentoo.patch,
  +files/xe-guest-utilities-5.6.100_p651-update-guest-attrs.patch,
  +files/xe-guest-utilities-6.2.0_p1120-Guest-Attributes.patch,
  +files/xe-guest-utilities-6.2.0_p1120-Linux-Distribution.patch, +metadata.xml,
  +xe-guest-utilities-5.6.0_p595.ebuild, +xe-guest-utilities-6.1.0_p1033.ebuild,
  +xe-guest-utilities-6.2.0_p1120.ebuild:
  Initial commit, based off Chris Camisa's work in his OpenStack overlay:
  https://github.com/Camisa/OpenStack-Overlay/tree/master/sys-cluster/xe-guest-
  utilities; I intend to proxy further commits from him.




Reply via email to