dlan        14/09/11 13:41:25

  Modified:             ChangeLog
  Added:                xen-4.4.1-r1.ebuild
  Removed:              xen-4.4.1.ebuild
  Log:
  fix security bug 522576
  
  (Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xAABEFD55)

Revision  Changes    Path
1.174                app-emulation/xen/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xen/ChangeLog?rev=1.174&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xen/ChangeLog?rev=1.174&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xen/ChangeLog?r1=1.173&r2=1.174

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v
retrieving revision 1.173
retrieving revision 1.174
diff -u -r1.173 -r1.174
--- ChangeLog   11 Sep 2014 05:22:42 -0000      1.173
+++ ChangeLog   11 Sep 2014 13:41:25 -0000      1.174
@@ -1,6 +1,12 @@
 # ChangeLog for app-emulation/xen
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.173 
2014/09/11 05:22:42 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.174 
2014/09/11 13:41:25 dlan Exp $
+
+*xen-4.4.1-r1 (11 Sep 2014)
+
+  11 Sep 2014; Yixun Lan <d...@gentoo.org> -xen-4.4.1.ebuild,
+  +xen-4.4.1-r1.ebuild:
+  fix security bug 522576
 
 *xen-4.4.1 (11 Sep 2014)
 *xen-4.3.3 (11 Sep 2014)



1.1                  app-emulation/xen/xen-4.4.1-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xen/xen-4.4.1-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/xen/xen-4.4.1-r1.ebuild?rev=1.1&content-type=text/plain

Index: xen-4.4.1-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.4.1-r1.ebuild,v 1.1 
2014/09/11 13:41:25 dlan Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )

MY_PV=${PV/_/-}
MY_P=${PN}-${PV/_/-}

if [[ $PV == *9999 ]]; then
        KEYWORDS=""
        EGIT_REPO_URI="git://xenbits.xen.org/${PN}.git"
        live_eclass="git-2"
else
        KEYWORDS="~amd64 ~arm -x86"
        UPSTREAM_VER=0
        GENTOO_VER=

        [[ -n ${UPSTREAM_VER} ]] && \
                
UPSTREAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz";
        [[ -n ${GENTOO_VER} ]] && \
                
GENTOO_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P}-gentoo-patches-${GENTOO_VER}.tar.xz";
        
SRC_URI="http://bits.xensource.com/oss-xen/release/${MY_PV}/${MY_P}.tar.gz
                ${UPSTREAM_PATCHSET_URI}
                ${GENTOO_PATCHSET_URI}"

fi

inherit mount-boot flag-o-matic python-any-r1 toolchain-funcs eutils 
${live_eclass}

DESCRIPTION="The Xen virtual machine monitor"
HOMEPAGE="http://xen.org/";
LICENSE="GPL-2"
SLOT="0"
IUSE="custom-cflags debug efi flask xsm"

DEPEND="${PYTHON_DEPS}
        efi? ( >=sys-devel/binutils-2.22[multitarget] )
        !efi? ( >=sys-devel/binutils-2.22[-multitarget] )"
RDEPEND=""
PDEPEND="~app-emulation/xen-tools-${PV}"

RESTRICT="test"

# Approved by QA team in bug #144032
QA_WX_LOAD="boot/xen-syms-${PV}"

REQUIRED_USE="flask? ( xsm )
        arm? ( debug )"

S="${WORKDIR}/${MY_P}"

pkg_setup() {
        python-any-r1_pkg_setup
        if [[ -z ${XEN_TARGET_ARCH} ]]; then
                if use x86 && use amd64; then
                        die "Confusion! Both x86 and amd64 are set in your use 
flags!"
                elif use x86; then
                        export XEN_TARGET_ARCH="x86_32"
                elif use amd64; then
                        export XEN_TARGET_ARCH="x86_64"
                elif use arm; then
                        export XEN_TARGET_ARCH="arm32"
                else
                        die "Unsupported architecture!"
                fi
        fi

        if use flask ; then
                export "XSM_ENABLE=y"
                export "FLASK_ENABLE=y"
        elif use xsm ; then
                export "XSM_ENABLE=y"
        fi
}

src_prepare() {
        # Upstream's patchset
        if [[ -n ${UPSTREAM_VER} ]]; then
                EPATCH_SUFFIX="patch" \
                EPATCH_FORCE="yes" \
                EPATCH_OPTS="-p1" \
                        epatch "${WORKDIR}"/patches-upstream
        fi

        # Gentoo's patchset
        if [[ -n ${GENTOO_VER} ]]; then
                EPATCH_SUFFIX="patch" \
                EPATCH_FORCE="yes" \
                        epatch "${WORKDIR}"/patches-gentoo
        fi

        # Drop .config
        sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't 
drop"

        if use efi; then
                epatch "${FILESDIR}"/${PN}-4.4-efi.patch
                export EFI_VENDOR="gentoo"
                export EFI_MOUNTPOINT="boot"
        fi

        # if the user *really* wants to use their own custom-cflags, let them
        if use custom-cflags; then
                einfo "User wants their own CFLAGS - removing defaults"
                # try and remove all the default custom-cflags
                find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk 
-exec sed \
                        -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
                        -e 
's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
                        -e 
's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
                        -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
                        -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
                        -i {} \; || die "failed to re-set custom-cflags"
        fi

        # remove -Werror for gcc-4.6's sake
        find "${S}" -name 'Makefile*' -o -name '*.mk' -o -name 'common.make' | \
                xargs sed -i 's/ *-Werror */ /'
        # not strictly necessary to fix this
        sed -i 's/, "-Werror"//' "${S}/tools/python/setup.py" || die "failed to 
re-set setup.py"

        epatch_user
}

src_configure() {
        use arm && myopt="${myopt} CONFIG_EARLY_PRINTK=sun7i"

        use debug && myopt="${myopt} debug=y"

        if use custom-cflags; then
                filter-flags -fPIE -fstack-protector
                replace-flags -O3 -O2
        else
                unset CFLAGS
        fi
}

src_compile() {
        # Send raw LDFLAGS so that --as-needed works
        emake V=1 CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C 
xen ${myopt}
}

src_install() {
        local myopt
        use debug && myopt="${myopt} debug=y"

        # The 'make install' doesn't 'mkdir -p' the subdirs
        if use efi; then
                mkdir -p "${D}"${EFI_MOUNTPOINT}/efi/${EFI_VENDOR} || die
        fi

        emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install
}

pkg_postinst() {
        elog "Official Xen Guide and the unoffical wiki page:"
        elog " http://www.gentoo.org/doc/en/xen-guide.xml";
        elog " http://en.gentoo-wiki.com/wiki/Xen/";

        use efi && einfo "The efi executable is installed in boot/efi/gentoo"
}




Reply via email to