jmbsvicetto    14/09/22 02:47:12

  Modified:             ChangeLog
  Added:                phpmyadmin-4.2.9.ebuild
  Log:
  Add 4.2.9 release
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
BB0E6E98)

Revision  Changes    Path
1.525                dev-db/phpmyadmin/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/ChangeLog?rev=1.525&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/ChangeLog?rev=1.525&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/ChangeLog?r1=1.524&r2=1.525

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v
retrieving revision 1.524
retrieving revision 1.525
diff -u -r1.524 -r1.525
--- ChangeLog   20 Sep 2014 11:05:25 -0000      1.524
+++ ChangeLog   22 Sep 2014 02:47:12 -0000      1.525
@@ -1,6 +1,12 @@
 # ChangeLog for dev-db/phpmyadmin
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.524 
2014/09/20 11:05:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.525 
2014/09/22 02:47:12 jmbsvicetto Exp $
+
+*phpmyadmin-4.2.9 (22 Sep 2014)
+
+  22 Sep 2014; Jorge Manuel B. S. Vicetto <jmbsvice...@gentoo.org>
+  +phpmyadmin-4.2.9.ebuild:
+  Add 4.2.9 release
 
   20 Sep 2014; Agostino Sarubbo <a...@gentoo.org> phpmyadmin-4.1.14.3.ebuild:
   Stable for alpha, wrt bug #520142



1.1                  dev-db/phpmyadmin/phpmyadmin-4.2.9.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.2.9.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.2.9.ebuild?rev=1.1&content-type=text/plain

Index: phpmyadmin-4.2.9.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.2.9.ebuild,v 
1.1 2014/09/22 02:47:12 jmbsvicetto Exp $

EAPI="4"

inherit eutils webapp depend.php

MY_PV=${PV/_/-}
MY_P="phpMyAdmin-${MY_PV}-all-languages"

DESCRIPTION="Web-based administration for MySQL database in PHP"
HOMEPAGE="http://www.phpmyadmin.net/";
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~ppc-macos ~x64-macos ~x86-macos"
IUSE="setup"

RDEPEND="
        dev-lang/php[crypt,ctype,filter,json,session,unicode]
        || (
                dev-lang/php[mysqli]
                dev-lang/php[mysql]
        )
"

need_httpd_cgi
need_php_httpd

S="${WORKDIR}"/${MY_P}

pkg_setup() {
        webapp_pkg_setup
}

src_install() {
        webapp_src_preinst

        dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
        rm -f LICENSE README* RELEASE-DATE-${MY_PV}

        if ! use setup; then
                rm -rf setup || die "Cannot remove setup utility"
                elog "The phpMyAdmin setup utility has been removed."
                elog "It is a regular target of various exploits. If you need 
it, set USE=setup."
        else
                elog "You should consider disabling the setup USE flag"
                elog "to exclude the setup utility if you don't use it."
                elog "It regularly is the target of various exploits."
        fi

        insinto "${MY_HTDOCSDIR#${EPREFIX}}"
        doins -r .

        webapp_configfile 
"${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
        webapp_serverowned 
"${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php

        webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
        webapp_src_install
}




Reply via email to