hasufell    15/02/16 17:47:07

  Modified:             ChangeLog
  Added:                libuv-1.4.0.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  Changes    Path
1.32                 dev-libs/libuv/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/ChangeLog?rev=1.32&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/ChangeLog?rev=1.32&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/ChangeLog?r1=1.31&r2=1.32

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v
retrieving revision 1.31
retrieving revision 1.32
diff -u -r1.31 -r1.32
--- ChangeLog   16 Jan 2015 15:47:31 -0000      1.31
+++ ChangeLog   16 Feb 2015 17:47:07 -0000      1.32
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/libuv
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.31 2015/01/16 
15:47:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.32 2015/02/16 
17:47:07 hasufell Exp $
+
+*libuv-1.4.0 (16 Feb 2015)
+
+  16 Feb 2015; Julian Ospald <hasuf...@gentoo.org> +libuv-1.4.0.ebuild:
+  version bump
 
 *libuv-1.2.1-r1 (16 Jan 2015)
 



1.1                  dev-libs/libuv/libuv-1.4.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/libuv-1.4.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/libuv-1.4.0.ebuild?rev=1.1&content-type=text/plain

Index: libuv-1.4.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-1.4.0.ebuild,v 1.1 
2015/02/16 17:47:07 hasufell Exp $

EAPI=5

inherit eutils autotools multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv";
SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"

DEPEND="
        sys-devel/libtool
        virtual/pkgconfig
"

src_prepare() {
        echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
                > m4/libuv-extra-automake-flags.m4 || die

        sed -i \
                -e '/CC_CHECK_CFLAGS_APPEND(\[-g\])/d' \
                configure.ac || die "fixing CFLAGS failed!"

        eautoreconf
}

multilib_src_configure() {
        ECONF_SOURCE="${S}" econf \
                $(use_enable static-libs static)
}

multilib_src_test() {
        mkdir "${BUILD_DIR}"/test || die
        cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
        default
}

multilib_src_install_all() {
        einstalldocs
        prune_libtool_files
}




Reply via email to