patrick     15/07/19 01:51:25

  Modified:             ChangeLog
  Added:                logbook-0.10.0.ebuild
  Log:
  Bump
  
  (Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.25                 dev-python/logbook/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/logbook/ChangeLog?rev=1.25&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/logbook/ChangeLog?rev=1.25&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/logbook/ChangeLog?r1=1.24&r2=1.25

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v
retrieving revision 1.24
retrieving revision 1.25
diff -u -r1.24 -r1.25
--- ChangeLog   15 Jun 2015 21:50:42 -0000      1.24
+++ ChangeLog   19 Jul 2015 01:51:25 -0000      1.25
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/logbook
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.24 
2015/06/15 21:50:42 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.25 
2015/07/19 01:51:25 patrick Exp $
+
+*logbook-0.10.0 (19 Jul 2015)
+
+  19 Jul 2015; Patrick Lauer <patr...@gentoo.org> +logbook-0.10.0.ebuild:
+  Bump
 
 *logbook-0.9.1 (15 Jun 2015)
 



1.1                  dev-python/logbook/logbook-0.10.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/logbook/logbook-0.10.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/logbook/logbook-0.10.0.ebuild?rev=1.1&content-type=text/plain

Index: logbook-0.10.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.10.0.ebuild,v 
1.1 2015/07/19 01:51:25 patrick Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )

inherit distutils-r1

DESCRIPTION="A logging replacement for Python"
HOMEPAGE="http://packages.python.org/Logbook/ 
http://pypi.python.org/pypi/Logbook";
SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
DISTUTILS_IN_SOURCE_BUILD=1

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )
        doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"

PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )

python_prepare_all() {
        # Delete test file requiring local conncetion to redis server
        rm tests/test_queues.py || die
        distutils-r1_python_prepare_all
}

python_compile_all() {
        use doc && emake -C docs html
}

python_test() {
        py.test tests || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
        use doc && HTML_DOCS=( docs/_build/html/. )
        distutils-r1_python_install_all
}




Reply via email to