alunduil    15/04/18 15:11:00

  Modified:             ChangeLog
  Added:                pyrax-1.9.4.ebuild
  Log:
  add version 1.9.4
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
11A8217C!)

Revision  Changes    Path
1.18                 dev-python/pyrax/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyrax/ChangeLog?rev=1.18&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyrax/ChangeLog?rev=1.18&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyrax/ChangeLog?r1=1.17&r2=1.18

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v
retrieving revision 1.17
retrieving revision 1.18
diff -u -r1.17 -r1.18
--- ChangeLog   26 Nov 2014 17:03:24 -0000      1.17
+++ ChangeLog   18 Apr 2015 15:11:00 -0000      1.18
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/pyrax
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.17 
2014/11/26 17:03:24 alunduil Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.18 
2015/04/18 15:11:00 alunduil Exp $
+
+*pyrax-1.9.4 (18 Apr 2015)
+
+  18 Apr 2015; Alex Brandt <alund...@gentoo.org> +pyrax-1.9.4.ebuild,
+  metadata.xml:
+  add version 1.9.4
 
   26 Nov 2014; Alex Brandt <alund...@gentoo.org> -pyrax-1.3.6.ebuild,
   -pyrax-1.4.3.ebuild, -pyrax-1.4.7-r1.ebuild, -pyrax-1.4.7.ebuild,



1.1                  dev-python/pyrax/pyrax-1.9.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyrax/pyrax-1.9.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyrax/pyrax-1.9.4.ebuild?rev=1.1&content-type=text/plain

Index: pyrax-1.9.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/pyrax-1.9.4.ebuild,v 1.1 
2015/04/18 15:11:00 alunduil Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="Python language bindings for OpenStack Clouds"
HOMEPAGE="https://github.com/rackspace/pyrax";
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples test"

CDEPEND="
        dev-python/keyring[${PYTHON_USEDEP}]
        dev-python/mock[${PYTHON_USEDEP}]
        >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
        dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
        >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
        >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
"
DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                ${CDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
                
dev-python/rax-scheduled-images-python-novaclient-ext[${PYTHON_USEDEP}]
        )
"
RDEPEND="${CDEPEND}"

python_test() {
        nosetests tests/unit || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
        use examples && local EXAMPLES=( samples/. )

        distutils-r1_python_install_all
}




Reply via email to