graaff      14/11/17 20:20:24

  Modified:             ChangeLog
  Added:                railties-4.1.8.ebuild railties-4.0.12.ebuild
                        railties-3.2.21.ebuild
  Log:
  Version bump for security bug 529635.
  
  (Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.93                 dev-ruby/railties/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/ChangeLog?rev=1.93&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/ChangeLog?rev=1.93&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/ChangeLog?r1=1.92&r2=1.93

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v
retrieving revision 1.92
retrieving revision 1.93
diff -u -r1.92 -r1.93
--- ChangeLog   7 Nov 2014 10:13:15 -0000       1.92
+++ ChangeLog   17 Nov 2014 20:20:24 -0000      1.93
@@ -1,6 +1,14 @@
 # ChangeLog for dev-ruby/railties
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.92 
2014/11/07 10:13:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.93 
2014/11/17 20:20:24 graaff Exp $
+
+*railties-4.1.8 (17 Nov 2014)
+*railties-4.0.12 (17 Nov 2014)
+*railties-3.2.21 (17 Nov 2014)
+
+  17 Nov 2014; Hans de Graaff <gra...@gentoo.org> +railties-3.2.21.ebuild,
+  +railties-4.0.12.ebuild, +railties-4.1.8.ebuild:
+  Version bump for security bug 529635.
 
   07 Nov 2014; Hans de Graaff <gra...@gentoo.org> -railties-3.2.19.ebuild,
   -railties-4.0.9.ebuild, -railties-4.0.10.ebuild, -railties-4.1.5.ebuild,



1.1                  dev-ruby/railties/railties-4.1.8.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/railties-4.1.8.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/railties-4.1.8.ebuild?rev=1.1&content-type=text/plain

Index: railties-4.1.8.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-4.1.8.ebuild,v 
1.1 2014/11/17 20:20:24 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_TASK_TEST="test:regular"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="railties.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem versionator

DESCRIPTION="Tools for creating, working with, and running Rails applications"
HOMEPAGE="http://github.com/rails/rails";
SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

# The test suite has many failures, most likely due to a mismatch in
# exact dependencies or environment specifics. Needs further
# investigation.
RESTRICT="test"

RDEPEND+=">=app-admin/eselect-rails-0.19"

ruby_add_rdepend "
        ~dev-ruby/activesupport-${PV}
        ~dev-ruby/actionpack-${PV}
        >=dev-ruby/thor-0.18.1
        >=dev-ruby/rake-0.8.7"

ruby_add_bdepend "
        test? (
                ~dev-ruby/actionview-${PV}
                dev-ruby/mocha:0.13
        )"

all_ruby_prepare() {
        rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
        sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to 
remove load paths"
        sed -i -e '1igem "minitest", "~>4.0"' test/abstract_unit.rb || die

        # Also allow rdoc 4.x
        sed -i -e 's/~> 3.4/>= 3.4/' ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_install() {
        all_fakegem_install

        ruby_fakegem_binwrapper rails rails-${PV}
}

pkg_postinst() {
        elog "To select between slots of rails, use:"
        elog "\teselect rails"

        eselect rails update
}

pkg_postrm() {
        eselect rails update
}



1.1                  dev-ruby/railties/railties-4.0.12.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/railties-4.0.12.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/railties-4.0.12.ebuild?rev=1.1&content-type=text/plain

Index: railties-4.0.12.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-4.0.12.ebuild,v 
1.1 2014/11/17 20:20:24 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_TASK_TEST="test:regular"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="railties.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem versionator

DESCRIPTION="Tools for creating, working with, and running Rails applications"
HOMEPAGE="http://github.com/rails/rails";
SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

# The test suite has many failures, most likely due to a mismatch in
# exact dependencies or environment specifics. Needs further
# investigation.
RESTRICT="test"

RDEPEND+=">=app-admin/eselect-rails-0.19"

ruby_add_rdepend "
        ~dev-ruby/activesupport-${PV}
        ~dev-ruby/actionpack-${PV}
        >=dev-ruby/thor-0.18.1
        >=dev-ruby/rake-0.8.7"

ruby_add_bdepend "
        test? (
                dev-ruby/mocha:0.13
        )"

all_ruby_prepare() {
        rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
        sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to 
remove load paths"
        sed -i -e '1igem "minitest", "~>4.0"' test/abstract_unit.rb || die

        # Also allow rdoc 4.x
        sed -i -e 's/~> 3.4/>= 3.4/' ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_install() {
        all_fakegem_install

        ruby_fakegem_binwrapper rails rails-${PV}
}

pkg_postinst() {
        elog "To select between slots of rails, use:"
        elog "\teselect rails"

        eselect rails update
}

pkg_postrm() {
        eselect rails update
}



1.1                  dev-ruby/railties/railties-3.2.21.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/railties-3.2.21.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/railties/railties-3.2.21.ebuild?rev=1.1&content-type=text/plain

Index: railties-3.2.21.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.2.21.ebuild,v 
1.1 2014/11/17 20:20:24 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20"

RUBY_FAKEGEM_TASK_TEST="test:regular"
RUBY_FAKEGEM_TASK_DOC="generate_guides"
RUBY_FAKEGEM_DOCDIR="guides/output"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="railties.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem versionator

DESCRIPTION="Tools for creating, working with, and running Rails applications"
HOMEPAGE="http://github.com/rails/rails";
SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

# The test suite has many failures, most likely due to a mismatch in
# exact dependencies or environment specifics. Needs further
# investigation.
RESTRICT="test"

RDEPEND+=">=app-admin/eselect-rails-0.18"

ruby_add_rdepend "
        ~dev-ruby/activesupport-${PV}
        ~dev-ruby/actionpack-${PV}
        >=dev-ruby/rdoc-3.4
        >=dev-ruby/thor-0.14.6
        >=dev-ruby/rack-ssl-1.3.2:1.3
        >=dev-ruby/rake-0.8.7"

ruby_add_bdepend "
        test? (
                dev-ruby/mocha:0.13
        )
        doc? (
                >=dev-ruby/redcloth-4.1.1
        )"

all_ruby_prepare() {
        # Remove items from the common Gemfile that we don't need for this
        # test run. This also requires handling some gemspecs.
        sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\)/d' 
../Gemfile || die

        # Also allow rdoc 4.x
        sed -i -e 's/~> 3.4/>= 3.4/' ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_install() {
        all_fakegem_install

        if use doc ; then
                mv guides/output guides/guides || die
                dohtml -r guides/guides
        fi

        ruby_fakegem_binwrapper rails rails-${PV}
}

pkg_postinst() {
        elog "To select between slots of rails, use:"
        elog "\teselect rails"

        eselect rails update
}

pkg_postrm() {
        eselect rails update
}




Reply via email to