mrueg       14/10/22 13:02:47

  Modified:             ChangeLog
  Added:                rb-gsl-1.16.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )

Revision  Changes    Path
1.7                  dev-ruby/rb-gsl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rb-gsl/ChangeLog?rev=1.7&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rb-gsl/ChangeLog?rev=1.7&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rb-gsl/ChangeLog?r1=1.6&r2=1.7

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- ChangeLog   13 Jul 2014 07:11:25 -0000      1.6
+++ ChangeLog   22 Oct 2014 13:02:47 -0000      1.7
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/rb-gsl
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v 1.6 2014/07/13 
07:11:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v 1.7 2014/10/22 
13:02:47 mrueg Exp $
+
+*rb-gsl-1.16.0.3 (22 Oct 2014)
+
+  22 Oct 2014; Manuel RĂ¼ger <mr...@gentoo.org> +rb-gsl-1.16.0.3.ebuild:
+  Version bump.
 
 *rb-gsl-1.16.0.2 (13 Jul 2014)
 



1.1                  dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild?rev=1.1&content-type=text/plain

Index: rb-gsl-1.16.0.3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild,v 1.1 
2014/10/22 13:02:47 mrueg Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"

inherit ruby-fakegem multilib

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="ChangeLog README"

RUBY_FAKEGEM_TASK_TEST="test:libs"
DESCRIPTION="Ruby interface to GNU Scientific Library"
HOMEPAGE="https://github.com/david-macmahon/rb-gsl";
#SRC_URI="https://github.com/david-macmahon/${PN}/archive/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"

DEPEND+=" sci-libs/gsl"
RDEPEND+=" sci-libs/gsl"

RUBY_S="${PN}-${P}"

ruby_add_rdepend "dev-ruby/narray"

each_ruby_prepare() {
        sed -i -e '/$CPPFLAGS =/a \$LDFLAGS = " -L#{narray_config} -l:narray.so 
"+$LDFLAGS' -e 's/src/lib/' ext/gsl/extconf.rb || die
}

each_ruby_configure() {
        ${RUBY} -Cext/gsl extconf.rb || die
}

each_ruby_compile() {
        emake -Cext/gsl V=1
        cp ext/gsl/*$(get_modname) lib/gsl || die
}

each_ruby_test() {
        ${RUBY} -S testrb -Ilib -Itest test/*.rb test/*/*.rb || die
}




Reply via email to