mrueg       14/04/03 08:51:54

  Modified:             redcloth-4.2.9-r1.ebuild ChangeLog
  Added:                redcloth-4.2.9-r2.ebuild
  Log:
  Add ruby21. Drop ruby18. Drop alpha, sparc. Rekeywording in bug #465948.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )

Revision  Changes    Path
1.4                  dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild?r1=1.3&r2=1.4

Index: redcloth-4.2.9-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- redcloth-4.2.9-r1.ebuild    2 Jan 2014 14:39:38 -0000       1.3
+++ redcloth-4.2.9-r1.ebuild    3 Apr 2014 08:51:54 -0000       1.4
@@ -1,12 +1,12 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild,v 1.3 
2014/01/02 14:39:38 graaff Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r1.ebuild,v 1.4 
2014/04/03 08:51:54 mrueg Exp $
 
 EAPI=5
 
 # jruby → tests still fail with UTF-8 characters
 # 
http://jgarber.lighthouseapp.com/projects/13054/tickets/149-redcloth-4-doesnt-support-multi-bytes-content
-USE_RUBY="ruby18 ruby19 ruby20"
+USE_RUBY="ruby19 ruby20"
 
 RUBY_FAKEGEM_NAME="RedCloth"
 



1.84                 dev-ruby/redcloth/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/ChangeLog?rev=1.84&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/ChangeLog?rev=1.84&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/ChangeLog?r1=1.83&r2=1.84

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v
retrieving revision 1.83
retrieving revision 1.84
diff -u -r1.83 -r1.84
--- ChangeLog   2 Jan 2014 14:39:37 -0000       1.83
+++ ChangeLog   3 Apr 2014 08:51:54 -0000       1.84
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/redcloth
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.83 
2014/01/02 14:39:37 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.84 
2014/04/03 08:51:54 mrueg Exp $
+
+*redcloth-4.2.9-r2 (03 Apr 2014)
+
+  03 Apr 2014; Manuel Rüger <mr...@gentoo.org> +redcloth-4.2.9-r2.ebuild,
+  redcloth-4.2.9-r1.ebuild:
+  Add ruby21. Drop ruby18. Drop alpha, sparc. Rekeywording in bug #465948.
 
   02 Jan 2014; Hans de Graaff <gra...@gentoo.org> redcloth-4.2.9.ebuild,
   redcloth-4.2.9-r1.ebuild:



1.1                  dev-ruby/redcloth/redcloth-4.2.9-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r2.ebuild?rev=1.1&content-type=text/plain

Index: redcloth-4.2.9-r2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r2.ebuild,v 
1.1 2014/04/03 08:51:54 mrueg Exp $

EAPI=5

# jruby → tests still fail with UTF-8 characters
# 
http://jgarber.lighthouseapp.com/projects/13054/tickets/149-redcloth-4-doesnt-support-multi-bytes-content
USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_NAME="RedCloth"

RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"

RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"

inherit ruby-fakegem versionator

DESCRIPTION="A module for using Textile in Ruby"
HOMEPAGE="http://redcloth.org/";

GITHUB_USER=jgarber
SRC_URI="https://github.com/${GITHUB_USER}/redcloth/tarball/v${PV} -> 
${RUBY_FAKEGEM_NAME}-git-${PV}.tgz"
RUBY_S="${GITHUB_USER}-${PN}-*"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux 
~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris 
~x86-solaris"
IUSE=""

DEPEND+=" dev-util/ragel"

ruby_add_bdepend "
        >=dev-ruby/rake-0.8.7
        >=dev-ruby/rake-compiler-0.7.1
        test? ( >=dev-ruby/diff-lcs-1.1.2 )"

pkg_setup() {
        ruby-ng_pkg_setup

        # Export the VERBOSE variable to avoid remapping of stdout and
        # stderr, and that breaks because of bad interactions between
        # echoe, Ruby and Gentoo.
        export VERBOSE=1
}

all_ruby_prepare() {
        sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
        rm tasks/{release,gems,rspec}.rake || die
}

each_ruby_compile() {
        # We cannot run this manually easily, because Ragel re-generation
        # is a mess
        ${RUBY} -S rake compile || die "rake compile failed"
}




Reply via email to