mrueg       15/05/29 15:06:15

  Modified:             ChangeLog
  Added:                test-unit-3.1.1.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )

Revision  Changes    Path
1.119                dev-ruby/test-unit/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/test-unit/ChangeLog?rev=1.119&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/test-unit/ChangeLog?rev=1.119&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/test-unit/ChangeLog?r1=1.118&r2=1.119

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v
retrieving revision 1.118
retrieving revision 1.119
diff -u -r1.118 -r1.119
--- ChangeLog   9 May 2015 06:00:21 -0000       1.118
+++ ChangeLog   29 May 2015 15:06:15 -0000      1.119
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/test-unit
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.118 
2015/05/09 06:00:21 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.119 
2015/05/29 15:06:15 mrueg Exp $
+
+*test-unit-3.1.1 (29 May 2015)
+
+  29 May 2015; Manuel RĂ¼ger <mr...@gentoo.org> +test-unit-3.1.1.ebuild:
+  Version bump.
 
   09 May 2015; Hans de Graaff <gra...@gentoo.org> test-unit-3.0.9-r1.ebuild:
   Use rm -f to avoid issues like bug 540182.



1.1                  dev-ruby/test-unit/test-unit-3.1.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/test-unit/test-unit-3.1.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/test-unit/test-unit-3.1.1.ebuild?rev=1.1&content-type=text/plain

Index: test-unit-3.1.1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-3.1.1.ebuild,v 
1.1 2015/05/29 15:06:15 mrueg Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="TODO README.md doc/text/news.md"

inherit ruby-fakegem

# Assume for now that ruby22 is not eselected yet and only depend on
# yard for the other ruby implementations. Without this assumption
# bootstrapping ruby22 won't be possible due to the yard dependency
# tree.
USE_RUBY="${USE_RUBY/ruby22/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"

DESCRIPTION="An xUnit family unit testing framework for Ruby"
HOMEPAGE="https://rubygems.org/gems/test-unit";

LICENSE="|| ( Ruby GPL-2 ) PSF-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc 
~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="doc test"

# power_assert does not work with ruby19 but is not needed for backward
# compatibility:
# https://github.com/k-tsj/power_assert/issues/8#issuecomment-71363455
USE_RUBY="${USE_RUBY/ruby19/}" ruby_add_rdepend "dev-ruby/power_assert"

each_ruby_prepare() {
        case ${RUBY} in
                *ruby19)
                        # Remove metadata to avoid registering the unsupported
                        # power_assert dependency.
                        rm -f ../metadata || die
                        ;;
        esac
}

all_ruby_compile() {
        all_fakegem_compile

        if use doc; then
                yard doc --title ${PN} || die
        fi
}

each_ruby_test() {
        ${RUBY} test/run-test.rb || die "testsuite failed"
}

all_ruby_install() {
        all_fakegem_install

        newbin "${FILESDIR}"/testrb-3 testrb-2
}




Reply via email to