mgorny      15/06/02 08:35:38

  Modified:             ChangeLog
  Added:                xboxdrv-0.8.5-r2.ebuild
  Log:
  Add D-Bus and systemd service files. Add slot operators and missing dbus-glib 
dep. Fixes bugs #481572 and #544752. 
https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/134 by nE0sIghT with 
my changes.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.35                 games-util/xboxdrv/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-util/xboxdrv/ChangeLog?rev=1.35&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-util/xboxdrv/ChangeLog?rev=1.35&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-util/xboxdrv/ChangeLog?r1=1.34&r2=1.35

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v
retrieving revision 1.34
retrieving revision 1.35
diff -u -r1.34 -r1.35
--- ChangeLog   20 Jan 2014 18:20:39 -0000      1.34
+++ ChangeLog   2 Jun 2015 08:35:38 -0000       1.35
@@ -1,6 +1,14 @@
 # ChangeLog for games-util/xboxdrv
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v 1.34 
2014/01/20 18:20:39 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v 1.35 
2015/06/02 08:35:38 mgorny Exp $
+
+*xboxdrv-0.8.5-r2 (02 Jun 2015)
+
+  02 Jun 2015; Michał Górny <mgo...@gentoo.org> +files/org.seul.Xboxdrv.conf,
+  +files/xboxdrv.service, +files/xboxdrv.udev-rules, +xboxdrv-0.8.5-r2.ebuild:
+  Add D-Bus and systemd service files. Add slot operators and missing dbus-glib
+  dep. Fixes bugs #481572 and #544752. 
https://github.com/gentoo/gentoo-portage-
+  rsync-mirror/pull/134 by nE0sIghT with my changes.
 
   20 Jan 2014; Michael Sterrett <mr_bon...@gentoo.org> 
-xboxdrv-0.8.4-r1.ebuild,
   -xboxdrv-0.8.4.ebuild, -xboxdrv-0.8.5.ebuild:



1.1                  games-util/xboxdrv/xboxdrv-0.8.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-util/xboxdrv/xboxdrv-0.8.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-util/xboxdrv/xboxdrv-0.8.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: xboxdrv-0.8.5-r2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/xboxdrv-0.8.5-r2.ebuild,v 
1.1 2015/06/02 08:35:38 mgorny Exp $

EAPI=5
inherit linux-info scons-utils toolchain-funcs systemd udev

MY_P=${PN}-linux-${PV}
DESCRIPTION="Userspace Xbox 360 Controller driver"
HOMEPAGE="http://pingus.seul.org/~grumbel/xboxdrv/";
SRC_URI="http://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="dev-libs/boost
        dev-libs/dbus-glib:=
        virtual/libudev:=
        sys-apps/dbus:=
        dev-libs/glib:2=
        virtual/libusb:1=
        x11-libs/libX11:="
DEPEND="${RDEPEND}
        virtual/pkgconfig"

S=${WORKDIR}/${MY_P}

CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"

src_prepare() {
        epatch "${FILESDIR}"/${P}-scons.patch
}

src_compile() {
        escons \
                BUILD=custom \
                CXX="$(tc-getCXX)" \
                AR="$(tc-getAR)" \
                RANLIB="$(tc-getRANLIB)" \
                CXXFLAGS="-Wall ${CXXFLAGS}" \
                LINKFLAGS="${LDFLAGS}"
}

src_install() {
        dobin xboxdrv
        doman doc/xboxdrv.1
        dodoc AUTHORS NEWS PROTOCOL README TODO

        newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
        newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv

        insinto /etc/dbus-1/system.d/
        doins "${FILESDIR}/org.seul.Xboxdrv.conf"

        udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
        systemd_dounit "${FILESDIR}"/xboxdrv.service
}

pkg_postinst() {
        udev_reload
}




Reply via email to