jauhien     14/05/27 16:29:18

  Modified:             ChangeLog
  Added:                lxqt-panel-0.7.0-r1.ebuild
  Removed:              lxqt-panel-0.7.0.ebuild
  Log:
  install mans
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xB2EFA1D4)

Revision  Changes    Path
1.3                  lxqt-base/lxqt-panel/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/lxqt-base/lxqt-panel/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/lxqt-base/lxqt-panel/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/lxqt-base/lxqt-panel/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-panel/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   27 May 2014 13:38:57 -0000      1.2
+++ ChangeLog   27 May 2014 16:29:18 -0000      1.3
@@ -1,6 +1,12 @@
 # ChangeLog for lxqt-base/lxqt-panel
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-panel/ChangeLog,v 1.2 
2014/05/27 13:38:57 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-panel/ChangeLog,v 1.3 
2014/05/27 16:29:18 jauhien Exp $
+
+*lxqt-panel-0.7.0-r1 (27 May 2014)
+
+  27 May 2014; Jauhien Piatlicki <jauh...@gentoo.org>
+  +lxqt-panel-0.7.0-r1.ebuild, -lxqt-panel-0.7.0.ebuild:
+  install mans
 
   27 May 2014; Jauhien Piatlicki <jauh...@gentoo.org> lxqt-panel-0.7.0.ebuild:
   Add dependencies needed for reboot/halt



1.1                  lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild?rev=1.1&content-type=text/plain

Index: lxqt-panel-0.7.0-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild,v 1.1 
2014/05/27 16:29:18 jauhien Exp $

EAPI=5
inherit cmake-utils

DESCRIPTION="LXQt desktop panel and plugins"
HOMEPAGE="http://www.lxqt.org/";

if [[ ${PV} = *9999* ]]; then
        inherit git-r3
        EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
        SRC_URI="http://lxqt.org/downloads/lxqt/${PV}/${P}.tar.xz";
        KEYWORDS="~amd64 ~x86"
        S=${WORKDIR}
fi

LICENSE="GPL-2 LGPL-2.1+"
SLOT="0"
IUSE="+alsa +clock colorpicker cpuload +desktopswitch dom +kbindicator +mainmenu
        +mount networkmonitor pulseaudio +quicklaunch screensaver sensors
        +showdesktop sysstat +taskbar teatime +tray +volume worldclock"
REQUIRED_USE="volume? ( || ( alsa pulseaudio ) )"

DEPEND="dev-qt/qtcore:4
        dev-qt/qtdbus:4
        dev-qt/qtgui:4
        >=lxde-base/menu-cache-0.3.3
        lxqt-base/liblxqt
        lxqt-base/liblxqt-mount
        lxqt-base/libsysstat
        lxqt-base/lxqt-globalkeys
        razorqt-base/libqtxdg
        x11-libs/libX11
        cpuload? ( sys-libs/libstatgrab )
        mainmenu? ( || ( sys-auth/consolekit[policykit(-)]
                sys-apps/systemd[policykit(-)] ) )
        networkmonitor? ( sys-libs/libstatgrab )
        sensors? ( sys-apps/lm_sensors )
        sysstat? ( lxqt-base/libsysstat )
        volume? ( alsa? ( media-libs/alsa-lib )
                pulseaudio? ( media-sound/pulseaudio ) )
        worldclock? ( dev-libs/icu:= )"
RDEPEND="${DEPEND}
        lxde-base/lxmenu-data"

src_configure() {
        local mycmakeargs i y
        for i in clock colorpicker cpuload desktopswitch dom kbindicator 
mainmenu mount \
                networkmonitor quicklaunch screensaver sensors showdesktop 
sysstat \
                taskbar teatime tray volume worldclock; do
                y=$(tr '[:lower:]' '[:upper:]' <<< "${i}")
                mycmakeargs+=( $(cmake-utils_use ${i} ${y}_PLUGIN) )
        done

        if use volume; then
                mycmakeargs+=( $(cmake-utils_use alsa VOLUME_USE_ALSA)
                        $(cmake-utils_use pulseaudio VOLUME_USE_PULSEAUDIO) )
        fi

        cmake-utils_src_configure
}

src_install(){
        cmake-utils_src_install
        doman panel/man/*.1
}




Reply via email to