yngwin      15/04/18 12:45:21

  Modified:             ChangeLog
  Added:                fontconfig-2.11.93.ebuild
  Removed:              fontconfig-2.10.92.ebuild
  Log:
  Version bump to development snapshot release. Roll new latin reorder patch, 
adding Liberation as default font family. Add 3 post-release patches from 
upstream. Drop old.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x4FDF9CFD2FAC514E!)

Revision  Changes    Path
1.209                media-libs/fontconfig/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/fontconfig/ChangeLog?rev=1.209&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/fontconfig/ChangeLog?rev=1.209&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/fontconfig/ChangeLog?r1=1.208&r2=1.209

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v
retrieving revision 1.208
retrieving revision 1.209
diff -u -r1.208 -r1.209
--- ChangeLog   17 Apr 2015 08:45:38 -0000      1.208
+++ ChangeLog   18 Apr 2015 12:45:21 -0000      1.209
@@ -1,6 +1,18 @@
 # ChangeLog for media-libs/fontconfig
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.208 
2015/04/17 08:45:38 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.209 
2015/04/18 12:45:21 yngwin Exp $
+
+*fontconfig-2.11.93 (18 Apr 2015)
+
+  18 Apr 2015; Ben de Groot <yng...@gentoo.org>
+  +files/fontconfig-2.11.93-addfile.patch,
+  +files/fontconfig-2.11.93-fix-sigfpe.patch,
+  +files/fontconfig-2.11.93-latin-update.patch,
+  +files/fontconfig-2.11.93-rmdead.patch, +fontconfig-2.11.93.ebuild,
+  -fontconfig-2.10.92.ebuild:
+  Version bump to development snapshot release. Roll new latin reorder patch,
+  adding Liberation as default font family. Add 3 post-release patches from
+  upstream. Drop old.
 
   17 Apr 2015; Mikle Kolyada <zlog...@gentoo.org> fontconfig-2.11.1-r2.ebuild:
   sparc stable wrt bug #520010



1.1                  media-libs/fontconfig/fontconfig-2.11.93.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/fontconfig/fontconfig-2.11.93.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/fontconfig/fontconfig-2.11.93.ebuild?rev=1.1&content-type=text/plain

Index: fontconfig-2.11.93.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.11.93.ebuild,v 1.1 
2015/04/18 12:45:21 yngwin Exp $

EAPI=5
AUTOTOOLS_AUTORECONF=yes
inherit eutils readme.gentoo autotools-multilib

DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://fontconfig.org/";
SRC_URI="http://fontconfig.org/release/${P}.tar.bz2";

LICENSE="MIT"
SLOT="1.0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd 
~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris 
~x86-solaris ~x86-winnt"
IUSE="doc static-libs"

# Purposefully dropped the xml USE flag and libxml2 support.  Expat is the
# default and used by every distro.  See bug #283191.
RDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
        >=media-libs/freetype-2.5.3-r1[${MULTILIB_USEDEP}]
        abi_x86_32? ( !app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] )"
DEPEND="${RDEPEND}
        virtual/pkgconfig
        doc? ( =app-text/docbook-sgml-dtd-3.1*
                app-text/docbook-sgml-utils[jadetex] )"
PDEPEND="!x86-winnt? ( app-eselect/eselect-fontconfig )
        virtual/ttf-fonts"

PATCHES=(
        "${FILESDIR}"/${PN}-2.10.2-docbook.patch # 310157
        "${FILESDIR}"/${PN}-2.11.93-latin-update.patch # 130466 + make 
liberation default
        "${FILESDIR}"/${PN}-2.11.93-rmdead.patch # these 3 are upstream, in 
next release
        "${FILESDIR}"/${PN}-2.11.93-addfile.patch
        "${FILESDIR}"/${PN}-2.11.93-fix-sigfpe.patch
)

MULTILIB_CHOST_TOOLS=( /usr/bin/fc-cache )

pkg_setup() {
        DOC_CONTENTS="Please make fontconfig configuration changes using
        \`eselect fontconfig\`. Any changes made to /etc/fonts/fonts.conf will 
be
        overwritten. If you need to reset your configuration to upstream 
defaults,
        delete the directory ${EROOT}etc/fonts/conf.d/ and re-emerge 
fontconfig."
}

src_configure() {
        local addfonts
        # harvest some font locations, such that users can benefit from the
        # host OS's installed fonts
        case ${CHOST} in
                *-darwin*)
                        addfonts=",/Library/Fonts,/System/Library/Fonts"
                ;;
                *-solaris*)
                        [[ -d /usr/X/lib/X11/fonts/TrueType ]] && \
                                addfonts=",/usr/X/lib/X11/fonts/TrueType"
                        [[ -d /usr/X/lib/X11/fonts/Type1 ]] && \
                                
addfonts="${addfonts},/usr/X/lib/X11/fonts/Type1"
                ;;
                *-linux-gnu)
                        use prefix && [[ -d /usr/share/fonts ]] && \
                                addfonts=",/usr/share/fonts"
                ;;
        esac

        local myeconfargs=(
                $(use_enable doc docbook)
                --enable-docs
                --localstatedir="${EPREFIX}"/var
                --with-default-fonts="${EPREFIX}"/usr/share/fonts
                --with-add-fonts="${EPREFIX}/usr/local/share/fonts${addfonts}" \
                --with-templatedir="${EPREFIX}"/etc/fonts/conf.avail
        )

        autotools-multilib_src_configure
}

multilib_src_install() {
        default

        # avoid calling this multiple times, bug #459210
        if multilib_is_native_abi; then
                # stuff installed from build-dir
                emake -C doc DESTDIR="${D}" install-man

                insinto /etc/fonts
                doins fonts.conf
        fi
}

multilib_src_install_all() {
        einstalldocs
        prune_libtool_files --all

        # fc-lang directory contains language coverage datafiles
        # which are needed to test the coverage of fonts.
        insinto /usr/share/fc-lang
        doins fc-lang/*.orth

        dodoc doc/fontconfig-user.{txt,pdf}

        if [[ -e ${ED}usr/share/doc/fontconfig/ ]];  then
                mv "${ED}"usr/share/doc/fontconfig/* "${ED}"/usr/share/doc/${P} 
|| die
                rm -rf "${ED}"usr/share/doc/fontconfig
        fi

        # Changes should be made to /etc/fonts/local.conf, and as we had
        # too much problems with broken fonts.conf we force update it ...
        echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
        doenvd "${T}"/37fontconfig

        # As of fontconfig 2.7, everything sticks their noses in here.
        dodir /etc/sandbox.d
        echo 'SANDBOX_PREDICT="/var/cache/fontconfig"' > 
"${ED}"/etc/sandbox.d/37fontconfig

        readme.gentoo_create_doc
}

pkg_preinst() {
        # Bug #193476
        # /etc/fonts/conf.d/ contains symlinks to ../conf.avail/ to include 
various
        # config files.  If we install as-is, we'll blow away user settings.
        ebegin "Syncing fontconfig configuration to system"
        if [[ -e ${EROOT}/etc/fonts/conf.d ]]; then
                for file in "${EROOT}"/etc/fonts/conf.avail/*; do
                        f=${file##*/}
                        if [[ -L ${EROOT}/etc/fonts/conf.d/${f} ]]; then
                                [[ -f ${ED}etc/fonts/conf.avail/${f} ]] \
                                        && ln -sf ../conf.avail/"${f}" 
"${ED}"etc/fonts/conf.d/ &>/dev/null
                        else
                                [[ -f ${ED}etc/fonts/conf.avail/${f} ]] \
                                        && rm "${ED}"etc/fonts/conf.d/"${f}" 
&>/dev/null
                        fi
                done
        fi
        eend $?
}

pkg_postinst() {
        einfo "Cleaning broken symlinks in "${EROOT}"etc/fonts/conf.d/"
        find -L "${EROOT}"etc/fonts/conf.d/ -type l -delete

        readme.gentoo_print_elog

        if [[ ${ROOT} = / ]]; then
                multilib_pkg_postinst() {
                        ebegin "Creating global font cache for ${ABI}"
                        "${EPREFIX}"/usr/bin/${CHOST}-fc-cache -srf
                        eend $?
                }

                multilib_parallel_foreach_abi multilib_pkg_postinst
        fi
}




Reply via email to