pacho       15/07/05 08:18:38

  Modified:             ChangeLog
  Added:                harfbuzz-0.9.41.ebuild
  Removed:              harfbuzz-0.9.35.ebuild
  Log:
  Version bump, drop old
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  Changes    Path
1.112                media-libs/harfbuzz/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/harfbuzz/ChangeLog?rev=1.112&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/harfbuzz/ChangeLog?rev=1.112&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/harfbuzz/ChangeLog?r1=1.111&r2=1.112

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v
retrieving revision 1.111
retrieving revision 1.112
diff -u -r1.111 -r1.112
--- ChangeLog   31 May 2015 10:56:39 -0000      1.111
+++ ChangeLog   5 Jul 2015 08:18:38 -0000       1.112
@@ -1,6 +1,12 @@
 # ChangeLog for media-libs/harfbuzz
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.111 
2015/05/31 10:56:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.112 
2015/07/05 08:18:38 pacho Exp $
+
+*harfbuzz-0.9.41 (05 Jul 2015)
+
+  05 Jul 2015; Pacho Ramos <pa...@gentoo.org> +harfbuzz-0.9.41.ebuild,
+  -harfbuzz-0.9.35.ebuild:
+  Version bump, drop old
 
   31 May 2015; Markus Meier <mae...@gentoo.org> harfbuzz-0.9.38.ebuild:
   arm stable, bug #544792



1.1                  media-libs/harfbuzz/harfbuzz-0.9.41.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.41.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.41.ebuild?rev=1.1&content-type=text/plain

Index: harfbuzz-0.9.41.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.41.ebuild,v 
1.1 2015/07/05 08:18:38 pacho Exp $

EAPI=5

EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
[[ ${PV} == 9999 ]] && inherit git-r3 autotools

PYTHON_COMPAT=( python2_7 )

inherit eutils libtool multilib-minimal python-any-r1

DESCRIPTION="An OpenType text shaping engine"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz";
[[ ${PV} == 9999 ]] || 
SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2";

LICENSE="Old-MIT ISC icu"
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
[[ ${PV} == 9999 ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh 
~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos 
~x86-macos ~x64-solaris"

IUSE="+cairo fontconfig +glib +graphite icu +introspection static-libs test 
+truetype"
REQUIRED_USE="introspection? ( glib )"

RDEPEND="
        cairo? ( x11-libs/cairo:= )
        fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
        glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
        graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
        icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
        introspection? ( >=dev-libs/gobject-introspection-1.34 )
        truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
        dev-util/gtk-doc-am
        virtual/pkgconfig
        test? ( ${PYTHON_DEPS} )
"
# eautoreconf requires gobject-introspection-common
# ragel needed if regenerating *.hh files from *.rl
[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
        >=dev-libs/gobject-introspection-common-1.34
        dev-util/ragel
"

pkg_setup() {
        use test && python-any-r1_pkg_setup
}

src_prepare() {
        if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
                # on Darwin/Solaris we need to link with g++, like automake 
defaults
                # to, but overridden by upstream because on Linux this is not
                # necessary, bug #449126
                sed -i \
                        -e 's/\<LINK\>/CXXLINK/' \
                        src/Makefile.am || die
                sed -i \
                        -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
                        src/Makefile.in || die
                sed -i \
                        -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
                        test/api/Makefile.in || die
        fi

        [[ ${PV} == 9999 ]] && eautoreconf
        elibtoolize # for Solaris

        # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
        sed -e 's#tests/arabic-fallback-shaping.tests##' -i 
test/shaping/Makefile.in || die "sed failed"
}

multilib_src_configure() {
        ECONF_SOURCE="${S}" \
        # harfbuzz-gobject only used for instrospection, bug #535852
        econf \
                --without-coretext \
                --without-uniscribe \
                $(use_enable static-libs static) \
                $(multilib_native_use_with cairo) \
                $(use_with fontconfig) \
                $(use_with glib) \
                $(use_with introspection gobject) \
                $(use_with graphite graphite2) \
                $(use_with icu) \
                $(multilib_native_use_enable introspection) \
                $(use_with truetype freetype)

        if multilib_is_native_abi; then
                ln -s "${S}"/docs/reference/html docs/reference/html || die
        fi
}

multilib_src_install_all() {
        einstalldocs
        prune_libtool_files --modules
}




Reply via email to