rich0       14/09/08 16:31:22

  Modified:             metadata.xml ChangeLog
  Added:                mythplugins-0.27.3_p20140907.ebuild
  Log:
  Bump, fix dependencies and tie to mythtv USE flags.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x08C170DE55EC123A)

Revision  Changes    Path
1.4                  media-plugins/mythplugins/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/metadata.xml?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/metadata.xml?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/metadata.xml?r1=1.3&r2=1.4

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/metadata.xml,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- metadata.xml        3 Apr 2013 12:42:15 -0000       1.3
+++ metadata.xml        8 Sep 2014 16:31:22 -0000       1.4
@@ -6,6 +6,7 @@
                <flag name='cdr'>Allows MythMusic to burn CD-Rs</flag>
                <flag name='exif'>Allows MythGallery to read EXIF data from 
photos</flag>
                <flag name='fftw'>Adds visual effects to MythMusic when playing 
back music</flag>
+               <flag name="hls">HTTP Live Streaming support</flag>
                <flag name='raw'>Allows MythGallery to view photos saved in RAW 
format</flag>
 
                <flag name='mytharchive'>Allows you to archive recorded content 
to CD or DVD</flag>



1.33                 media-plugins/mythplugins/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/ChangeLog?rev=1.33&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/ChangeLog?rev=1.33&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/ChangeLog?r1=1.32&r2=1.33

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v
retrieving revision 1.32
retrieving revision 1.33
diff -u -r1.32 -r1.33
--- ChangeLog   21 Aug 2014 01:07:16 -0000      1.32
+++ ChangeLog   8 Sep 2014 16:31:22 -0000       1.33
@@ -1,6 +1,12 @@
 # ChangeLog for media-plugins/mythplugins
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v 1.32 
2014/08/21 01:07:16 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v 1.33 
2014/09/08 16:31:22 rich0 Exp $
+
+*mythplugins-0.27.3_p20140907 (08 Sep 2014)
+
+  08 Sep 2014; Richard Freeman <ri...@gentoo.org>
+  +mythplugins-0.27.3_p20140907.ebuild, metadata.xml:
+  Bump, fix dependencies and tie to mythtv USE flags.
 
   21 Aug 2014; Richard Freeman <ri...@gentoo.org>
   -mythplugins-0.26.0_p20130322.ebuild, -mythplugins-0.26.0_p20130419.ebuild,



1.1                  
media-plugins/mythplugins/mythplugins-0.27.3_p20140907.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/mythplugins-0.27.3_p20140907.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/mythplugins/mythplugins-0.27.3_p20140907.ebuild?rev=1.1&content-type=text/plain

Index: mythplugins-0.27.3_p20140907.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/mythplugins/mythplugins-0.27.3_p20140907.ebuild,v
 1.1 2014/09/08 16:31:22 rich0 Exp $

EAPI=5

PYTHON_DEPEND="2:2.6"
BACKPORTS="2d4a7c9235287b0589035974bff282e3f2e9a7e5"
MY_P=${P%_p*}

inherit eutils python

DESCRIPTION="Official MythTV plugins"
HOMEPAGE="http://www.mythtv.org";
SRC_URI="https://github.com/MythTV/mythtv/archive/v0.27.3.tar.gz -> 
mythtv-0.27.3.tar.gz
        
${BACKPORTS:+http://dev.gentoo.org/~rich0/distfiles/${MY_P}-${BACKPORTS}.tar.xz}";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

MYTHPLUGINS="mytharchive mythbrowser mythgallery mythgame \
mythmusic mythnetvision mythnews mythweather mythzoneminder"

IUSE="${MYTHPLUGINS} alsa cdda cdr exif fftw hls ieee1394 libass raw theora 
vorbis xml xvid"

DEPEND="!media-plugins/mytharchive
        !media-plugins/mythbrowser
        !media-plugins/mythgallery
        !media-plugins/mythgame
        !media-plugins/mythmovies
        !media-plugins/mythmusic
        !media-plugins/mythnetvision
        !media-plugins/mythnews
        !media-plugins/mythweather
        
=media-tv/mythtv-${PV}*:=[alsa=,hls=,ieee1394=,libass=,python,theora=,vorbis=,xml=,xvid=]
        dev-libs/glib:=
        xml? ( >=dev-libs/libxml2-2.6.0:= )
        dev-qt/qtcore:=
        dev-qt/qtgui:=
        dev-qt/qtopengl:=
        dev-qt/qtsql:=
        dev-libs/openssl:=
        alsa? ( >=media-libs/alsa-lib-1.0.24:= )
        hls? (
                media-libs/faac:=
                media-libs/libvpx:=
                >=media-libs/x264-0.0.20111220:=
                >=media-sound/lame-3.93.1
        )
        media-libs/freetype:=
        libass? ( >=media-libs/libass-0.9.11:= )
        media-libs/libpng:=
        theora? ( media-libs/libtheora:= media-libs/libogg:= )
        vorbis? ( media-libs/libogg:= )
        xvid? ( >=media-libs/xvid-1.1.0:= )
        virtual/libudev:=
        ieee1394? (
                >=sys-libs/libraw1394-1.2.0:=
                >=sys-libs/libavc1394-0.5.3:=
                >=media-libs/libiec61883-1.0.0:=
        )
        x11-libs/libX11:=
        sys-libs/zlib:=
        x11-libs/libXext:=
        x11-libs/libXinerama:=
        x11-libs/libXrandr:=
        x11-libs/libXv:=
        x11-libs/libXxf86vm:=
        fftw? ( sci-libs/fftw:= )
        sys-apps/util-linux:=
        mythzoneminder? ( virtual/mysql:= )
        mytharchive? (
                app-cdr/dvd+rw-tools
                virtual/python-imaging:=
                media-video/dvdauthor
                media-video/mjpegtools[png]
                media-video/transcode
                virtual/cdrtools
        )
        mythgallery? (
                media-libs/tiff:=
                virtual/opengl
                exif? ( >media-libs/libexif-0.6.9:= )
                raw? ( media-gfx/dcraw )
        )
        mythmusic? (
                >=media-libs/flac-1.1.2:=
                >=media-libs/taglib-1.6:=
                vorbis? ( >=media-libs/libvorbis-1.0:= )
                virtual/opengl
                cdda? (
                        dev-libs/libcdio:=
                        cdr? ( virtual/cdrtools )
                )

        )
        mythnetvision? (
                =dev-lang/python-2*:=[xml]
                dev-python/lxml:=
                dev-python/mysql-python:=
                dev-python/oauth:=
                dev-python/pycurl:=
        )
        mythweather? (
                dev-perl/DateManip
                dev-perl/DateTime-Format-ISO8601
                >=dev-perl/DateTime-1
                dev-perl/ImageSize
                dev-perl/JSON
                dev-perl/SOAP-Lite
                dev-perl/XML-Simple
                dev-perl/XML-Parser
                dev-perl/XML-SAX
                dev-perl/XML-XPath
        )
        mythbrowser? (
                dev-qt/qtwebkit:=
        )"
RDEPEND="${DEPEND}"

REQUIRED_USE="
        cdda? ( mythmusic )
        cdr? ( mythmusic cdda )
        exif? ( mythgallery )
        fftw? ( mythmusic )
        mythnews? ( mythbrowser )
        raw? ( mythgallery )"

S="${WORKDIR}/mythtv-0.27.3/mythplugins"

pkg_setup() {
        python_set_active_version 2
        python_pkg_setup
}

src_prepare() {
        [[ -n ${BACKPORTS} ]] && \
                EPATCH_FORCE=yes EPATCH_SUFFIX="patch" 
EPATCH_SOURCE="${WORKDIR}/${MY_P}/patches" \
                        epatch

        epatch_user
}

src_configure() {
        ./configure \
                --prefix=/usr \
                --python=python2 \
                --enable-opengl \
                $(use_enable mythzoneminder) \
                $(use_enable mytharchive) \
                $(use_enable mythbrowser) \
                $(use_enable mythgallery) \
                $(use_enable mythgame) \
                $(use_enable mythmusic) \
                $(use_enable mythnetvision) \
                $(use_enable mythnews) \
                $(use_enable mythweather) \
                $(use_enable cdda cdio) \
                $(use_enable exif) \
                $(use_enable exif new-exif) \
                $(use_enable raw dcraw) \
                || die "configure failed"
}

src_install() {
        emake INSTALL_ROOT="${D}" install || die "make install failed"
}




Reply via email to