jer         14/08/22 15:25:20

  Modified:             ChangeLog
  Added:                fail2ban-99999999.ebuild
  Log:
  Add live ebuild.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.143                net-analyzer/fail2ban/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?rev=1.143&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?rev=1.143&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?r1=1.142&r2=1.143

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v
retrieving revision 1.142
retrieving revision 1.143
diff -u -r1.142 -r1.143
--- ChangeLog   22 Aug 2014 15:15:59 -0000      1.142
+++ ChangeLog   22 Aug 2014 15:25:20 -0000      1.143
@@ -1,6 +1,11 @@
 # ChangeLog for net-analyzer/fail2ban
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.142 
2014/08/22 15:15:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.143 
2014/08/22 15:25:20 jer Exp $
+
+*fail2ban-99999999 (22 Aug 2014)
+
+  22 Aug 2014; Jeroen Roovers <j...@gentoo.org> +fail2ban-99999999.ebuild:
+  Add live ebuild.
 
 *fail2ban-0.9.0-r2 (22 Aug 2014)
 *fail2ban-0.8.14 (22 Aug 2014)



1.1                  net-analyzer/fail2ban/fail2ban-99999999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild?rev=1.1&content-type=text/plain

Index: fail2ban-99999999.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild,v 1.1 
2014/08/22 15:25:20 jer Exp $

EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
PYTHON_REQ_USE="sqlite"

inherit distutils-r1 git-r3 systemd vcs-snapshot

DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="http://www.fail2ban.org/";
EGIT_REPO_URI="https://github.com/${PN}/${PN}/";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="selinux"

DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
RDEPEND="net-misc/whois
        virtual/mta
        virtual/logger
        net-firewall/iptables
        selinux? ( sec-policy/selinux-fail2ban )"

DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )

src_unpack() {
        git-r3_src_unpack
}

src_prepare() {
        # Replace /var/run with /run, but not in the top source directory
        sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f -mindepth 2 
) || die

        distutils-r1_src_prepare
}

python_test() {
        ${EPYTHON} bin/${PN}-testcases
}

src_install() {
        distutils-r1_src_install

        rm -rf "${D}"/usr/share/doc/${PN}

        # not FILESDIR
        newconfd files/gentoo-confd ${PN}
        newinitd files/gentoo-initd ${PN}
        systemd_dounit files/${PN}.service
        systemd_dotmpfilesd files/${PN}-tmpfiles.conf
        doman man/*.{1,5}

        # Use INSTALL_MASK  if you do not want to touch /etc/logrotate.d.
        # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
        insinto /etc/logrotate.d
        newins files/${PN}-logrotate ${PN}
}

pkg_preinst() {
        has_version "<${CATEGORY}/${PN}-0.7"
        previous_less_than_0_7=$?
}

pkg_postinst() {
        if [[ $previous_less_than_0_7 = 0 ]] ; then
                elog
                elog "Configuration files are now in /etc/fail2ban/"
                elog "You probably have to manually update your configuration"
                elog "files before restarting Fail2ban!"
                elog
                elog "Fail2ban is not installed under /usr/lib anymore. The"
                elog "new location is under /usr/share."
                elog
                elog "You are upgrading from version 0.6.x, please see:"
                elog 
"http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8";
        fi
        if ! has_version ${CATEGORY}/${PN}; then
                if ! has_version dev-python/pyinotify && ! has_version 
app-admin/gamin; then
                        elog "For most jail.conf configurations, it is 
recommended you install either"
                        elog "dev-python/pyinotify or app-admin/gamin (in order 
of preference)"
                        elog "to control how log file modifications are 
detected"
                fi
                if ! has_version dev-lang/python[sqlite]; then
                        elog "If you want to use ${PN}'s persistent database, 
then reinstall"
                        elog "dev-lang/python with USE=sqlite"
                fi
                if has_version sys-apps/systemd[-python]; then
                        elog "If you want to track logins through 
sys-apps/systemd's"
                        elog "journal backend, then reinstall sys-apps/systemd 
with USE=python"
                fi
        fi
}




Reply via email to