jer         14/08/22 15:15:59

  Modified:             ChangeLog
  Added:                fail2ban-0.9.0-r2.ebuild fail2ban-0.8.14.ebuild
  Removed:              fail2ban-0.9.0-r1.ebuild
  Log:
  Version bump. Add patch for loglevel expected to be an int (bug #520536 by 
Fabio Scaccabarozzi).
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.142                net-analyzer/fail2ban/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?rev=1.142&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?rev=1.142&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?r1=1.141&r2=1.142

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v
retrieving revision 1.141
retrieving revision 1.142
diff -u -r1.141 -r1.142
--- ChangeLog   12 Jul 2014 13:59:47 -0000      1.141
+++ ChangeLog   22 Aug 2014 15:15:59 -0000      1.142
@@ -1,6 +1,15 @@
 # ChangeLog for net-analyzer/fail2ban
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.141 
2014/07/12 13:59:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.142 
2014/08/22 15:15:59 jer Exp $
+
+*fail2ban-0.9.0-r2 (22 Aug 2014)
+*fail2ban-0.8.14 (22 Aug 2014)
+
+  22 Aug 2014; Jeroen Roovers <j...@gentoo.org> +fail2ban-0.8.14.ebuild,
+  -fail2ban-0.9.0-r1.ebuild, +fail2ban-0.9.0-r2.ebuild,
+  +files/fail2ban-0.9.0-loglevel-int.patch:
+  Version bump. Add patch for loglevel expected to be an int (bug #520536 by
+  Fabio Scaccabarozzi).
 
   12 Jul 2014; Jeroen Roovers <j...@gentoo.org> fail2ban-0.9.0-r1.ebuild:
   Set USE=sqlite dependency on dev-lang/python (bug #507306).



1.1                  net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild?rev=1.1&content-type=text/plain

Index: fail2ban-0.9.0-r2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild,v 1.1 
2014/08/22 15:15:59 jer Exp $

EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
PYTHON_REQ_USE="sqlite"

inherit distutils-r1 systemd vcs-snapshot

DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="http://www.fail2ban.org/";
SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="selinux"

DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
RDEPEND="net-misc/whois
        virtual/mta
        virtual/logger
        net-firewall/iptables
        selinux? ( sec-policy/selinux-fail2ban )"

DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )

src_prepare() {
        # Replace /var/run with /run, but not in the top source directory
        sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f -mindepth 2 
) || die

        # Do not install /run/fail2ban
        epatch "${FILESDIR}"/${P}-empty-run-dir.patch

        # Upstream patches
        epatch "${FILESDIR}"/${P}-python3-regex.patch
        epatch "${FILESDIR}"/${P}-loglevel-int.patch

        distutils-r1_src_prepare
}

python_test() {
        ${EPYTHON} bin/${PN}-testcases
}

src_install() {
        distutils-r1_src_install

        rm -rf "${D}"/usr/share/doc/${PN}

        # not FILESDIR
        newconfd files/gentoo-confd ${PN}
        newinitd files/gentoo-initd ${PN}
        systemd_dounit files/${PN}.service
        systemd_dotmpfilesd files/${PN}-tmpfiles.conf
        doman man/*.{1,5}

        # Use INSTALL_MASK  if you do not want to touch /etc/logrotate.d.
        # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
        insinto /etc/logrotate.d
        newins files/${PN}-logrotate ${PN}
}

pkg_preinst() {
        has_version "<${CATEGORY}/${PN}-0.7"
        previous_less_than_0_7=$?
}

pkg_postinst() {
        if [[ $previous_less_than_0_7 = 0 ]] ; then
                elog
                elog "Configuration files are now in /etc/fail2ban/"
                elog "You probably have to manually update your configuration"
                elog "files before restarting Fail2ban!"
                elog
                elog "Fail2ban is not installed under /usr/lib anymore. The"
                elog "new location is under /usr/share."
                elog
                elog "You are upgrading from version 0.6.x, please see:"
                elog 
"http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8";
        fi
        if ! has_version ${CATEGORY}/${PN}; then
                if ! has_version dev-python/pyinotify && ! has_version 
app-admin/gamin; then
                        elog "For most jail.conf configurations, it is 
recommended you install either"
                        elog "dev-python/pyinotify or app-admin/gamin (in order 
of preference)"
                        elog "to control how log file modifications are 
detected"
                fi
                if ! has_version dev-lang/python[sqlite]; then
                        elog "If you want to use ${PN}'s persistent database, 
then reinstall"
                        elog "dev-lang/python with USE=sqlite"
                fi
                if has_version sys-apps/systemd[-python]; then
                        elog "If you want to track logins through 
sys-apps/systemd's"
                        elog "journal backend, then reinstall sys-apps/systemd 
with USE=python"
                fi
        fi
}



1.1                  net-analyzer/fail2ban/fail2ban-0.8.14.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild?rev=1.1&content-type=text/plain

Index: fail2ban-0.8.14.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild,v 1.1 
2014/08/22 15:15:59 jer Exp $

EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
DISTUTILS_SINGLE_IMPL=yes

inherit distutils-r1 systemd vcs-snapshot

DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="http://www.fail2ban.org/";
SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="selinux"

DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
RDEPEND="net-misc/whois
        virtual/mta
        virtual/logger
        net-firewall/iptables
        selinux? ( sec-policy/selinux-fail2ban )"

src_prepare() {
        sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f ) || die
}

src_test() {
        ./${PN}-testcases-all
}

DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )

src_install() {
        distutils-r1_src_install

        rm -rf "${D}"/usr/share/doc/${PN}

        # not FILESDIR
        newconfd files/gentoo-confd ${PN}
        newinitd files/gentoo-initd ${PN}
        systemd_dounit files/${PN}.service
        systemd_dotmpfilesd files/${PN}-tmpfiles.conf
        doman man/*.{1,5}

        # Use INSTALL_MASK  if you do not want to touch /etc/logrotate.d.
        # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
        insinto /etc/logrotate.d
        newins files/${PN}-logrotate ${PN}
}

pkg_preinst() {
        has_version "<${CATEGORY}/${PN}-0.7"
        previous_less_than_0_7=$?
}

pkg_postinst() {
        if [[ $previous_less_than_0_7 = 0 ]] ; then
                elog
                elog "Configuration files are now in /etc/fail2ban/"
                elog "You probably have to manually update your configuration"
                elog "files before restarting Fail2ban!"
                elog
                elog "Fail2ban is not installed under /usr/lib anymore. The"
                elog "new location is under /usr/share."
                elog
                elog "You are upgrading from version 0.6.x, please see:"
                elog 
"http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8";
        fi
        if ! has_version ${CATEGORY}/${PN} && \
                ! has_version dev-python/pyinotify && ! has_version 
app-admin/gamin; then
                elog "For most jail.conf configurations, it is recommended you 
install either"
                elog "dev-python/pyinotify or app-admin/gamin (in order of 
preference)"
                elog "to control how log file modifications are detected"
        fi
}




Reply via email to