chutzpah    15/07/28 23:06:39

  Modified:             ChangeLog
  Added:                dnsmasq-2.74.ebuild
  Removed:              dnsmasq-2.73.ebuild dnsmasq-2.72.ebuild
                        dnsmasq-2.72-r1.ebuild
  Log:
  Version bump, remove old.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0xE3F69979BB4B8928DA78E3D17CBF44EF)

Revision  Changes    Path
1.280                net-dns/dnsmasq/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/dnsmasq/ChangeLog?rev=1.280&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/dnsmasq/ChangeLog?rev=1.280&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/dnsmasq/ChangeLog?r1=1.279&r2=1.280

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v
retrieving revision 1.279
retrieving revision 1.280
diff -u -r1.279 -r1.280
--- ChangeLog   24 Jul 2015 09:37:10 -0000      1.279
+++ ChangeLog   28 Jul 2015 23:06:39 -0000      1.280
@@ -1,6 +1,12 @@
 # ChangeLog for net-dns/dnsmasq
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.279 
2015/07/24 09:37:10 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.280 
2015/07/28 23:06:39 chutzpah Exp $
+
+*dnsmasq-2.74 (28 Jul 2015)
+
+  28 Jul 2015; Patrick McLean <chutz...@gentoo.org> +dnsmasq-2.74.ebuild,
+  -dnsmasq-2.72-r1.ebuild, -dnsmasq-2.72.ebuild, -dnsmasq-2.73.ebuild:
+  Version bump, remove old.
 
   24 Jul 2015; Mikle Kolyada <zlog...@gentoo.org> dnsmasq-2.72-r2.ebuild:
   ia64 stable wrt bug #547966



1.1                  net-dns/dnsmasq/dnsmasq-2.74.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.74.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.74.ebuild?rev=1.1&content-type=text/plain

Index: dnsmasq-2.74.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.74.ebuild,v 1.1 
2015/07/28 23:06:39 chutzpah Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic user systemd

DESCRIPTION="Small forwarding DNS server"
HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html";
SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz";

LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh 
~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec idn +inotify ipv6 lua nls 
script selinux static tftp"
DM_LINGUAS="de es fi fr id it no pl pt_BR ro"
for dm_lingua in ${DM_LINGUAS}; do
        IUSE+=" linguas_${dm_lingua}"
done

CDEPEND="dbus? ( sys-apps/dbus )
        idn? ( net-dns/libidn )
        lua? (
                || (
                        dev-lang/lua:0
                        dev-lang/lua:5.1
                )
        )
        conntrack? ( net-libs/libnetfilter_conntrack )
        nls? (
                sys-devel/gettext
                net-dns/libidn
        )
"

DEPEND="${CDEPEND}
        app-arch/xz-utils
        dnssec? (
                dev-libs/nettle[gmp]
                static? (
                        dev-libs/nettle[static-libs(+)]
                )
        )
        virtual/pkgconfig"

RDEPEND="${CDEPEND}
        dnssec? (
                !static? (
                        dev-libs/nettle[gmp]
                )
        )
        selinux? ( sec-policy/selinux-dnsmasq )
"

REQUIRED_USE="dhcp-tools? ( dhcp )
        lua? ( script )"

use_have() {
        local useflag no_only uword
        if [[ $1 == '-n' ]]; then
                no_only=1
                shift
        fi
        useflag="${1}"
        shift

        uword="${1:-${useflag}}"
        shift

        while [[ ${uword} ]]; do
                uword=${uword^^*}

                if ! use "${useflag}"; then
                        echo -n " -DNO_${uword}"
                elif [[ -z "${no_only}" ]]; then
                        echo -n " -DHAVE_${uword}"
                fi
                uword="${1}"
                shift
        done
}

pkg_pretend() {
        if use static; then
                einfo "Only sys-libs/gmp and dev-libs/nettle are statically 
linked."
                use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; 
the static USE flag is ignored."
        fi
}

pkg_setup() {
        enewgroup dnsmasq
        enewuser dnsmasq -1 -1 /dev/null dnsmasq
}

src_prepare() {
        sed -i -r 's:lua5.[0-9]+:lua:' Makefile
        sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
}

src_configure() {
        COPTS="$(use_have -n auth-dns auth)"
        COPTS+="$(use_have conntrack)"
        COPTS+="$(use_have dbus)"
        COPTS+="$(use_have idn)"
        COPTS+="$(use_have -n inotify)"
        COPTS+="$(use_have -n dhcp dhcp dhcp6)"
        COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
        COPTS+="$(use_have lua luascript)"
        COPTS+="$(use_have -n script)"
        COPTS+="$(use_have -n tftp)"
        COPTS+="$(use_have dnssec)"
        COPTS+="$(use_have static dnssec_static)"
}

src_compile() {
        emake \
                PREFIX=/usr \
                MANDIR=/usr/share/man \
                CC="$(tc-getCC)" \
                CFLAGS="${CFLAGS}" \
                LDFLAGS="${LDFLAGS}" \
                COPTS="${COPTS}" \
                CONFFILE="/etc/${PN}.conf" \
                all$(use nls && echo "-i18n")

        use dhcp-tools && emake -C contrib/wrt \
                PREFIX=/usr \
                MANDIR=/usr/share/man \
                CC="$(tc-getCC)" \
                CFLAGS="${CFLAGS}" \
                LDFLAGS="${LDFLAGS}" \
                all
}

src_install() {
        local lingua puid
        emake \
                PREFIX=/usr \
                MANDIR=/usr/share/man \
                COPTS="${COPTS}" \
                DESTDIR="${D}" \
                install$(use nls && echo "-i18n")

        for lingua in ${DM_LINGUAS}; do
                use linguas_${lingua} || rm -rf 
"${D}"/usr/share/locale/${lingua}
        done
        [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty 
"${D}"/usr/share/locale/

        dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
        dodoc -r logo

        dodoc CHANGELOG FAQ
        dohtml *.html

        newinitd "${FILESDIR}"/dnsmasq-init-r2 ${PN}
        newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}

        insinto /etc
        newins dnsmasq.conf.example dnsmasq.conf

        insinto /usr/share/dnsmasq
        doins trust-anchors.conf

        if use dhcp; then
                dodir /var/lib/misc
                newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r1 ${PN}
        fi
        if use dbus; then
                insinto /etc/dbus-1/system.d
                doins dbus/dnsmasq.conf
        fi

        if use dhcp-tools; then
                dosbin contrib/wrt/{dhcp_release,dhcp_lease_time}
                doman contrib/wrt/{dhcp_release,dhcp_lease_time}.1
        fi

        systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service

}

pkg_preinst() {
        # temporary workaround to (hopefully) prevent leases file from being 
removed
        [[ -f /var/lib/misc/dnsmasq.leases ]] && cp 
/var/lib/misc/dnsmasq.leases "${T}"
}

pkg_postinst() {
        # temporary workaround to (hopefully) prevent leases file from being 
removed
        [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases 
/var/lib/misc/dnsmasq.leases
}




Reply via email to