pacho       15/03/29 12:51:26

  Modified:             farstream-0.2.7.ebuild farstream-0.1.2-r2.ebuild
                        ChangeLog
  Removed:              farstream-0.2.4.ebuild
  Log:
  Drop msn USE as libmimic will be removed (#489552), drop old.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  Changes    Path
1.7                  net-libs/farstream/farstream-0.2.7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.2.7.ebuild?rev=1.7&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.2.7.ebuild?rev=1.7&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.2.7.ebuild?r1=1.6&r2=1.7

Index: farstream-0.2.7.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.2.7.ebuild,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- farstream-0.2.7.ebuild      29 Mar 2015 11:12:21 -0000      1.6
+++ farstream-0.2.7.ebuild      29 Mar 2015 12:51:26 -0000      1.7
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.2.7.ebuild,v 
1.6 2015/03/29 11:12:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.2.7.ebuild,v 
1.7 2015/03/29 12:51:26 pacho Exp $
 
 EAPI="5"
 GCONF_DEBUG="no"
@@ -15,11 +15,12 @@
 
 LICENSE="LGPL-2.1+"
 KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux 
~x86-linux"
-IUSE="+introspection msn test upnp"
+IUSE="+introspection test upnp"
 
 SLOT="0.2/5" # .so version
 
 # Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
 RESTRICT="test"
 
 COMMONDEPEND="
@@ -34,7 +35,6 @@
        media-libs/gst-plugins-good:1.0
        media-libs/gst-plugins-bad:1.0
        media-plugins/gst-plugins-libnice:1.0
-       msn? ( media-plugins/gst-plugins-mimic:1.0 )
 "
 DEPEND="${COMMONDEPEND}
        ${PYTHON_DEPS}
@@ -51,7 +51,6 @@
 
 src_configure() {
        
plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
-       use msn && plugins="${plugins},fsmsnconference"
        gnome2_src_configure \
                --disable-static \
                $(use_enable introspection) \
@@ -66,13 +65,3 @@
        addpredict /dev
        gnome2_src_compile
 }
-
-src_test() {
-       # FIXME: do an out-of-tree build for tests if USE=-msn
-       if ! use msn; then
-               elog "Tests disabled without msn use flag"
-               return
-       fi
-
-       emake -j1 check
-}



1.9                  net-libs/farstream/farstream-0.1.2-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild?r1=1.8&r2=1.9

Index: farstream-0.1.2-r2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- farstream-0.1.2-r2.ebuild   15 Mar 2015 13:29:51 -0000      1.8
+++ farstream-0.1.2-r2.ebuild   29 Mar 2015 12:51:26 -0000      1.9
@@ -1,9 +1,8 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild,v 1.8 
2015/03/15 13:29:51 pacho Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild,v 1.9 
2015/03/29 12:51:26 pacho Exp $
 
 EAPI="5"
-
 PYTHON_COMPAT=( python2_7 )
 
 inherit eutils python-single-r1
@@ -14,7 +13,9 @@
 
 LICENSE="LGPL-2.1+"
 KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux 
~x86-linux"
-IUSE="+introspection python msn test upnp"
+
+IUSE="+introspection python test upnp"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
 SLOT="0.1"
 
@@ -38,7 +39,6 @@
        || (
                >=media-plugins/gst-plugins-libnice-0.1.0:0.10
                <=net-libs/libnice-0.1.3[gstreamer] )
-       msn? ( >=media-plugins/gst-plugins-mimic-0.10.17:0.10 )
        !net-libs/farsight2
 "
 # This package is just a rename from farsight2
@@ -54,6 +54,9 @@
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }
@@ -65,7 +68,6 @@
 
 src_configure() {
        
plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
-       use msn && plugins="${plugins},fsmsnconference"
        econf --disable-static \
                $(use_enable introspection) \
                $(use_enable python) \
@@ -81,13 +83,3 @@
        # Remove .la files since static libs are no longer being installed
        find "${D}" -name '*.la' -exec rm -f '{}' + || die
 }
-
-src_test() {
-       # FIXME: do an out-of-tree build for tests if USE=-msn
-       if ! use msn; then
-               elog "Tests disabled without msn use flag"
-               return
-       fi
-
-       emake -j1 check
-}



1.54                 net-libs/farstream/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/ChangeLog?rev=1.54&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/ChangeLog?rev=1.54&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/ChangeLog?r1=1.53&r2=1.54

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v
retrieving revision 1.53
retrieving revision 1.54
diff -u -r1.53 -r1.54
--- ChangeLog   29 Mar 2015 11:12:21 -0000      1.53
+++ ChangeLog   29 Mar 2015 12:51:26 -0000      1.54
@@ -1,6 +1,10 @@
 # ChangeLog for net-libs/farstream
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.53 
2015/03/29 11:12:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.54 
2015/03/29 12:51:26 pacho Exp $
+
+  29 Mar 2015; Pacho Ramos <pa...@gentoo.org> -farstream-0.2.4.ebuild,
+  farstream-0.1.2-r2.ebuild, farstream-0.2.7.ebuild:
+  Drop msn USE as libmimic will be removed (#489552), drop old.
 
   29 Mar 2015; Jeroen Roovers <j...@gentoo.org> farstream-0.2.7.ebuild:
   Stable for HPPA (bug #534012).




Reply via email to