jauhien     15/07/05 20:43:27

  Modified:             ChangeLog
  Added:                coq-8.4_p6.ebuild
  Log:
  version bump: close bug 553942, thanks to  OGINO Masanori
  
  (Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key 
B2EFA1D4)

Revision  Changes    Path
1.88                 sci-mathematics/coq/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/coq/ChangeLog?rev=1.88&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/coq/ChangeLog?rev=1.88&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/coq/ChangeLog?r1=1.87&r2=1.88

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v
retrieving revision 1.87
retrieving revision 1.88
diff -u -r1.87 -r1.88
--- ChangeLog   27 Jun 2015 09:48:20 -0000      1.87
+++ ChangeLog   5 Jul 2015 20:43:27 -0000       1.88
@@ -1,6 +1,11 @@
 # ChangeLog for sci-mathematics/coq
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.87 
2015/06/27 09:48:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.88 
2015/07/05 20:43:27 jauhien Exp $
+
+*coq-8.4_p6 (05 Jul 2015)
+
+  05 Jul 2015; Jauhien Piatlicki <jauh...@gentoo.org> +coq-8.4_p6.ebuild:
+  version bump: close bug 553942, thanks to  OGINO Masanori
 
   27 Jun 2015; Agostino Sarubbo <a...@gentoo.org> coq-8.4_p5.ebuild:
   Stable for amd64, wrt bug #553322



1.1                  sci-mathematics/coq/coq-8.4_p6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/coq/coq-8.4_p6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/coq/coq-8.4_p6.ebuild?rev=1.1&content-type=text/plain

Index: coq-8.4_p6.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p6.ebuild,v 1.1 
2015/07/05 20:43:27 jauhien Exp $

EAPI="5"

inherit eutils multilib

MY_PV=${PV/_p/pl}
MY_P=${PN}-${MY_PV}

DESCRIPTION="Proof assistant written in O'Caml"
HOMEPAGE="http://coq.inria.fr/";
SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz";

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gtk debug +ocamlopt doc camlp5"

RDEPEND="
        >=dev-lang/ocaml-3.11.2:=[ocamlopt?]
        camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
        !camlp5? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )
        gtk? ( >=dev-ml/lablgtk-2.10.1:=[ocamlopt?] )"
DEPEND="${RDEPEND}
        doc? (
                media-libs/netpbm[png,zlib]
                virtual/latex-base
                dev-tex/hevea
                dev-tex/xcolor
                dev-texlive/texlive-pictures
                dev-texlive/texlive-mathextra
                dev-texlive/texlive-latexextra
                )"

S=${WORKDIR}/${MY_P}

src_prepare() {
        epatch "${FILESDIR}/${PN}-8.4_p5-do-not-install-revision.patch"
        # Fix generation of the index_urls.txt file with Gentoo dev-tex/hevea 
versions.
        # 
http://lists.gforge.inria.fr/pipermail/coq-commits/2014-October/013582.html
        epatch "${FILESDIR}/${PN}-8.4_p5-hevea.patch"
        epatch "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
}

src_configure() {
        ocaml_lib=$(ocamlc -where)
        local myconf=(
                --prefix /usr
                --bindir /usr/bin
                --libdir /usr/$(get_libdir)/coq
                --mandir /usr/share/man
                --emacslib /usr/share/emacs/site-lisp
                --coqdocdir /usr/$(get_libdir)/coq/coqdoc
                --docdir /usr/share/doc/${PF}
                --configdir /etc/xdg/${PN}
                --lablgtkdir ${ocaml_lib}/lablgtk2
                )

        use debug && myconf+=( --debug )
        use doc || myconf+=( --with-doc no )

        if use gtk; then
                if use ocamlopt; then
                        myconf+=( --coqide opt )
                else
                        myconf+=( --coqide byte )
                fi
        else
                myconf+=( --coqide no )
        fi

        if use ocamlopt; then
                myconf+=( --opt )
        else
                myconf+=( -byte-only )
        fi

        if use camlp5; then
                myconf+=( --camlp5dir ${ocaml_lib}/camlp5 )
        else
                myconf+=( --usecamlp4 )
        fi

        export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
        ./configure ${myconf[@]} || die "configure failed"
}

src_compile() {
        emake STRIP="true" -j1 world VERBOSE=1
}

src_test() {
        emake STRIP="true" check VERBOSE=1
}

src_install() {
        emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
        dodoc README CREDITS CHANGES

        use gtk && make_desktop_entry "coqide" "Coq IDE" 
"${EPREFIX}/usr/share/coq/coq.png"
}




Reply via email to