bicatali    14/06/10 19:24:14

  Modified:             ChangeLog
  Added:                lhapdf-6.1.2.ebuild
  Log:
  Version bump
  
  (Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 
0x13CB1360)

Revision  Changes    Path
1.27                 sci-physics/lhapdf/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-physics/lhapdf/ChangeLog?rev=1.27&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-physics/lhapdf/ChangeLog?rev=1.27&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-physics/lhapdf/ChangeLog?r1=1.26&r2=1.27

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v
retrieving revision 1.26
retrieving revision 1.27
diff -u -r1.26 -r1.27
--- ChangeLog   6 May 2014 16:19:56 -0000       1.26
+++ ChangeLog   10 Jun 2014 19:24:14 -0000      1.27
@@ -1,6 +1,11 @@
 # ChangeLog for sci-physics/lhapdf
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.26 
2014/05/06 16:19:56 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.27 
2014/06/10 19:24:14 bicatali Exp $
+
+*lhapdf-6.1.2 (10 Jun 2014)
+
+  10 Jun 2014; Sébastien Fabbro <bicat...@gentoo.org> +lhapdf-6.1.2.ebuild:
+  Version bump
 
 *lhapdf-6.1.0 (06 May 2014)
 



1.1                  sci-physics/lhapdf/lhapdf-6.1.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-physics/lhapdf/lhapdf-6.1.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-physics/lhapdf/lhapdf-6.1.2.ebuild?rev=1.1&content-type=text/plain

Index: lhapdf-6.1.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-6.1.2.ebuild,v 1.1 
2014/06/10 19:24:14 bicatali Exp $

EAPI=5

AUTOTOOLS_IN_SOURCE_BUILD=yes
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )

inherit versionator autotools-utils distutils-r1

MY_PV=$(get_version_component_range 1-3 ${PV})
MY_PF=LHAPDF-${MY_PV}

DESCRIPTION="Les Houches Parton Density Function unified library"
HOMEPAGE="http://lhapdf.hepforge.org/";
SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"

IUSE="doc examples python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="
        dev-libs/boost:0=
        python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
        doc? ( app-doc/doxygen[latex] )"

S="${WORKDIR}/${MY_PF}"

src_configure() {
        autotools-utils_src_configure $(use_enable python)
        if use python; then
                cd "${S}/wrappers/python" && distutils-r1_src_prepare
        fi
}

src_compile() {
        autotools-utils_src_compile all $(use doc && echo doxy)
        if use python; then
           cd "${S}/wrappers/python" && distutils-r1_src_compile
        fi
}

src_test() {
        autotools-utils_src_compile -C tests
}

src_install() {
        autotools-utils_src_install
        use doc && dohtml -r doc/doxygen/*
        if use examples; then
                insinto /usr/share/doc/${PF}/examples
                doins examples/*.cc
        fi
        if use python; then
           cd "${S}/wrappers/python" && distutils-r1_src_install
        fi
}

pkg_postinst() {
        elog "Download data files from:"
        elog 
"http://www.hepforge.org/archive/${PN}/pdfsets/$(get_version_component_range 
1-2 ${PV})"
        elog "and untar them into ${EROOT%/}/usr/share/LHAPDF"
}




Reply via email to