williamh    15/07/08 16:14:29

  Modified:             ChangeLog
  Added:                lmctfy-0.5.0-r1.ebuild
  Log:
  Go is only a build time dependency, and we need a slot dep so a rebuild will 
happen when Go is updated.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  Changes    Path
1.8                  sys-apps/lmctfy/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/lmctfy/ChangeLog?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/lmctfy/ChangeLog?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/lmctfy/ChangeLog?r1=1.7&r2=1.8

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/lmctfy/ChangeLog,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- ChangeLog   26 Apr 2015 23:29:48 -0000      1.7
+++ ChangeLog   8 Jul 2015 16:14:29 -0000       1.8
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/lmctfy
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lmctfy/ChangeLog,v 1.7 2015/04/26 
23:29:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lmctfy/ChangeLog,v 1.8 2015/07/08 
16:14:29 williamh Exp $
+
+*lmctfy-0.5.0-r1 (08 Jul 2015)
+
+  08 Jul 2015; William Hubbs <willi...@gentoo.org> +lmctfy-0.5.0-r1.ebuild:
+  Go is only a build time dependency, and we need a slot dep so a rebuild will
+  happen when Go is updated.
 
   26 Apr 2015; Manuel RĂ¼ger <mr...@gentoo.org> -lmctfy-0.1.0.ebuild:
   Remove old.



1.1                  sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild?rev=1.1&content-type=text/plain

Index: lmctfy-0.5.0-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild,v 1.1 
2015/07/08 16:14:29 williamh Exp $

EAPI=5

inherit eutils

DESCRIPTION="Linux application container management from Google"
HOMEPAGE="https://github.com/google/lmctfy";
SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

COMMON_DEPEND="
        dev-libs/protobuf
        >=dev-cpp/gflags-2.1.1
        dev-libs/re2
        sys-libs/libapparmor
        "
DEPEND="
        ${COMMON_DEPEND}
        dev-lang/go:=
        "
RDEPEND="${COMMON_DEPEND}"

src_compile() {
        # test deps take too long to compile
        use test && emake || emake lmctfy liblmctfy.a
}

src_install() {
        dobin bin/lmctfy/cli/lmctfy
        dolib.a bin/liblmctfy.a
}




Reply via email to