[gentoo-commits] gentoo-x86 commit in sys-boot/grub: grub-9999-r1.ebuild grub-2.02_beta2-r7.ebuild ChangeLog

2015-06-24 Thread Mike Gilbert (floppym)
floppym 15/06/25 00:12:06

  Modified: grub--r1.ebuild grub-2.02_beta2-r7.ebuild
ChangeLog
  Log:
  Add support for the U-Boot platform. Don't set TARGET_CC.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0BBEEA1FEA4843A4)

Revision  ChangesPath
1.35 sys-boot/grub/grub--r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub--r1.ebuild?rev=1.35&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub--r1.ebuild?rev=1.35&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub--r1.ebuild?r1=1.34&r2=1.35

Index: grub--r1.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-boot/grub/grub--r1.ebuild,v
retrieving revision 1.34
retrieving revision 1.35
diff -u -r1.34 -r1.35
--- grub--r1.ebuild 8 Apr 2015 20:32:47 -   1.34
+++ grub--r1.ebuild 25 Jun 2015 00:12:06 -  1.35
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub--r1.ebuild,v 1.34 
2015/04/08 20:32:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub--r1.ebuild,v 1.35 
2015/06/25 00:12:06 floppym Exp $
 
 EAPI=5
 
@@ -49,18 +49,7 @@
 SLOT="2"
 IUSE="debug device-mapper doc efiemu +fonts mount +multislot nls static sdl 
test +themes truetype libzfs"
 
-GRUB_ALL_PLATFORMS=(
-   # everywhere:
-   emu
-   # mips only:
-   qemu-mips loongson
-   # amd64, x86, ppc, ppc64:
-   ieee1275
-   # amd64, x86:
-   coreboot multiboot efi-32 pc qemu xen
-   # amd64, ia64:
-   efi-64
-)
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot 
qemu qemu-mips pc uboot xen )
 IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
 
 REQUIRED_USE="
@@ -245,11 +234,10 @@
use static && HOST_LDFLAGS+=" -static"
 
tc-ld-disable-gold #439082 #466536 #526348
-   export TARGET_LDFLAGS+=" ${LDFLAGS}"
+   export TARGET_LDFLAGS="${TARGET_LDFLAGS} ${LDFLAGS}"
unset LDFLAGS
 
-   tc-export CC NM OBJCOPY STRIP
-   export TARGET_CC=${TARGET_CC:-${CC}}
+   tc-export CC NM OBJCOPY RANLIB STRIP
tc-export BUILD_CC # Bug 485592
 
# Portage will take care of cleaning up GRUB_PLATFORMS



1.12 sys-boot/grub/grub-2.02_beta2-r7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild?r1=1.11&r2=1.12

Index: grub-2.02_beta2-r7.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- grub-2.02_beta2-r7.ebuild   8 Apr 2015 20:32:47 -   1.11
+++ grub-2.02_beta2-r7.ebuild   25 Jun 2015 00:12:06 -  1.12
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 
1.11 2015/04/08 20:32:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 
1.12 2015/06/25 00:12:06 floppym Exp $
 
 EAPI=5
 
@@ -47,18 +47,7 @@
 SLOT="2"
 IUSE="debug device-mapper doc efiemu +fonts mount +multislot nls static sdl 
test +themes truetype libzfs"
 
-GRUB_ALL_PLATFORMS=(
-   # everywhere:
-   emu
-   # mips only:
-   qemu-mips loongson
-   # amd64, x86, ppc, ppc64:
-   ieee1275
-   # amd64, x86:
-   coreboot multiboot efi-32 pc qemu xen
-   # amd64, ia64:
-   efi-64
-)
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot 
qemu qemu-mips pc uboot xen )
 IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
 
 REQUIRED_USE="
@@ -245,11 +234,10 @@
use static && HOST_LDFLAGS+=" -static"
 
tc-ld-disable-gold #439082 #466536 #526348
-   export TARGET_LDFLAGS+=" ${LDFLAGS}"
+   export TARGET_LDFLAGS="${TARGET_LDFLAGS} ${LDFLAGS}"
unset LDFLAGS
 
-   tc-export CC NM OBJCOPY STRIP
-   export TARGET_CC=${TARGET_CC:-${CC}}
+   tc-export CC NM OBJCOPY RANLIB STRIP
tc-export BUILD_CC # Bug 485592
 
# Portage will take care of cleaning up GRUB_PLATFORMS



1.355sys-boot/grub/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/ChangeLog?rev=1.355&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/ChangeLog?rev=1.3

[gentoo-commits] gentoo-x86 commit in sys-boot/grub: grub-9999-r1.ebuild grub-2.02_beta2-r7.ebuild ChangeLog

2015-02-03 Thread Mike Gilbert (floppym)
floppym 15/02/04 02:27:28

  Modified: grub--r1.ebuild grub-2.02_beta2-r7.ebuild
ChangeLog
  Log:
  Bump to unifont-7.0.06.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
0BBEEA1FEA4843A4)

Revision  ChangesPath
1.26 sys-boot/grub/grub--r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub--r1.ebuild?rev=1.26&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub--r1.ebuild?rev=1.26&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub--r1.ebuild?r1=1.25&r2=1.26

Index: grub--r1.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-boot/grub/grub--r1.ebuild,v
retrieving revision 1.25
retrieving revision 1.26
diff -u -r1.25 -r1.26
--- grub--r1.ebuild 4 Feb 2015 02:25:00 -   1.25
+++ grub--r1.ebuild 4 Feb 2015 02:27:28 -   1.26
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub--r1.ebuild,v 1.25 
2015/02/04 02:25:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub--r1.ebuild,v 1.26 
2015/02/04 02:27:28 floppym Exp $
 
 EAPI=5
 
@@ -37,7 +37,7 @@
 fi
 
 DEJAVU=dejavu-sans-ttf-2.34
-UNIFONT=unifont-7.0.05
+UNIFONT=unifont-7.0.06
 SRC_URI+=" mirror://gnu/unifont/${UNIFONT}/${UNIFONT}.pcf.gz
truetype? ( mirror://sourceforge/dejavu/${DEJAVU}.zip )"
 



1.3  sys-boot/grub/grub-2.02_beta2-r7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild?r1=1.2&r2=1.3

Index: grub-2.02_beta2-r7.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- grub-2.02_beta2-r7.ebuild   4 Feb 2015 02:25:00 -   1.2
+++ grub-2.02_beta2-r7.ebuild   4 Feb 2015 02:27:28 -   1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 
1.2 2015/02/04 02:25:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 
1.3 2015/02/04 02:27:28 floppym Exp $
 
 EAPI=5
 
@@ -35,7 +35,7 @@
 fi
 
 DEJAVU=dejavu-sans-ttf-2.34
-UNIFONT=unifont-7.0.01
+UNIFONT=unifont-7.0.06
 SRC_URI+=" mirror://gnu/unifont/${UNIFONT}/${UNIFONT}.pcf.gz
truetype? ( mirror://sourceforge/dejavu/${DEJAVU}.zip )"
 



1.343sys-boot/grub/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/ChangeLog?rev=1.343&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/ChangeLog?rev=1.343&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-boot/grub/ChangeLog?r1=1.342&r2=1.343

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v
retrieving revision 1.342
retrieving revision 1.343
diff -u -r1.342 -r1.343
--- ChangeLog   4 Feb 2015 02:25:00 -   1.342
+++ ChangeLog   4 Feb 2015 02:27:28 -   1.343
@@ -1,6 +1,10 @@
 # ChangeLog for sys-boot/grub
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.342 2015/02/04 
02:25:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.343 2015/02/04 
02:27:28 floppym Exp $
+
+  04 Feb 2015; Mike Gilbert  grub-2.02_beta2-r7.ebuild,
+  grub--r1.ebuild:
+  Bump to unifont-7.0.06.
 
   04 Feb 2015; Mike Gilbert  grub-2.02_beta2-r7.ebuild,
   grub--r1.ebuild: