slis        14/07/31 12:26:11

  Added:                metadata.xml hpx-0.9.8.ebuild Manifest ChangeLog
  Log:
  added hpx package
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0x55265D89)

Revision  Changes    Path
1.1                  sys-cluster/hpx/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
<longdescription>
  HPX (High Performance ParalleX) is a general C++ runtime system
  for parallel and distributed applications of any scale. It is the
  first freely available, open source, feature-complete, modular,
  and performance oriented implementation of the ParalleX execution
  model. HPX is targeted at conventional architectures and,
  currently, Linux based systems, such as SMP nodes and conventional
  clusters.
</longdescription>
<maintainer>
  <email>s...@gentoo.org</email>
</maintainer>
<use>
  <flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for memory 
allocation</flag>
  <flag name="perftools">Use <pkg>dev-util/google-perftools</pkg> for
  memory allocation</flag>
  <flag name="tbb">Use <pkg>dev-cpp/tbb</pkg> for memory
  allocation</flag>
  <flag name="papi">Use <pkg>dev-libs/papi</pkg> for NaCl</flag>
</use>
</pkgmetadata>



1.1                  sys-cluster/hpx/hpx-0.9.8.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/hpx-0.9.8.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/hpx-0.9.8.ebuild?rev=1.1&content-type=text/plain

Index: hpx-0.9.8.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpx/hpx-0.9.8.ebuild,v 1.1 
2014/07/31 12:26:11 slis Exp $

EAPI=5

PYTHON_COMPAT=( python{2_6,2_7} )

SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z";
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}_${PV}"

inherit cmake-utils fortran-2 multilib python-single-r1

DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/";

SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"

# TODO: some of the forced deps are may be optional
# it would need to work the automagic
RDEPEND="
        tbb? ( dev-cpp/tbb )
        >=dev-libs/boost-1.51
        dev-libs/libxml2
        papi? ( dev-libs/papi )
        sci-libs/hdf5
        >=sys-apps/hwloc-1.8
        >=sys-libs/libunwind-1
        sys-libs/zlib
        perftools? ( >=dev-util/google-perftools-1.7.1 )
"
DEPEND="${RDEPEND}
        app-arch/p7zip
        virtual/pkgconfig
        test? ( dev-lang/python )
"
REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"

PATCHES=(
        "${FILESDIR}"/hpx-0.9.8-install-path.patch
        "${FILESDIR}"/hpx-0.9.8-multilib.patch
        "${FILESDIR}"/hpx-0.9.8-cmake_dir.patch
)

pkg_setup() {
        use test && python-single-r1_pkg_setup
}

src_configure() {
        CMAKE_BUILD_TYPE=Release
        local mycmakeargs=(
                -DHPX_BUILD_EXAMPLES=OFF
                -DLIB=$(get_libdir)
                -Dcmake_dir=cmake
                $(cmake-utils_use doc HPX_BUILD_DOCUMENTATION)
                $(cmake-utils_use jemalloc HPX_JEMALLOC)
                $(cmake-utils_use test BUILD_TESTING)
                $(cmake-utils_use perftools HPX_GOOGLE_PERFTOOLS)
                $(cmake-utils_use papi HPX_PAPI)
        )
        if use perftools; then
                mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
        elif use jemalloc; then
                mycmakeargs+=( -DHPX_MALLOC=jemalloc )
        elif use tbb; then
                mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
        else
                mycmakeargs+=( -DHPX_MALLOC=system )
        fi
        cmake-utils_src_configure
}

src_test() {
        # avoid over-suscribing
        cmake-utils_src_make -j1 tests
}

src_install() {
        cmake-utils_src_install
        if use examples; then
                insinto /usr/share/doc/${PF}
                doins -r examples
        fi
}



1.1                  sys-cluster/hpx/Manifest

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/Manifest?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/Manifest?rev=1.1&content-type=text/plain

Index: Manifest
===================================================================
AUX hpx-0.9.8-cmake_dir.patch 782 SHA256 
bb442661be8fca955c09de44073d49d8e89d603f8169600009fd77146a3294f9 SHA512 
93fadaf1a8e302f8433c35ebbe4f75af6db21136d64a88574f56122f7204a387e6a0fc9a3fcde21cd8897364ecea203223a365fc84e2e725e8436b77a8fec9d9
 WHIRLPOOL 
fbdcad3ee78f8153519d64d5fc2b05c451dbe4bd45c34dcb2b0502accc5743d13fdc9d42e797204e7001733126056a3699381d314d3d049569cd3d862691d6dd
AUX hpx-0.9.8-install-path.patch 2952 SHA256 
c8bc7ed3a3023b6a278d7540009cd9b837085b6a0995b444f039863e8f008043 SHA512 
94273cbd42291fe8dcefe76f8e663997632c8dfc729ceac9c9e6a13b1168334788fe4f2e8c0c20b37d3d5ab339db2b44ba2a6c3fee656cc3981f26d79503f606
 WHIRLPOOL 
c4c539b337f43f09a95f69ea123d74db425a84ae81a927d4d8d5e04830cba36a8a2bf237bfbdee4b2f90f3eec2053e9cd50f9c91de898e710deeccecc6323d2e
AUX hpx-0.9.8-multilib.patch 6064 SHA256 
77a3eff3e8882bcd36836a65255a62267310f78d43557a22a9bd908481816e79 SHA512 
b378d6e259263a02929c06c0b093490115b5a573daed20f980c1fa15fe2f8ce4833a784cc8a1924ea1ddc8fdc853d07fd1e83a20fdc6c711211c8f3eb9e2f583
 WHIRLPOOL 
7e69572bfd9aa1b50a4173091d3b2e460fbccb7361963f74cfab14f27f965cc56d27be6e84310dd62eced27b1c4fe7eae5c1be7e43a99e9b8dbe3ed9497e2256
DIST hpx_0.9.8.7z 2089649 SHA256 
9e04685b07e4155e6d3e00c944e5fe91c0c815a2b3bc7bc345eb59d8708bac91 SHA512 
1789582ee776173d4aa67b512d2df225c734b98ffe59a8f1eee38b5112ac7c02e0c7c478f72062e5b6a5d5053ce1848729c374093378f63200acf51a208fb3c7
 WHIRLPOOL 
b4b5a8a83aa4d07466ee0570b9fdadd906281e626eed2ce82e3a8e03681de1591a46af2254cbd387eb2d0bfac22c6796537fbbb37764be7dd424b97dd0d433c7
EBUILD hpx-0.9.8.ebuild 2002 SHA256 
f6ff3dfa41714c225b5c603303d6ba375bb95d895905e0eda729e2d2d6a9195d SHA512 
f3e837c676c76a4dcbe49ec9db92fb757dd1d6361a6fb6a44f4fbffc8c13cb1dbb335f44eff9d6579a74df47c8508715a3bac984510066aaed072fa40e3435eb
 WHIRLPOOL 
8a73eef5e0520a9b6487bbd928cfd2337e88eef25ff0a5740bd96fc6d4812e2b08aaed9e094f387e02a8ccbe4354f7c388f6e3462a629b4140ac792bfa51bd08
MISC metadata.xml 983 SHA256 
d02d8e4f5427067f5e132cd085da5baf96905e4a06b0d8ea84c95769b89065b8 SHA512 
68d7d83ca092d51ffb22fc8633af8df1a82ab7b052fbba4f939777dd81b225d8991616890fb9585c1044b406dac05292030d049ddc62b38587d187a23fa08dff
 WHIRLPOOL 
723e5bc2e99e258f9b9b92bda106fd2ad7c33221d98228142630df214fb220a07dece447389fc6ac0f1b368d812fe661c1cf58ec310af803e735e3da0a41b8c9



1.1                  sys-cluster/hpx/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/hpx/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for sys-cluster/hpx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpx/ChangeLog,v 1.1 2014/07/31 
12:26:11 slis Exp $

*hpx-0.9.8 (31 Jul 2014)

  31 Jul 2014; SÅ‚awek Lis <s...@gentoo.org> +files/hpx-0.9.8-cmake_dir.patch,
  +files/hpx-0.9.8-install-path.patch, +files/hpx-0.9.8-multilib.patch,
  +hpx-0.9.8.ebuild, +metadata.xml:
  added hpx package




Reply via email to