[gentoo-commits] gentoo-x86 commit in sys-cluster/torque: ChangeLog torque-4.1.7.ebuild

2014-09-18 Thread Justin Lecher (jlec)
jlec14/09/18 13:19:21

  Modified: ChangeLog torque-4.1.7.ebuild
  Log:
  sys-cluster/torque: Bump EAPI and give some prefix love
  
  (Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 
B9D4F231BD1558AB!)

Revision  ChangesPath
1.169sys-cluster/torque/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/ChangeLog?rev=1.169view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/ChangeLog?rev=1.169content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/ChangeLog?r1=1.168r2=1.169

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v
retrieving revision 1.168
retrieving revision 1.169
diff -u -r1.168 -r1.169
--- ChangeLog   19 Jun 2014 20:31:24 -  1.168
+++ ChangeLog   18 Sep 2014 13:19:21 -  1.169
@@ -1,6 +1,9 @@
 # ChangeLog for sys-cluster/torque
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.168 
2014/06/19 20:31:24 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.169 
2014/09/18 13:19:21 jlec Exp $
+
+  18 Sep 2014; Justin Lecher j...@gentoo.org torque-4.1.7.ebuild:
+  Bump EAPI and give some prefix love
 
 *torque-4.1.7 (19 Jun 2014)
 



1.2  sys-cluster/torque/torque-4.1.7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild?rev=1.2view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild?rev=1.2content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild?r1=1.1r2=1.2

Index: torque-4.1.7.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- torque-4.1.7.ebuild 19 Jun 2014 20:31:24 -  1.1
+++ torque-4.1.7.ebuild 18 Sep 2014 13:19:21 -  1.2
@@ -1,8 +1,9 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild,v 
1.1 2014/06/19 20:31:24 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild,v 
1.2 2014/09/18 13:19:21 jlec Exp $
+
+EAPI=5
 
-EAPI=4
 inherit flag-o-matic eutils linux-info
 
 DESCRIPTION=Resource manager and queuing system based on OpenPBS
@@ -10,13 +11,14 @@
 # TODO:  hopefully moving to github tags soon
 # http://www.supercluster.org/pipermail/torquedev/2013-May/004519.html
 SRC_URI=http://www.adaptivecomputing.com/index.php?wpfb_dl=1690 - 
${P}.tar.gz
-LICENSE=torque-2.5
 
+LICENSE=torque-2.5
 SLOT=0
 KEYWORDS=~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86
 IUSE=cpusets +crypt doc drmaa kernel_linux munge nvidia server +syslog tk
 
-DEPEND_COMMON=sys-libs/ncurses
+DEPEND_COMMON=
+   sys-libs/ncurses
sys-libs/readline
cpusets? ( sys-apps/hwloc )
munge? ( sys-auth/munge )
@@ -33,7 +35,7 @@
!crypt? ( net-misc/netkit-rsh )
 
 pkg_setup() {
-   PBS_SERVER_HOME=${PBS_SERVER_HOME:-/var/spool/torque}
+   PBS_SERVER_HOME=${PBS_SERVER_HOME:-/var/spool/${PN}}
 
# Find a Torque server to use.  Check environment, then
# current setup (if any), and fall back on current hostname.
@@ -74,7 +76,7 @@
# --without-loadlibfile is supposed to do this for us...
sed -i '/mk_default_ld_lib_file || return 1/d' buildutils/pbs_mkdirs.in 
|| die
 
-   epatch ${FILESDIR}/torque-4.1.5.1-tcl8.6.patch
+   epatch ${FILESDIR}/${PN}-4.1.5.1-tcl8.6.patch
 
# 491270
epatch ${FILESDIR}/CVE-2013-4495.4.1.patch
@@ -105,53 +107,53 @@
 src_install() {
local dir
 
-   emake DESTDIR=${D} install || die make install failed
+   DOCS=( CHANGELOG README.* Release_Notes )
+   use doc  DOCS+=( doc/admin_guide.ps doc/*.pdf )
 
-   dodoc CHANGELOG README.* Release_Notes || die dodoc failed
-   if use doc; then
-   dodoc doc/admin_guide.ps doc/*.pdf || die dodoc failed
-   fi
+   default
 
# The build script isn't alternative install location friendly,
# So we have to fix some hard-coded paths in tclIndex for xpbs* to work
-   for file in `find ${D} -iname tclIndex`; do
-   sed -e s/${D//\// }/ / ${file}  ${file}.new
-   mv ${file}.new ${file} || die
+   for file in $(find ${ED} -iname tclIndex); do
+   sed \
+   -e s/${ED//\// }/ / \
+   -i ${file} || die
done
 
-   for dir in $(find ${D}/${PBS_SERVER_HOME} -type d); do
-   keepdir ${dir#${D}}

[gentoo-commits] gentoo-x86 commit in sys-cluster/torque: ChangeLog torque-4.1.7.ebuild

2014-06-19 Thread Justin Bronder (jsbronder)
jsbronder14/06/19 20:31:24

  Modified: ChangeLog
  Added:torque-4.1.7.ebuild
  Log:
  Bump 4.1.7, add fix for CVE-2013-4495 (#491270)
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
4D7043C9)

Revision  ChangesPath
1.168sys-cluster/torque/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/ChangeLog?rev=1.168view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/ChangeLog?rev=1.168content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/ChangeLog?r1=1.167r2=1.168

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v
retrieving revision 1.167
retrieving revision 1.168
diff -u -r1.167 -r1.168
--- ChangeLog   19 Jun 2014 19:55:00 -  1.167
+++ ChangeLog   19 Jun 2014 20:31:24 -  1.168
@@ -1,6 +1,12 @@
 # ChangeLog for sys-cluster/torque
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.167 
2014/06/19 19:55:00 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.168 
2014/06/19 20:31:24 jsbronder Exp $
+
+*torque-4.1.7 (19 Jun 2014)
+
+  19 Jun 2014; Justin Bronder jsbron...@gentoo.org +torque-4.1.7.ebuild,
+  +files/CVE-2013-4495.4.1.patch:
+  Bump 4.1.7, add fix for CVE-2013-4495 (#491270)
 
 *torque-2.5.13 (19 Jun 2014)
 



1.1  sys-cluster/torque/torque-4.1.7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild?rev=1.1view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild?rev=1.1content-type=text/plain

Index: torque-4.1.7.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-4.1.7.ebuild,v 1.1 
2014/06/19 20:31:24 jsbronder Exp $

EAPI=4
inherit flag-o-matic eutils linux-info

DESCRIPTION=Resource manager and queuing system based on OpenPBS
HOMEPAGE=http://www.adaptivecomputing.com/products/open-source/torque;
# TODO:  hopefully moving to github tags soon
# http://www.supercluster.org/pipermail/torquedev/2013-May/004519.html
SRC_URI=http://www.adaptivecomputing.com/index.php?wpfb_dl=1690 - ${P}.tar.gz
LICENSE=torque-2.5

SLOT=0
KEYWORDS=~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86
IUSE=cpusets +crypt doc drmaa kernel_linux munge nvidia server +syslog tk

DEPEND_COMMON=sys-libs/ncurses
sys-libs/readline
cpusets? ( sys-apps/hwloc )
munge? ( sys-auth/munge )
nvidia? ( =x11-drivers/nvidia-drivers-275 )
tk? ( dev-lang/tk )
syslog? ( virtual/logger )
!games-util/qstat

DEPEND=${DEPEND_COMMON}
!sys-cluster/slurm

RDEPEND=${DEPEND_COMMON}
crypt? ( net-misc/openssh )
!crypt? ( net-misc/netkit-rsh )

pkg_setup() {
PBS_SERVER_HOME=${PBS_SERVER_HOME:-/var/spool/torque}

# Find a Torque server to use.  Check environment, then
# current setup (if any), and fall back on current hostname.
if [ -z ${PBS_SERVER_NAME} ]; then
if [ -f ${ROOT}${PBS_SERVER_HOME}/server_name ]; then

PBS_SERVER_NAME=$(${ROOT}${PBS_SERVER_HOME}/server_name)
else
PBS_SERVER_NAME=$(hostname -f)
fi
fi

USE_CPUSETS=--disable-cpuset
if use cpusets; then
if ! use kernel_linux; then
einfo
elog Torque currently only has support for cpusets 
in linux.
elog Assuming you didn't really want this USE flag.
einfo
else
linux-info_pkg_setup
if ! linux_config_exists || ! linux_chkconfig_present 
CPUSETS; then
einfo
elog Torque support for cpusets will 
require that you recompile
elog your kernel with CONFIG_CPUSETS enabled.
einfo
fi
USE_CPUSETS=--enable-cpuset
fi
fi
}

src_prepare() {
# Unused and causes breakage when switching from glibc to tirpc.
# https://github.com/adaptivecomputing/torque/pull/148
sed -i '/rpc\/rpc\.h/d' src/lib/Libnet/net_client.c || die

# We install to a valid location, no need to muck with ld.so.conf
# --without-loadlibfile is supposed to do this for us...
sed -i '/mk_default_ld_lib_file || return 1/d' buildutils/pbs_mkdirs.in 
|| die