polynomial-c    15/01/23 19:38:59

  Modified:             ChangeLog
  Added:                bison-3.0.4.ebuild
  Removed:              bison-3.0.2.ebuild
  Log:
  Version bump. Removed old
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
0x981CA6FC)

Revision  Changes    Path
1.133                sys-devel/bison/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/bison/ChangeLog?rev=1.133&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/bison/ChangeLog?rev=1.133&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/bison/ChangeLog?r1=1.132&r2=1.133

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v
retrieving revision 1.132
retrieving revision 1.133
diff -u -r1.132 -r1.133
--- ChangeLog   15 Jan 2015 19:30:43 -0000      1.132
+++ ChangeLog   23 Jan 2015 19:38:58 -0000      1.133
@@ -1,6 +1,12 @@
 # ChangeLog for sys-devel/bison
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.132 
2015/01/15 19:30:43 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.133 
2015/01/23 19:38:58 polynomial-c Exp $
+
+*bison-3.0.4 (23 Jan 2015)
+
+  23 Jan 2015; Lars Wendler <polynomia...@gentoo.org> -bison-3.0.2.ebuild,
+  +bison-3.0.4.ebuild:
+  Version bump. Removed old.
 
 *bison-3.0.3-r1 (15 Jan 2015)
 



1.1                  sys-devel/bison/bison-3.0.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/bison/bison-3.0.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/bison/bison-3.0.4.ebuild?rev=1.1&content-type=text/plain

Index: bison-3.0.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-3.0.4.ebuild,v 1.1 
2015/01/23 19:38:58 polynomial-c Exp $

EAPI=5

inherit flag-o-matic

DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
HOMEPAGE="http://www.gnu.org/software/bison/";
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd 
~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux 
~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint 
~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static"

RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
        sys-devel/flex
        nls? ( sys-devel/gettext )"

DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 
PACKAGING README-alpha README-release

src_configure() {
        use static && append-ldflags -static

        econf \
                --docdir="${EPREFIX}"/usr/share/doc/${PF} \
                $(use_enable nls)
}

src_install() {
        default

        # This one is installed by dev-util/yacc
        mv "${ED}"/usr/bin/yacc{,.bison} || die
        mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die

        # We do not need liby.a
        rm -r "${ED}"/usr/lib* || die

        # Move to documentation directory and leave compressing for EAPI>=4
        mv "${ED}"/usr/share/${PN}/README 
"${ED}"/usr/share/doc/${PF}/README.data
}

pkg_postinst() {
        local f="${EROOT}/usr/bin/yacc"
        if [[ ! -e ${f} ]] ; then
                ln -s yacc.bison "${f}"
        fi
}

pkg_postrm() {
        # clean up the dead symlink when we get unmerged #377469
        local f="${EROOT}/usr/bin/yacc"
        if [[ -L ${f} && ! -e ${f} ]] ; then
                rm -f "${f}"
        fi
}




Reply via email to