[gentoo-commits] gentoo-x86 commit in sys-devel/llvm: ChangeLog llvm-9999.ebuild

2015-06-15 Thread Bernard Cafarelli (voyageur)
voyageur15/06/15 22:26:52

  Modified: ChangeLog llvm-.ebuild
  Log:
  lldb fixes thanks to mgorny's review
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
00F7AB331B0F097F)

Revision  ChangesPath
1.253sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.253view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.253content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.252r2=1.253

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.252
retrieving revision 1.253
diff -u -r1.252 -r1.253
--- ChangeLog   15 Jun 2015 12:52:14 -  1.252
+++ ChangeLog   15 Jun 2015 22:26:52 -  1.253
@@ -1,6 +1,9 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.252 2015/06/15 
12:52:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.253 2015/06/15 
22:26:52 voyageur Exp $
+
+  15 Jun 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild:
+  lldb fixes thanks to mgorny's review
 
   15 Jun 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild,
   metadata.xml:



1.118sys-devel/llvm/llvm-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.118view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.118content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?r1=1.117r2=1.118

Index: llvm-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v
retrieving revision 1.117
retrieving revision 1.118
diff -u -r1.117 -r1.118
--- llvm-.ebuild15 Jun 2015 12:52:14 -  1.117
+++ llvm-.ebuild15 Jun 2015 22:26:52 -  1.118
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.117 
2015/06/15 12:52:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.118 
2015/06/15 22:26:52 voyageur Exp $
 
 EAPI=5
 
@@ -66,8 +66,8 @@
 # pypy gives me around 1700 unresolved tests due to open file limit
 # being exceeded. probably GC does not close them fast enough.
 REQUIRED_USE=${PYTHON_REQUIRED_USE}
-   test? ( || ( $(python_gen_useflags 'python*') ) )
-   lldb? ( clang )
+   lldb? ( clang )
+   test? ( || ( $(python_gen_useflags 'python*') ) )
 
 pkg_pretend() {
# in megs
@@ -243,12 +243,16 @@
-DFFI_LIBRARY_DIR=${ffi_ldflags#-L}
 
-DHAVE_HISTEDIT_H=$(usex libedit)
-
-   -DLLDB_DISABLE_LIBEDIT=$(usex libedit 0 1)
-   -DLLDB_DISABLE_CURSES=$(usex libedit 0 1)
-   -DLLDB_ENABLE_TERMINFO=$(usex ncurses)
)
 
+   if use lldb; then
+   mycmakeargs+=(
+   -DLLDB_DISABLE_LIBEDIT=$(usex !libedit)
+   -DLLDB_DISABLE_CURSES=$(usex !ncurses)
+   -DLLDB_ENABLE_TERMINFO=$(usex ncurses)
+   )
+   fi
+
if ! multilib_is_native_abi || ! use ocaml; then
mycmakeargs+=(
-DOCAMLFIND=NO
@@ -284,7 +288,7 @@
 
if use lldb; then
mycmakeargs+=(
-   -DLLDB_DISABLE_PYTHON=$(usex python 0 1)
+   -DLLDB_DISABLE_PYTHON=$(usex !python)
)
fi
 






[gentoo-commits] gentoo-x86 commit in sys-devel/llvm: ChangeLog llvm-9999.ebuild

2015-06-11 Thread Bernard Cafarelli (voyageur)
voyageur15/06/11 17:05:20

  Modified: ChangeLog llvm-.ebuild
  Log:
  Documentation build can be made optional again, add back pax markings
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
00F7AB331B0F097F)

Revision  ChangesPath
1.247sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.247view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.247content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.246r2=1.247

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.246
retrieving revision 1.247
diff -u -r1.246 -r1.247
--- ChangeLog   9 Jun 2015 21:17:33 -   1.246
+++ ChangeLog   11 Jun 2015 17:05:20 -  1.247
@@ -1,6 +1,9 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.246 2015/06/09 
21:17:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.247 2015/06/11 
17:05:20 voyageur Exp $
+
+  11 Jun 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild:
+  Documentation build can be made optional again, add back pax markings
 
   09 Jun 2015; Michał Górny mgo...@gentoo.org llvm-.ebuild:
   Enable EH  RTTI for better compatibility



1.113sys-devel/llvm/llvm-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.113view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.113content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?r1=1.112r2=1.113

Index: llvm-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v
retrieving revision 1.112
retrieving revision 1.113
diff -u -r1.112 -r1.113
--- llvm-.ebuild9 Jun 2015 21:17:33 -   1.112
+++ llvm-.ebuild11 Jun 2015 17:05:20 -  1.113
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.112 
2015/06/09 21:17:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.113 
2015/06/11 17:05:20 voyageur Exp $
 
 EAPI=5
 
@@ -43,7 +43,6 @@
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
 DEPEND=${COMMON_DEPEND}
dev-lang/perl
-   dev-python/sphinx
=sys-devel/make-3.81
=sys-devel/flex-2.5.4
=sys-devel/bison-1.875d
@@ -53,6 +52,7 @@
|| ( =sys-devel/binutils-2.18 =sys-devel/binutils-apple-5.1 )
kernel_Darwin? ( sys-libs/libcxx )
clang? ( xml? ( virtual/pkgconfig ) )
+   doc? ( dev-python/sphinx )
libffi? ( virtual/pkgconfig )
!!dev-python/configparser-3.3.0.2
${PYTHON_DEPS}
@@ -243,11 +243,10 @@
 
if multilib_is_native_abi; then
mycmakeargs+=(
-   -DLLVM_BUILD_DOCS=ON
+   $(cmake-utils_use doc LLVM_BUILD_DOCS)
+   $(cmake-utils_use doc LLVM_ENABLE_SPHINX)
+   $(cmake-utils_use doc SPHINX_OUTPUT_HTML)
-DLLVM_ENABLE_DOXYGEN=OFF
-   -DLLVM_ENABLE_SPHINX=ON
-   -DSPHINX_OUTPUT_HTML=$(usex doc)
-

-DLLVM_INSTALL_HTML=${EPREFIX}/usr/share/doc/${PF}/html
)
 
@@ -296,6 +295,10 @@
 multilib_src_compile() {
cmake-utils_src_compile
 
+   pax-mark m ${BUILD_DIR}/bin/llvm-rtdyld
+   pax-mark m ${BUILD_DIR}/bin/lli
+   pax-mark m ${BUILD_DIR}/bin/lli-child-target
+
if use test; then
pax-mark m 
${BUILD_DIR}/unittests/ExecutionEngine/Orc/OrcJITTests
pax-mark m 
${BUILD_DIR}/unittests/ExecutionEngine/MCJIT/MCJITTests
@@ -340,7 +343,6 @@
)
fi
 
-
multilib-minimal_src_install
 }
 






[gentoo-commits] gentoo-x86 commit in sys-devel/llvm: ChangeLog llvm-9999.ebuild

2015-05-29 Thread Bernard Cafarelli (voyageur)
voyageur15/05/29 09:24:43

  Modified: ChangeLog llvm-.ebuild
  Log:
  Revert accidental commit on live ebuild, should fix #550608 and #550682
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
00F7AB331B0F097F)

Revision  ChangesPath
1.241sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.241view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.241content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.240r2=1.241

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.240
retrieving revision 1.241
diff -u -r1.240 -r1.241
--- ChangeLog   27 May 2015 11:58:56 -  1.240
+++ ChangeLog   29 May 2015 09:24:43 -  1.241
@@ -1,6 +1,9 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.240 2015/05/27 
11:58:56 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.241 2015/05/29 
09:24:43 voyageur Exp $
+
+  29 May 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild:
+  Revert accidental commit on live ebuild, should fix #550608 and #550682
 
 *llvm-3.6.1 (27 May 2015)
 



1.107sys-devel/llvm/llvm-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.107view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.107content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?r1=1.106r2=1.107

Index: llvm-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v
retrieving revision 1.106
retrieving revision 1.107
diff -u -r1.106 -r1.107
--- llvm-.ebuild27 May 2015 11:58:56 -  1.106
+++ llvm-.ebuild29 May 2015 09:24:43 -  1.107
@@ -1,12 +1,12 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.106 
2015/05/27 11:58:56 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.107 
2015/05/29 09:24:43 voyageur Exp $
 
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 pypy )
 
-inherit eutils cmake-utils flag-o-matic git-r3 multibuild multilib \
+inherit eutils flag-o-matic git-r3 multibuild multilib \
multilib-minimal python-r1 toolchain-funcs pax-utils check-reqs
 
 DESCRIPTION=Low Level Virtual Machine
@@ -19,7 +19,8 @@
 SLOT=0/${PV}
 KEYWORDS=
 IUSE=clang debug doc gold libedit +libffi multitarget ncurses ocaml python
-   +static-analyzer test xml video_cards_radeon kernel_Darwin
+   +static-analyzer test xml video_cards_radeon
+   kernel_Darwin
 
 COMMON_DEPEND=
sys-libs/zlib:0=
@@ -43,6 +44,10 @@
=sys-devel/make-3.81
=sys-devel/flex-2.5.4
=sys-devel/bison-1.875d
+   || ( =sys-devel/gcc-3.0 =sys-devel/gcc-apple-4.2.1
+   ( =sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
+   )
+   || ( =sys-devel/binutils-2.18 =sys-devel/binutils-apple-5.1 )
clang? ( xml? ( virtual/pkgconfig ) )
libffi? ( virtual/pkgconfig )
!!dev-python/configparser-3.3.0.2
@@ -233,8 +238,7 @@
tc-export CC CXX
 
ECONF_SOURCE=${S} \
-   cmake-utils_src_configure
-   #econf ${conf_flags[@]}
+   econf ${conf_flags[@]}
 }
 
 set_makeargs() {
@@ -466,6 +470,7 @@
insinto /usr/share/vim/vimfiles/${dir}
doins ${dir}/*.vim
done
+   popd /dev/null || die
 
if use clang; then
pushd tools/clang /dev/null || die
@@ -506,5 +511,6 @@
python_doscript 
${S}/projects/compiler-rt/lib/asan/scripts/asan_symbolize.py
}
python_foreach_impl python_inst
+   popd /dev/null || die
fi
 }






[gentoo-commits] gentoo-x86 commit in sys-devel/llvm: ChangeLog llvm-9999.ebuild

2015-05-04 Thread Bernard Cafarelli (voyageur)
voyageur15/05/04 16:01:36

  Modified: ChangeLog llvm-.ebuild
  Log:
  Fix vim files installation, thanks Tobias Jakobi. Note this does not fix 
USE=clang build, which still needs the cmake rewrite
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
00F7AB331B0F097F)

Revision  ChangesPath
1.239sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.239view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.239content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.238r2=1.239

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.238
retrieving revision 1.239
diff -u -r1.238 -r1.239
--- ChangeLog   16 Apr 2015 11:55:18 -  1.238
+++ ChangeLog   4 May 2015 16:01:35 -   1.239
@@ -1,6 +1,10 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.238 2015/04/16 
11:55:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.239 2015/05/04 
16:01:35 voyageur Exp $
+
+  04 May 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild:
+  Fix vim files installation, thanks Tobias Jakobi. Note this does not fix
+  USE=clang build, which still needs the cmake rewrite
 
   16 Apr 2015; Bernard Cafarelli voyag...@gentoo.org llvm-3.3-r3.ebuild,
   llvm-3.4.2.ebuild, llvm-3.5.0.ebuild, llvm-3.5.1.ebuild, llvm-3.5.2.ebuild,



1.105sys-devel/llvm/llvm-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.105view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.105content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?r1=1.104r2=1.105

Index: llvm-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v
retrieving revision 1.104
retrieving revision 1.105
diff -u -r1.104 -r1.105
--- llvm-.ebuild16 Apr 2015 11:55:18 -  1.104
+++ llvm-.ebuild4 May 2015 16:01:35 -   1.105
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.104 
2015/04/16 11:55:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.105 
2015/05/04 16:01:35 voyageur Exp $
 
 EAPI=5
 
@@ -465,11 +465,14 @@
 }
 
 multilib_src_install_all() {
-   insinto /usr/share/vim/vimfiles/syntax
-   doins utils/vim/*.vim
+   pushd utils/vim /dev/null || die
+   for dir in */; do
+   insinto /usr/share/vim/vimfiles/${dir}
+   doins ${dir}/*.vim
+   done
 
if use clang; then
-   cd tools/clang || die
+   pushd tools/clang /dev/null || die
 
if use static-analyzer ; then
dobin tools/scan-build/ccc-analyzer






[gentoo-commits] gentoo-x86 commit in sys-devel/llvm: ChangeLog llvm-9999.ebuild

2015-04-02 Thread Bernard Cafarelli (voyageur)
voyageur15/04/02 15:05:26

  Modified: ChangeLog llvm-.ebuild
  Log:
  Fix live ebuild patch, though it requires a rewrite for cmake build system, 
bug #543536
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
00F7AB331B0F097F)

Revision  ChangesPath
1.235sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.235view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.235content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.234r2=1.235

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.234
retrieving revision 1.235
diff -u -r1.234 -r1.235
--- ChangeLog   19 Mar 2015 09:28:02 -  1.234
+++ ChangeLog   2 Apr 2015 15:05:26 -   1.235
@@ -1,6 +1,11 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.234 2015/03/19 
09:28:02 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.235 2015/04/02 
15:05:26 voyageur Exp $
+
+  02 Apr 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild,
+  +files/llvm-3.7-nodoctargz.patch:
+  Fix live ebuild patch, though it requires a rewrite for cmake build system,
+  bug #543536
 
   19 Mar 2015; Bernard Cafarelli voyag...@gentoo.org llvm-3.1-r2.ebuild,
   +files/llvm-3.1-docs-pod-markup-fixes.patch,



1.103sys-devel/llvm/llvm-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.103view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.103content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?r1=1.102r2=1.103

Index: llvm-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v
retrieving revision 1.102
retrieving revision 1.103
diff -u -r1.102 -r1.103
--- llvm-.ebuild4 Feb 2015 10:55:25 -   1.102
+++ llvm-.ebuild2 Apr 2015 15:05:26 -   1.103
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.102 
2015/02/04 10:55:25 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.103 
2015/04/02 15:05:26 voyageur Exp $
 
 EAPI=5
 
@@ -143,7 +143,7 @@
 }
 
 src_prepare() {
-   epatch ${FILESDIR}/${PN}-3.2-nodoctargz.patch
+   epatch ${FILESDIR}/${PN}-3.7-nodoctargz.patch
epatch ${FILESDIR}/${PN}-3.5-gcc-4.9.patch
epatch ${FILESDIR}/${PN}-3.6-gentoo-install.patch
# Make ocaml warnings non-fatal, bug #537308






[gentoo-commits] gentoo-x86 commit in sys-devel/llvm: ChangeLog llvm-9999.ebuild

2015-01-25 Thread Bernard Cafarelli (voyageur)
voyageur15/01/25 23:45:06

  Modified: ChangeLog llvm-.ebuild
  Log:
  Update ocaml tests path for live ebuild, bug #537504
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
C74525F2)

Revision  ChangesPath
1.222sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.222view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.222content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.221r2=1.222

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.221
retrieving revision 1.222
diff -u -r1.221 -r1.222
--- ChangeLog   23 Jan 2015 13:22:11 -  1.221
+++ ChangeLog   25 Jan 2015 23:45:06 -  1.222
@@ -1,6 +1,9 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.221 2015/01/23 
13:22:11 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.222 2015/01/25 
23:45:06 voyageur Exp $
+
+  25 Jan 2015; Bernard Cafarelli voyag...@gentoo.org llvm-.ebuild:
+  Update ocaml tests path for live ebuild, bug #537504
 
   23 Jan 2015; Bernard Cafarelli voyag...@gentoo.org llvm-3.5.1.ebuild,
   llvm-.ebuild:



1.98 sys-devel/llvm/llvm-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.98view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?rev=1.98content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-.ebuild?r1=1.97r2=1.98

Index: llvm-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v
retrieving revision 1.97
retrieving revision 1.98
diff -u -r1.97 -r1.98
--- llvm-.ebuild23 Jan 2015 13:22:11 -  1.97
+++ llvm-.ebuild25 Jan 2015 23:45:06 -  1.98
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.97 
2015/01/23 13:22:11 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-.ebuild,v 1.98 
2015/01/25 23:45:06 voyageur Exp $
 
 EAPI=5
 
@@ -147,7 +147,7 @@
epatch ${FILESDIR}/${PN}-3.5-gcc-4.9.patch
epatch ${FILESDIR}/${PN}-3.6-gentoo-install.patch
# Make ocaml warnings non-fatal, bug #537308
-   sed -e /RUN/s/-warn-error A// -i test/Bindings/Ocaml/*ml  || die
+   sed -e /RUN/s/-warn-error A// -i test/Bindings/OCaml/*ml  || die
 
if use clang; then
# Automatically select active system GCC's libraries, bugs 
#406163 and #417913