voyageur    15/08/06 12:18:45

  Modified:             llvm-3.6.1.ebuild ChangeLog llvm-9999.ebuild
                        llvm-3.6.2.ebuild llvm-3.6.0.ebuild
  Log:
  Add missing dependencies to finally close #543422 (USE-flag masked on 
sparc/powerpc)
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
00F7AB331B0F097F)

Revision  Changes    Path
1.6                  sys-devel/llvm/llvm-3.6.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild?r1=1.5&r2=1.6

Index: llvm-3.6.1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- llvm-3.6.1.ebuild   14 Jun 2015 17:56:07 -0000      1.5
+++ llvm-3.6.1.ebuild   6 Aug 2015 12:18:45 -0000       1.6
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v 1.5 
2015/06/14 17:56:07 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v 1.6 
2015/08/06 12:18:45 voyageur Exp $
 
 EAPI=5
 
@@ -38,7 +38,10 @@
        libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
        libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
-       ocaml? ( dev-lang/ocaml:0= )"
+       ocaml? (
+               dev-lang/ocaml:0=
+               dev-ml/findlib
+               dev-ml/ocaml-ctypes )"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
 DEPEND="${COMMON_DEPEND}
        app-arch/xz-utils
@@ -55,6 +58,7 @@
        doc? ( dev-python/sphinx )
        libffi? ( virtual/pkgconfig )
        !!<dev-python/configparser-3.3.0.2
+       ocaml? ( test? ( dev-ml/ounit ) )
        ${PYTHON_DEPS}"
 RDEPEND="${COMMON_DEPEND}
        clang? ( !<=sys-devel/clang-${PV}-r99



1.258                sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.258&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.258&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.257&r2=1.258

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.257
retrieving revision 1.258
diff -u -r1.257 -r1.258
--- ChangeLog   25 Jul 2015 13:53:53 -0000      1.257
+++ ChangeLog   6 Aug 2015 12:18:45 -0000       1.258
@@ -1,6 +1,11 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.257 2015/07/25 
13:53:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.258 2015/08/06 
12:18:45 voyageur Exp $
+
+  06 Aug 2015; Bernard Cafarelli <voyag...@gentoo.org> llvm-3.6.0.ebuild,
+  llvm-3.6.1.ebuild, llvm-3.6.2.ebuild, llvm-9999.ebuild:
+  Add missing dependencies to finally close #543422 (USE-flag masked on
+  sparc/powerpc)
 
 *llvm-3.6.2 (25 Jul 2015)
 



1.120                sys-devel/llvm/llvm-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild?rev=1.120&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild?rev=1.120&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild?r1=1.119&r2=1.120

Index: llvm-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v
retrieving revision 1.119
retrieving revision 1.120
diff -u -r1.119 -r1.120
--- llvm-9999.ebuild    19 Jul 2015 17:29:33 -0000      1.119
+++ llvm-9999.ebuild    6 Aug 2015 12:18:45 -0000       1.120
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.119 
2015/07/19 17:29:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.120 
2015/08/06 12:18:45 voyageur Exp $
 
 EAPI=5
 
@@ -56,6 +56,7 @@
        libffi? ( virtual/pkgconfig )
        lldb? ( dev-lang/swig )
        !!<dev-python/configparser-3.3.0.2
+       ocaml? ( test? ( dev-ml/ounit ) )
        ${PYTHON_DEPS}"
 RDEPEND="${COMMON_DEPEND}
        clang? ( !<=sys-devel/clang-${PV}-r99 )



1.2                  sys-devel/llvm/llvm-3.6.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.2.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.2.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.2.ebuild?r1=1.1&r2=1.2

Index: llvm-3.6.2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.2.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- llvm-3.6.2.ebuild   25 Jul 2015 13:53:53 -0000      1.1
+++ llvm-3.6.2.ebuild   6 Aug 2015 12:18:45 -0000       1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.2.ebuild,v 1.1 
2015/07/25 13:53:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.2.ebuild,v 1.2 
2015/08/06 12:18:45 voyageur Exp $
 
 EAPI=5
 
@@ -38,7 +38,10 @@
        libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
        libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
-       ocaml? ( dev-lang/ocaml:0= )"
+       ocaml? (
+               dev-lang/ocaml:0=
+               dev-ml/findlib
+               dev-ml/ocaml-ctypes )"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
 DEPEND="${COMMON_DEPEND}
        app-arch/xz-utils
@@ -55,6 +58,7 @@
        doc? ( dev-python/sphinx )
        libffi? ( virtual/pkgconfig )
        !!<dev-python/configparser-3.3.0.2
+       ocaml? ( test? ( dev-ml/ounit ) )
        ${PYTHON_DEPS}"
 RDEPEND="${COMMON_DEPEND}
        clang? ( !<=sys-devel/clang-${PV}-r99



1.3                  sys-devel/llvm/llvm-3.6.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild?r1=1.2&r2=1.3

Index: llvm-3.6.0.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- llvm-3.6.0.ebuild   16 Apr 2015 11:55:18 -0000      1.2
+++ llvm-3.6.0.ebuild   6 Aug 2015 12:18:45 -0000       1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild,v 1.2 
2015/04/16 11:55:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild,v 1.3 
2015/08/06 12:18:45 voyageur Exp $
 
 EAPI=5
 
@@ -38,7 +38,10 @@
        libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
        libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
-       ocaml? ( dev-lang/ocaml:0= )"
+       ocaml? (
+               dev-lang/ocaml:0=
+               dev-ml/findlib
+               dev-ml/ocaml-ctypes )"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
 DEPEND="${COMMON_DEPEND}
        app-arch/xz-utils
@@ -54,6 +57,7 @@
        doc? ( dev-python/sphinx )
        libffi? ( virtual/pkgconfig )
        !!<dev-python/configparser-3.3.0.2
+       ocaml? ( test? ( dev-ml/ounit ) )
        ${PYTHON_DEPS}"
 RDEPEND="${COMMON_DEPEND}
        clang? ( !<=sys-devel/clang-${PV}-r99




Reply via email to