prometheanfire    14/06/05 17:58:55

  Modified:             ChangeLog
  Added:                hardened-sources-3.2.59-r3.ebuild
                        hardened-sources-3.11.7-r2.ebuild
                        hardened-sources-3.2.53-r7.ebuild
                        hardened-sources-3.2.54-r10.ebuild
                        hardened-sources-3.2.55-r8.ebuild
                        hardened-sources-3.13.6-r4.ebuild
  Log:
  more fixes for CVE-2014-3153 bug 512526
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x2471eb3e40ac5ac3)

Revision  Changes    Path
1.1057               sys-kernel/hardened-sources/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/ChangeLog?rev=1.1057&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/ChangeLog?rev=1.1057&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/ChangeLog?r1=1.1056&r2=1.1057

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v
retrieving revision 1.1056
retrieving revision 1.1057
diff -u -r1.1056 -r1.1057
--- ChangeLog   5 Jun 2014 17:24:14 -0000       1.1056
+++ ChangeLog   5 Jun 2014 17:58:55 -0000       1.1057
@@ -1,6 +1,19 @@
 # ChangeLog for sys-kernel/hardened-sources
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 
1.1056 2014/06/05 17:24:14 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 
1.1057 2014/06/05 17:58:55 prometheanfire Exp $
+
+*hardened-sources-3.2.59-r3 (05 Jun 2014)
+*hardened-sources-3.11.7-r2 (05 Jun 2014)
+*hardened-sources-3.2.55-r8 (05 Jun 2014)
+*hardened-sources-3.2.53-r7 (05 Jun 2014)
+*hardened-sources-3.2.54-r10 (05 Jun 2014)
+*hardened-sources-3.13.6-r4 (05 Jun 2014)
+
+  05 Jun 2014; Matthew Thode <prometheanf...@gentoo.org>
+  +hardened-sources-3.11.7-r2.ebuild, +hardened-sources-3.13.6-r4.ebuild,
+  +hardened-sources-3.2.53-r7.ebuild, +hardened-sources-3.2.54-r10.ebuild,
+  +hardened-sources-3.2.55-r8.ebuild, +hardened-sources-3.2.59-r3.ebuild:
+  more fixes for CVE-2014-3153 bug 512526
 
 *hardened-sources-3.14.5-r1 (05 Jun 2014)
 



1.1                  
sys-kernel/hardened-sources/hardened-sources-3.2.59-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.59-r3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.59-r3.ebuild?rev=1.1&content-type=text/plain

Index: hardened-sources-3.2.59-r3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.59-r3.ebuild,v
 1.1 2014/06/05 17:58:55 prometheanfire Exp $

EAPI="5"

ETYPE="sources"
K_WANT_GENPATCHES="base extras"
K_GENPATCHES_VER="16"
K_DEBLOB_AVAILABLE="1"

inherit kernel-2
detect_version

HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
HGPV_URI="http://dev.gentoo.org/~prometheanfire/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2";
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"

UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"

DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/";
IUSE="deblob"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND=">=sys-devel/gcc-4.5"

pkg_postinst() {
        kernel-2_pkg_postinst

        local GRADM_COMPAT="sys-apps/gradm-3.0*"

        ewarn
        ewarn "Users of grsecurity's RBAC system must ensure they are using"
        ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
        ewarn "It is strongly recommended that the following command is issued"
        ewarn "prior to booting a ${PF} kernel for the first time:"
        ewarn
        ewarn "emerge -na =${GRADM_COMPAT}"
        ewarn
}



1.1                  
sys-kernel/hardened-sources/hardened-sources-3.11.7-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.11.7-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.11.7-r2.ebuild?rev=1.1&content-type=text/plain

Index: hardened-sources-3.11.7-r2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.11.7-r2.ebuild,v
 1.1 2014/06/05 17:58:55 prometheanfire Exp $

EAPI="5"

ETYPE="sources"
K_WANT_GENPATCHES="base"
K_GENPATCHES_VER="10"
K_DEBLOB_AVAILABLE="1"

inherit kernel-2
detect_version

HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-3"
HGPV_URI="http://dev.gentoo.org/~prometheanfire/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2";
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"

UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
UNIPATCH_EXCLUDE="
        1500_XATTR_USER_PREFIX.patch
        2900_dev-root-proc-mount-fix.patch"

DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/";
IUSE="deblob"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND=">=sys-devel/gcc-4.5"

pkg_postinst() {
        kernel-2_pkg_postinst

        local GRADM_COMPAT="sys-apps/gradm-2.9.1*"

        ewarn
        ewarn "Users of grsecurity's RBAC system must ensure they are using"
        ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
        ewarn "It is strongly recommended that the following command is issued"
        ewarn "prior to booting a ${PF} kernel for the first time:"
        ewarn
        ewarn "emerge -na =${GRADM_COMPAT}"
        ewarn
}



1.1                  
sys-kernel/hardened-sources/hardened-sources-3.2.53-r7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.53-r7.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.53-r7.ebuild?rev=1.1&content-type=text/plain

Index: hardened-sources-3.2.53-r7.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.53-r7.ebuild,v
 1.1 2014/06/05 17:58:55 prometheanfire Exp $

EAPI="5"

ETYPE="sources"
K_WANT_GENPATCHES="base extras"
K_GENPATCHES_VER="16"
K_DEBLOB_AVAILABLE="1"

inherit kernel-2
detect_version

HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-8"
HGPV_URI="http://dev.gentoo.org/~prometheanfire/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2";
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"

UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"

DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/";
IUSE="deblob"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND=">=sys-devel/gcc-4.5"

pkg_postinst() {
        kernel-2_pkg_postinst

        local GRADM_COMPAT="sys-apps/gradm-3.0*"

        ewarn
        ewarn "Users of grsecurity's RBAC system must ensure they are using"
        ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
        ewarn "It is strongly recommended that the following command is issued"
        ewarn "prior to booting a ${PF} kernel for the first time:"
        ewarn
        ewarn "emerge -na =${GRADM_COMPAT}"
        ewarn
}



1.1                  
sys-kernel/hardened-sources/hardened-sources-3.2.54-r10.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.54-r10.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.54-r10.ebuild?rev=1.1&content-type=text/plain

Index: hardened-sources-3.2.54-r10.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.54-r10.ebuild,v
 1.1 2014/06/05 17:58:55 prometheanfire Exp $

EAPI="5"

ETYPE="sources"
K_WANT_GENPATCHES="base extras"
K_GENPATCHES_VER="16"
K_DEBLOB_AVAILABLE="1"

inherit kernel-2
detect_version

HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-11"
HGPV_URI="http://dev.gentoo.org/~prometheanfire/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2";
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"

UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"

DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/";
IUSE="deblob"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND=">=sys-devel/gcc-4.5"

pkg_postinst() {
        kernel-2_pkg_postinst

        local GRADM_COMPAT="sys-apps/gradm-3.0*"

        ewarn
        ewarn "Users of grsecurity's RBAC system must ensure they are using"
        ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
        ewarn "It is strongly recommended that the following command is issued"
        ewarn "prior to booting a ${PF} kernel for the first time:"
        ewarn
        ewarn "emerge -na =${GRADM_COMPAT}"
        ewarn
}



1.1                  
sys-kernel/hardened-sources/hardened-sources-3.2.55-r8.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.55-r8.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.55-r8.ebuild?rev=1.1&content-type=text/plain

Index: hardened-sources-3.2.55-r8.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.55-r8.ebuild,v
 1.1 2014/06/05 17:58:55 prometheanfire Exp $

EAPI="5"

ETYPE="sources"
K_WANT_GENPATCHES="base extras"
K_GENPATCHES_VER="16"
K_DEBLOB_AVAILABLE="1"

inherit kernel-2
detect_version

HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-9"
HGPV_URI="http://dev.gentoo.org/~prometheanfire/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2";
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"

UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"

DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/";
IUSE="deblob"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND=">=sys-devel/gcc-4.5"

pkg_postinst() {
        kernel-2_pkg_postinst

        local GRADM_COMPAT="sys-apps/gradm-3.0*"

        ewarn
        ewarn "Users of grsecurity's RBAC system must ensure they are using"
        ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
        ewarn "It is strongly recommended that the following command is issued"
        ewarn "prior to booting a ${PF} kernel for the first time:"
        ewarn
        ewarn "emerge -na =${GRADM_COMPAT}"
        ewarn
}



1.1                  
sys-kernel/hardened-sources/hardened-sources-3.13.6-r4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.13.6-r4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.13.6-r4.ebuild?rev=1.1&content-type=text/plain

Index: hardened-sources-3.13.6-r4.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.13.6-r4.ebuild,v
 1.1 2014/06/05 17:58:55 prometheanfire Exp $

EAPI="5"

ETYPE="sources"
K_WANT_GENPATCHES="base"
K_GENPATCHES_VER="9"
K_DEBLOB_AVAILABLE="1"

inherit kernel-2
detect_version

HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-5"
HGPV_URI="http://dev.gentoo.org/~prometheanfire/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2";
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"

UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
UNIPATCH_EXCLUDE="
        1500_XATTR_USER_PREFIX.patch
        2900_dev-root-proc-mount-fix.patch"

DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/";
IUSE="deblob"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND=">=sys-devel/gcc-4.5"

pkg_postinst() {
        kernel-2_pkg_postinst

        local GRADM_COMPAT="sys-apps/gradm-3.0*"

        ewarn
        ewarn "Users of grsecurity's RBAC system must ensure they are using"
        ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
        ewarn "It is strongly recommended that the following command is issued"
        ewarn "prior to booting a ${PF} kernel for the first time:"
        ewarn
        ewarn "emerge -na =${GRADM_COMPAT}"
        ewarn
}




Reply via email to