aballier    14/03/22 11:33:31

  Modified:             ChangeLog
  Added:                libcxxrt-0.0_p20140322.ebuild
  Log:
  bump a new snapshot
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
160F534A)

Revision  Changes    Path
1.22                 sys-libs/libcxxrt/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libcxxrt/ChangeLog?rev=1.22&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libcxxrt/ChangeLog?rev=1.22&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libcxxrt/ChangeLog?r1=1.21&r2=1.22

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v
retrieving revision 1.21
retrieving revision 1.22
diff -u -r1.21 -r1.22
--- ChangeLog   5 Jan 2014 11:37:17 -0000       1.21
+++ ChangeLog   22 Mar 2014 11:33:31 -0000      1.22
@@ -1,6 +1,12 @@
 # ChangeLog for sys-libs/libcxxrt
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.21 
2014/01/05 11:37:17 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.22 
2014/03/22 11:33:31 aballier Exp $
+
+*libcxxrt-0.0_p20140322 (22 Mar 2014)
+
+  22 Mar 2014; Alexis Ballier <aball...@gentoo.org>
+  +libcxxrt-0.0_p20140322.ebuild:
+  bump a new snapshot
 
   05 Jan 2014; Naohiro Aota <na...@gentoo.org> libcxxrt-0.0_p20131222.ebuild:
   Add ~x86-fbsd. #482820



1.1                  sys-libs/libcxxrt/libcxxrt-0.0_p20140322.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20140322.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20140322.ebuild?rev=1.1&content-type=text/plain

Index: libcxxrt-0.0_p20140322.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20140322.ebuild,v 1.1 
2014/03/22 11:33:31 aballier Exp $

EAPI=5

EGIT_REPO_URI="git://github.com/pathscale/libcxxrt.git"

[ "${PV%9999}" != "${PV}" ] && SCM="git-2" || SCM=""

inherit flag-o-matic toolchain-funcs portability ${SCM} multilib-minimal

DESCRIPTION="C++ Runtime from PathScale, FreeBSD and NetBSD."
HOMEPAGE="https://github.com/pathscale/libcxxrt 
http://www.pathscale.com/node/265";
if [ "${PV%9999}" = "${PV}" ] ; then
        SRC_URI="mirror://gentoo/${P}.tar.xz"
        DEPEND="app-arch/xz-utils"
else
        SRC_URI=""
fi

LICENSE="BSD-2"
SLOT="0"
if [ "${PV%9999}" = "${PV}" ] ; then
        KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
else
        KEYWORDS=""
fi
IUSE="libunwind static-libs"

RDEPEND="libunwind? ( >=sys-libs/libunwind-1.0.1-r1[static-libs?] )"
DEPEND="${RDEPEND}
        ${DEPEND}"

DOCS=( AUTHORS COPYRIGHT README )

src_prepare() {
        cp "${FILESDIR}/Makefile" src/ || die
        cp "${FILESDIR}/Makefile.test" test/Makefile || die
        multilib_copy_sources
}

multilib_src_compile() {
        # Notes: we build -nodefaultlibs to avoid linking to gcc libs.
        # libcxxrt needs: dladdr (dlopen_lib), libunwind or libgcc_s and the 
libc.
        tc-export CC CXX AR
        append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
        cd "${BUILD_DIR}/src"
        LIBS="$(dlopen_lib) -l$(usex libunwind unwind gcc_s) -lc" emake shared
        use static-libs && emake static
}

multilib_src_test() {
        cd "${BUILD_DIR}/test"
        LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
                LIBS="-L${BUILD_DIR}/src -lcxxrt -l$(usex libunwind unwind 
gcc_s) -lc" \
                emake check
}

multilib_src_install() {
        # TODO: See README. Maybe hide it in a subdir and let only libcxx know 
about
        # it. FreeBSD head installs it in /lib
        dolib.so src/${PN}.so*
        use static-libs && dolib.a src/${PN}.a
}

multilib_src_install_all() {
        einstalldocs
        insinto /usr/include/libcxxrt/
        doins src/cxxabi.h src/unwind*.h
}




Reply via email to