sdamashek    14/03/22 16:34:14

  Modified:             ChangeLog
  Added:                postfixadmin-2.3.7.ebuild
  Removed:              postfixadmin-2.3.5.ebuild postfixadmin-2.3.2.ebuild
  Log:
  Remove 2.3.5, version bump to 2.3.7 wrt bug 502270
  
  (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 
3C472B56)

Revision  Changes    Path
1.32                 www-apps/postfixadmin/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/postfixadmin/ChangeLog?rev=1.32&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/postfixadmin/ChangeLog?rev=1.32&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/postfixadmin/ChangeLog?r1=1.31&r2=1.32

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-apps/postfixadmin/ChangeLog,v
retrieving revision 1.31
retrieving revision 1.32
diff -u -r1.31 -r1.32
--- ChangeLog   3 Mar 2014 23:33:05 -0000       1.31
+++ ChangeLog   22 Mar 2014 16:34:14 -0000      1.32
@@ -1,6 +1,14 @@
 # ChangeLog for www-apps/postfixadmin
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/postfixadmin/ChangeLog,v 1.31 
2014/03/03 23:33:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/postfixadmin/ChangeLog,v 1.32 
2014/03/22 16:34:14 sdamashek Exp $
+
+*postfixadmin-2.3.7 (22 Mar 2014)
+
+  22 Mar 2014; Samuel Damashek <sdamas...@gentoo.org>
+  +postfixadmin-2.3.7.ebuild, -postfixadmin-2.3.2.ebuild,
+  -postfixadmin-2.3.5.ebuild, -postfixadmin-2.3.6.ebuild,
+  postfixadmin-2.3.6.ebuild:
+  Remove 2.3.5, version bump to 2.3.7 wrt bug 502270
 
   03 Mar 2014; Pacho Ramos <pa...@gentoo.org> postfixadmin-2.3.6.ebuild:
   amd64 stable, bug #482760



1.1                  www-apps/postfixadmin/postfixadmin-2.3.7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/postfixadmin/postfixadmin-2.3.7.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/postfixadmin/postfixadmin-2.3.7.ebuild?rev=1.1&content-type=text/plain

Index: postfixadmin-2.3.7.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/www-apps/postfixadmin/postfixadmin-2.3.7.ebuild,v 1.1 
2014/03/22 16:34:14 sdamashek Exp $

EAPI="4"

inherit user webapp

DESCRIPTION="Web Based Management tool for Postfix style virtual domains and 
users."
HOMEPAGE="http://postfixadmin.sourceforge.net";
SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"

LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+mysql postgres +vacation xmlrpc"
REQUIRED_USE="|| ( mysql postgres )"

DEPEND="vacation? ( dev-perl/DBI
                virtual/perl-MIME-Base64
                dev-perl/MIME-EncWords
                dev-perl/Email-Valid
                dev-perl/Mail-Sender
                dev-perl/log-dispatch
                dev-perl/Log-Log4perl
                dev-perl/MIME-Charset
                mysql? ( dev-perl/DBD-mysql )
                postgres? ( dev-perl/DBD-Pg ) )
        xmlrpc? ( dev-php/ZendFramework[-minimal] )
        dev-lang/php[unicode,imap,postgres?,xmlrpc?]"

RDEPEND="${DEPEND}
        virtual/httpd-php
        mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"

need_httpd_cgi

pkg_setup() {
        webapp_pkg_setup

        if use vacation; then
                enewgroup vacation
                enewuser vacation -1 -1 -1 vacation
        fi
}

src_install() {
        webapp_src_preinst

        if use vacation; then
                insinto /var/spool/vacation
                newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
                fowners vacation:vacation 
/var/spool/vacation/vacation.pl-${SLOT}
                fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
                dodoc VIRTUAL_VACATION/FILTER_README
                newdoc VIRTUAL_VACATION/INSTALL.TXT VIRTUAL_VACATION_INSTALL.TXT
                rm -r 
VIRTUAL_VACATION/{vacation.pl,INSTALL.TXT,tests,FILTER_README}
        fi

        insinto /usr/share/doc/${PF}/
        doins -r ADDITIONS

        local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
        dodoc ${docs}

        rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ 
ADDITIONS/

        insinto "${MY_HTDOCSDIR}"
        doins -r .

        webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php

        webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
        webapp_src_install
}

pkg_postinst() {
        webapp_pkg_postinst
        if use vacation; then
                # portage does not update owners of directories (feature :)
                chown vacation:vacation "${ROOT}"/var/spool/vacation/
                einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
                einfo "/var/spool/vacation/vacation.pl-${SLOT}"
                ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},}
        fi
}

pkg_postrm() {
        # Make sure we don't leave broken vacation.pl symlink
        find -L "${ROOT}"/var/spool/vacation/ -type l -delete
        if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl ]] &&
                path_exists "${ROOT}"/var/spool/vacation/vacation.pl-*; then
                ln -s $(LC_ALL=C ls -1 /var/spool/vacation/vacation.pl-* | tail 
-n1) \
                        "${ROOT}"/var/spool/vacation/vacation.pl
                ewarn "/var/spool/vacation/vacation.pl was updated to point on 
most"
                ewarn "recent verion, but please, do your own checks"
        fi
}




Reply via email to